LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-11-2005, 10:04 PM   #1
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Rep: Reputation: 15
emacs - keep changes in settings


Every time I start Emacs, all the settings
(like paren matching highlightning, fly-spell mode, which dictionary to use...)
I have made the last time are deleted and
changed back to default settings... how could I keep the changes?

I have also tried to change setting as root, but no change are kept when
I start Emacs again.

Can anyone tell me how to keep settings?

I have tried to find out by googling wihout luck.
 
Old 04-11-2005, 10:32 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: earth
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Once done with your changes select the option
"Save changes" from the options-menu.

If you're not running emacs in X and don't like
to use the menu try
Meta-X customize-save-customized


Cheers,
Tink

Last edited by Tinkster; 04-11-2005 at 10:35 PM.
 
Old 04-12-2005, 08:15 AM   #3
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
Thanks TInkstar


Now I can keep settings like 'paren matching highlighttning'

Still, I cannot figure out how to save settings like
'set-language-environment' and which dictionary to use for flyspell-mode.

When I open emacs, I want emacs to have
set-language-environment': latin-1
flyspell-mode (with different dictionary from english)

Does anyone know how I can do that?
 
Old 04-12-2005, 02:31 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: earth
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917Reputation: 917
Can't set that from within emacs (well, you can edit
the file in question using emacs, I suppose) ... you'll
have to edit your ~/.emacs file manually ... for the
appropriate settings have a google ...

something like
'(set-language-environment "latin-1")
whould work for instance...


Cheers,
Tink
 
Old 04-12-2005, 06:36 PM   #5
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
Thanks for your advice, Tinkster. It's a great help.

Well I have added the foolllowing lines in ~/.emacs:

Code:
(set-language-environment "Latin-1")
(add-hook 'LaTeX-mode-hook 'flyspell-mode)
(setq LaTex-mode-hook
       '(lambda () 
       (setq ispell-personal-dictionary "~/.ispell-dico-perso")
       (ispell-change-dictionary "dansk")
       ))
It's succeeded to have Latin-1 as default language environment, but
emacs doesn't start flyspell-mode automatically when I open .tex files...
and default dictionary is still English...
Can you maybe see what I am doing wrong?

Thanks in advance...
 
Old 04-13-2005, 10:00 AM   #6
kentri9
Member
 
Registered: Aug 2004
Distribution: Fedora Core 2
Posts: 39

Original Poster
Rep: Reputation: 15
I have resolved the problem:

Code:
;; Latin-1 is compatible with windows/other linux's
(set-language-environment "Latin-1")

;;flyspell-mode with danish dictionary starts up 
;;automatically when a .tex file is opened
(setq latex-mode-hook
      (lambda ()
	(flyspell-mode 1)
	(set (make-local-variable 'ispell-personal-dictionary) "~/.ispell-dico-perso")
	(ispell-change-dictionary "dansk")
	))
I had misspelled latex as LaTex....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
where is the .emacs file in the emacs source code tarball? aizkorri Programming 2 01-13-2007 03:05 PM
Emacs ignoring X server resource settings abovett Fedora 0 08-19-2005 07:09 PM
emacs not responding to .emacs file in Mandriva 2005 LE. Please help LaptopLinux Mandriva 1 06-08-2005 09:36 AM
Why can't I change Emacs color settings? SuperRob2000 Linux - Software 3 08-27-2004 08:07 AM
edb (emacs database) won't open file - emacs 20 & 21 tip184 Linux - Software 0 04-03-2004 08:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration