LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-25-2009, 01:51 AM   #1
PNReddi
LQ Newbie
 
Registered: Feb 2009
Posts: 1

Rep: Reputation: 0
Post EAP methods failing


Hi all,
I am working on 802.11 WLAN sation which supports the WPA-EAP methods.
I am working on the Embedded platform for bringing up the EAP methods(same is working on the desktop platform).
I have installed freeradius-1.0.2, openssl-0.9.8j,wpa_supplicant-0.5.5.
After sending EAP response packet of identifer 6 with length 372,Authenticator is sending EAP Failure packet thus stoppping the transmission.

Attached is the radius server log

rad_check_password: Found Auth-Type EAP
auth: type "EAP"
Processing the authenticate section of radiusd.conf
modcall: entering group authenticate for request 214
rlm_eap: Request found, released from the list
rlm_eap: EAP/ttls
rlm_eap: processing type ttls
rlm_eap_ttls: Authenticate
rlm_eap_tls: processing TLS
eaptls_verify returned 7
rlm_eap_tls: Done initial handshake
rlm_eap_tls: <<< TLS 1.0 Handshake [length 0106], ClientKeyExchange
TLS_accept: SSLv3 read client key exchange A
rlm_eap_tls: <<< TLS 1.0 ChangeCipherSpec [length 0001]
rlm_eap_tls: >>> TLS 1.0 Alert [length 0002], fatal bad_record_mac
TLS Alert write:fatal:bad record mac
TLS_accept: Need to read more data: SSLv3 read certificate verify A
rlm_eap: SSL error error:1408F119:SSL routines:SSL3_GET_RECORD:decryption failed or bad record mac
rlm_eap_tls: SSL_read failed in a system call (-1), TLS session fails.
eaptls_process returned 13
rlm_eap: Freeing handler
modcall[authenticate]: module "eap" returns reject for request 214
modcall: leaving group authenticate (returns reject) for request 214
auth: Failed to validate the user.
Delaying request 214 for 1 seconds
Finished request 214
Going to the next request
--- Walking the entire request list ---
Waking up in 1 seconds...
--- Walking the entire request list ---
Waking up in 1 seconds...
--- Walking the entire request list ---
Sending Access-Reject of id 0 to 192.168.2.13 port 2048
EAP-Message = 0x04060004
Message-Authenticator = 0x00000000000000000000000000000000


can any one help me to solve this issue.

-Thanks in Advance
NarayanaReddy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compiz failing, GLcore.so failing to load Schrambo Linux - Desktop 4 02-23-2008 07:13 PM
EAP and RADIUS and W2K metallica1973 Linux - Networking 7 09-21-2006 08:54 PM
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 08:34 AM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 03:37 PM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 07:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration