LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-22-2014, 09:05 PM   #1
Changes
Member
 
Registered: Oct 2008
Posts: 190

Rep: Reputation: 16
Dependency issues with nvidia-tegra package


I'm trying to get Lubuntu 14.04 (armhf version) running on a Toshiba AC100, which involves installing the proprietary drivers from nVidia.

Now, previous versions of (L)Ubuntu had the nvidia-tegra package easily installable in preferences->software&updates, but if I try it now it says no drivers available. So I went looking for the nvidia-tegra deb for Trusty and found it here. Problem is, if I try to install it it complains about a "xorg-video-abi-14" missing dependency.

If I try apt-get install xorg-video-abi-14 it says it's unavailable but referred to by another package. I went looking and found this according to which it's supposed to be provided by xserver-xorg-core, but that's for amd64 systems and in any case the version of xserver-xorg-core I have in my install (2:1.15.1-0ubuntu2) doesn't seem to provide it.

Getting the proprietary driver running is paramount, as the graphics are really slow on the OSS one, to the point I'll downgrade to 13.10 or earlier before making do without. I'd much rather get it working in 14.04 though, so what do I do?

Last edited by Changes; 05-22-2014 at 09:10 PM.
 
Old 05-25-2014, 01:58 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, Debian 12 & Devuan
Posts: 9,491
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Hi:

A few ideas here-

Try looking in Synaptic Package Manager and see if "xorg-video-abi-14" is there and have Synaptic install it.

Look in the "Trusty" repository--

Is your Toshibia 32-bit? or 64-bit?

Run this to be sure-
Code:
cat /proc/cpuinfo
http://packages.ubuntu.com/trusty/
https://packages.debian.org/sid/xorg-video-abi-14
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Nvidia's 3D Tegra driver now open sourced LXer Syndicated Linux News 0 04-07-2013 12:15 AM
LXer: NVIDIA: New Features, Support For Linux For Tegra LXer Syndicated Linux News 0 11-24-2012 07:41 PM
LXer: NVIDIA Releases Tegra Hardfp Pack LXer Syndicated Linux News 0 05-06-2012 10:00 AM
LXer: Plasma Active on NVidia Tegra 2 LXer Syndicated Linux News 0 10-28-2011 12:00 AM
Future package dependency resolving tools/issues? MasterC Red Hat 7 08-30-2003 09:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration