LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-07-2018, 07:15 PM   #1
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,160

Rep: Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991
Debian Stretch - disable any authentication on SNMP


I have a problem using a HP network scanner on Debian Stretch. Exactly the error I have is reported and solved on some forum.

The recommended solution is to set the SNMP community string to public for read and write.

Unfortunately Debian Stretch installs SNMPv3 which has a much more developed security model.

I don't need that, I don't want that. In the snmpd config file the old community strings cannot be configured anymore.

Now every web page about Debian states that SNMPv3 can be used in a number of ways depending on the “securityLevel” configuration parameter. One of them is
Code:
noAuthNoPriv – No authorisation and no encryption, basically no security at all!
Which is exactly what I want. But NONE of those pages actually tell HOW to set the securityLevel to noAuthNoProv

So how do I totally disable security in SNMP?
Or alternatively: how do I emulate SNMPv2 behaviour and have the read and write community set to public?

jlinkels
 
Old 06-07-2018, 08:49 PM   #2
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,160

Original Poster
Rep: Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991
Follow-up: It seems that the strings to set the community SNMPv2 styles are:
Code:
rocommunity public
rwcommunity public
Unfortunately I cannot test if it works. Thing is, I am trying to get a networked scanner to work using libsane-hpaio. The scanner reports "Device busy". It was reported that this error could be worked around by setting the write community to public.

Eventually I set up an SSH tunnel to the scanner and tried to scan through the web interface. To my surprise the scanner really produces a "Device busy" error. No sane or hpaio involved.

Unfortunately this scanner is 9000 km away from where I am and in a different time zone. So I can't ask anyone to power cycle the scanner.

This problem is especially nagging because when I was next to the scanner with my laptop running Debian Jessie, scanning over the network worked perfectly well. Now I try to do this from a headless server running Stretch, no DE install. So the conditions are very different.

Once the scanner is not busy anymore and the same error persists, I continue troubleshooting. I seems complicated, sane-backend, SNMP....

jlinkels
 
Old 06-08-2018, 08:49 AM   #3
jlinkels
LQ Guru
 
Registered: Oct 2003
Location: Bonaire, Leeuwarden
Distribution: Debian /Jessie/Stretch/Sid, Linux Mint DE
Posts: 5,160

Original Poster
Rep: Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991Reputation: 991
Follow-up:

In the mentioned scanner problem it was not needed to grant write access to the community. As a matter of fact without any modification to SNMP the libsane-hpaio worked well.

The problem was caused by the state of the scanner itself which reported to be busy. The reason is yet unknown. Someone has corrected that but did not report.

It is worth to mention though that libsane-hpaio produced hundreds of SNMP error messages about missings MIBs before SNMP was installed. Installation of libsane-hpaio did not pull in SNMP as dependency. I am not sure whether libsane-hpaio would have worked without SNMP.

For the record, this is what needs to be installed for SNMP and get rid of the MIB error messages.
Code:
apt-get install snmp snmpd snmp-mibs-downloader
service snmpd restart
jlinkels
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Installing Php 7.2 On Debian 8 Jessie And Debian 9 Stretch LXer Syndicated Linux News 0 03-09-2018 10:12 AM
[SOLVED] How to disable system bell in Debian 9 Stretch Xfce? linustalman Debian 5 06-29-2017 01:01 PM
LXer: How to upgrade Debian 8 Jessie to Debian 9 Stretch LXer Syndicated Linux News 0 06-16-2017 02:11 AM
How to disable snmp service on T3. UltraSoul Solaris / OpenSolaris 4 03-19-2007 02:48 AM
Nagios and snmp authentication ebel.velda Linux - Software 1 02-28-2007 09:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration