LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-12-2004, 05:44 PM   #1
georgekm
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Rep: Reputation: 0
CUPS = only blank pages


I use Vectorlinux 4.0 (2.4.27) on a PIII laptop and am trying to make my Samsung ML-1750 (Postscript) laser printer to work. I have CUPS 1.1.20 installed along with foomatic and all the relevant stuff as part of a package provided by the guys at VectorLinux (printing-stable-1).

This config used to work very well up until a few weeks ago. I don't know what exactly happened (installing gimp-print for my photo printer maybe?) but since my printer only spits out blank pages if I try to print the test page, and does nothing at all when I try OpenOffice or Firebird. It used to work with everything!

I tested other versions of CUPS, removing everything and re-installing but no luck. Strangely enough, initially at least I could print a .ps file via lp, but now after all the experiments this is failing as well.

Help someone, I am getting desperate! Is there a log somewhere that may be of help? The only thing I have found is that the CUPS GUI job log marks the test pages I send as aborted.


Any help will be greatly appreciated!

George
 
Old 11-12-2004, 06:43 PM   #2
georgekm
LQ Newbie
 
Registered: Nov 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Some extra info

Just in case it helps, here is what /var/log/cups/error_log reports when you send a test page to the printer:

I [13/Nov/2004:00:31:47 -0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=8755)
I [13/Nov/2004:00:31:54 -0800] Started "/usr/lib/cups/cgi-bin/printers.cgi" (pid=8756)
I [13/Nov/2004:00:31:54 -0800] Adding start banner page "none" to job 8.
I [13/Nov/2004:00:31:54 -0800] Adding end banner page "none" to job 8.
I [13/Nov/2004:00:31:54 -0800] Job 8 queued on 'Samsung' by 'root'.
I [13/Nov/2004:00:31:54 -0800] Started filter /usr/lib/cups/filter/pstops (PID 8757) for job 8.
I [13/Nov/2004:00:31:54 -0800] Started filter /usr/lib/cups/filter/foomatic-rip (PID 8758) for job 8.
I [13/Nov/2004:00:31:55 -0800] Started backend /usr/lib/cups/backend/usb (PID 8759) for job 8.
W [13/Nov/2004:00:31:55 -0800] [Job 8] Media tray empty!

.... which by the way is not empty and is not reported as such by the GUI...

George
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 1 printing blank pages Rollie Peck Linux - Newbie 2 08-21-2005 07:39 PM
php 5.0 blank pages (fedora) spacy2003 Linux - Software 2 02-06-2005 01:34 PM
Printing Blank Pages Flat_Tire_ Slackware 11 11-28-2002 03:41 AM
Man pages blank ? redgore Linux - General 2 09-07-2002 05:05 AM
Blank pages before and after printing bspicer Linux - General 0 05-13-2002 02:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration