LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-07-2005, 09:41 AM   #1
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Rep: Reputation: 30
Changing resolution of CLI


Hi, I'm using FC3 on a Toshiba laptop, and I want to change the resolution of the CLI.

Under Xfree86 there was an option to change it, there was a section defined as:

80x25
80x30
80x40

etc, but in xorg.conf I can't find it.

Basically when my system boots the text is huge, and it is annoying when I drop out of X to the CLI and I feel as if I'm in playschool with all of the huge letters.

Is it possible to fix this easily?


Thanks in advance,
Morrolan
 
Old 03-07-2005, 11:03 AM   #2
youngtom
Member
 
Registered: Feb 2005
Location: Rio de Janerio
Distribution: suse 9.1, suse 9.2, redhat enterprise, ubuntu, kubuntu
Posts: 104

Rep: Reputation: 15
If you are in an xterm, then you can change the font size with <cntrl><right-right-click>
 
Old 03-08-2005, 07:19 AM   #3
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Original Poster
Rep: Reputation: 30
No it's not an xterm, I'm talking bootup and CLI - i.e. when I don't login to a GUI.

Like I said, it was an easy enough problem to fix when everything was XFree86, but since the move to x.org the config file seems to have shrunk drastically.
 
Old 03-08-2005, 09:23 AM   #4
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 60
I found a table on the net which is pretty handy for cli resolutions.
Code:
Color depth      |   640x480      800x600      1024x768      1280x1024
256        (8bit)|     769          771           773           775
32000     (15bit)|     784          787           790           793
65000     (16bit)|     785          788           791           794
16.7 Mill.(24bit)|     786          789           792           795
The higher numbers are smaller text.

Just add a selection to the end of your kernel in the grub.conf with the vga of your choice like this....
Code:
title Fedora Core
	root (hd1,1)
	kernel /boot/vmlinuz-2.6.10-1.770_FC3 ro root=LABEL=/ rhgb quiet vga=790
	initrd /boot/initrd-2.6.10-1.770_FC3.img
 
Old 03-08-2005, 01:09 PM   #5
harken
Member
 
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
Here's something from /Documentation/svga.txt file from the Linux kernel source:
Quote:
The video mode to be used is selected by a kernel parameter which can be
specified in the kernel Makefile (the SVGA_MODE=... line) or by the "vga=..."
option of LILO (or some other boot loader you use) or by the "vidmode" utility
(present in standard Linux utility packages). You can use the following values
of this parameter:

NORMAL_VGA - Standard 80x25 mode available on all display adapters.

EXTENDED_VGA - Standard 8-pixel font mode: 80x43 on EGA, 80x50 on VGA.

ASK_VGA - Display a video mode menu upon startup (see below).

0..35 - Menu item number (when you have used the menu to view the list of
modes available on your adapter, you can specify the menu item you want
to use). 0..9 correspond to "0".."9", 10..35 to "a".."z". Warning: the
mode list displayed may vary as the kernel version changes, because the
modes are listed in a "first detected -- first displayed" manner. It's
better to use absolute mode numbers instead.

0x.... - Hexadecimal video mode ID (also displayed on the menu, see below
for exact meaning of the ID). Warning: rdev and LILO don't support
hexadecimal numbers -- you have to convert it to decimal manually.
Combined with what homey provided I hope it'll help.
 
Old 03-08-2005, 02:47 PM   #6
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Original Poster
Rep: Reputation: 30
That looks like what I need, I'll give it a try as soon as I can and let you know!

Cheers!


Morrolan
 
Old 03-09-2005, 06:42 AM   #7
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Original Poster
Rep: Reputation: 30
Prelimary test failed - I set it to 790 and it still booted in what looks like 769 - I will try some other lesser modes tonight.
 
Old 03-09-2005, 10:20 AM   #8
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 60
I wonder if you have the video card and monitor setup properly. If it was my machine, I would run yum update to get the lastest driver info onboard. Then I would run as root user the command:
system-config-display .
 
Old 03-10-2005, 07:10 AM   #9
morrolan
Member
 
Registered: Sep 2003
Location: Manchester UK
Posts: 264

Original Poster
Rep: Reputation: 30
The card and monitor are setup fine, I did what you prescribed only last week.

I have solved it now - it obviously didn't like 32,000 colours before the graphics card had been initialised, but setting it to "773" (1024x768x256) works fine.

I did as homey recommended and simply added the parameter onto the end of the kernel line in grub.

One question - will a kernel update detect that, or will I have to add that each time I update my kernel?
 
Old 03-10-2005, 10:30 AM   #10
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 60
A kernel update may fix the problem but I don't think it will put any extra info like that in the grub.conf.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem changing the video adapter setting and changing the screen resolution habiblove Linux - General 3 02-18-2006 06:10 PM
changing gui from cli twistedrhymes Linux - Newbie 3 06-14-2005 03:44 AM
Need help changing resolution jtdwyer Fedora 2 05-20-2005 01:12 AM
Changing Console (CLI) Resolution overbored Linux - Software 0 09-07-2004 09:33 PM
CLI changing of Timezone bretthoward Linux - General 0 08-04-2001 09:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration