LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-01-2005, 03:28 PM   #1
karhu
LQ Newbie
 
Registered: Jun 2005
Location: Finland (far away from home -> PERU)
Distribution: Fedora Core 3
Posts: 24

Rep: Reputation: 16
cdrecord: Cannot open SCSI driver.


Hi, I'm trying to burn a CD with songs that are already in wav format.
(my cdrw is reading CDs and DVDs fine. I got the songs ripping an audio CD using transcode)


to burn a CD I executed the command:

[root@localhost ~]# nice --18 cdrecord dev=1,0,0 speed=1 fs=4m -v -eject -audio tract*wav

but nothing happens. The results of the command are:

Code:
.
.
.
scsidev: '1,0,0'
scsibus: 1 target: 0 lun: 0
cdrecord: Success. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
then, if I execute:

[root@localhost ~]# cdrecord -scanbus

the results are:

Code:
.
.
.
scsidev: 'ATA'
devname: 'ATA'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version (schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c1.83 04/05/20 Copyright 1997 J. Schilling').
scsibus1:
        1,0,0   100) 'HL-DT-ST' 'DVDRAM GSA-4163B' 'A103' Removable CD-ROM
        1,1,0   101) *
        1,2,0   102) *
        1,3,0   103) *
        1,4,0   104) *
        1,5,0   105) *
        1,6,0   106) *
        1,7,0   107) *
I get the same error message, even after I modified the file /etc/fstab (adding "rw" to the line where my /dev/hdc is: )

the contents of my /etc/fstab now are:

Code:
.
.
.
/dev/hdc /media/cdrecorder auto pamconsole, fscontext=system_ubject_r:removable_t,rw ,exec,noauto, managed 0 0

Can somebody help me with this problem ?

thanks in advance.


ps. afterwards I also modified the file /etc/grub.conf, by adding :

hdc=ide-sci

in the same line that refers to the kernel. so, now it reads:

Code:
# grub.conf generated by anaconda
.
.
.
title Fedora Core (2.6.9-1.667)
	root (hd0,0)
	kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 hdc=ide-sci rhgb quiet
	initrd /initrd-2.6.9-1.667.img
but the error message remains the same and I still cannot burn any CDs

my distro is: Fedora Core 3


kind regards,



Last edited by karhu; 08-03-2005 at 02:05 AM.
 
Old 08-01-2005, 03:33 PM   #2
karhu
LQ Newbie
 
Registered: Jun 2005
Location: Finland (far away from home -> PERU)
Distribution: Fedora Core 3
Posts: 24

Original Poster
Rep: Reputation: 16
Hi,

I had to restore my /etc/fstab to its original content (I guess /dev/hdc is set as read only?):

Code:
/dev/hdc /media/cdrecorder auto pamconsole, fscontext=system_ubject_r:removable_t, exec,noauto, managed 0 0

because after I modified it (as mentioned in my previous post): /dev/hdc as: rw

Code:
/dev/hdc /media/cdrecorder auto pamconsole, fscontext=system_ubject_r:removable_t,rw ,exec,noauto, managed 0 0

I got the message: "/etc/fstab line 9 in bad format"
everytime I rebooted the computer.



Last edited by karhu; 08-03-2005 at 01:57 AM.
 
Old 08-01-2005, 04:02 PM   #3
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Try changing it from this:
[root@localhost ~]# nice -18 cdrecord dev=1,0,0 speed=1 fs=4m -v -eject -audio tract*wav
to this:
[root@localhost ~]# nice -18 cdrecord dev=/dev/hdc speed=1 fs=4m -v -eject -audio tract*wav

KC
 
Old 08-02-2005, 02:33 AM   #4
karhu
LQ Newbie
 
Registered: Jun 2005
Location: Finland (far away from home -> PERU)
Distribution: Fedora Core 3
Posts: 24

Original Poster
Rep: Reputation: 16
many thanks!

I'm at work now, but I will try your solution as soon as I get home.




btw,

any ideas about what is wrong with my /etc/fstab ?

how can I modify my /etc/fstab to set the cdrom as rw? )



by the moment, I had to leave the file as it was originally:

Code:
/dev/hdc /media/cdrecorder auto pamconsole, fscontext=system_ubject_r:removable_t, exec,noauto, managed 0 0

so now /dev/hdc is read only, because when I modified the file to this:

Code:
/dev/hdc /media/cdrecorder auto pamconsole, fscontext=system_ubject_r:removable_t,rw ,exec,noauto, managed 0 0
I received the error I commented in my second post.




thanks in advance,

Last edited by karhu; 08-03-2005 at 01:57 AM.
 
Old 08-02-2005, 02:45 AM   #5
kencaz
Senior Member
 
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
Looks like your using "Supermount"... I have a CDR and CDRW and in my fstab both are mounted "ro" ... cdrocord, kb3, or other burning applications will make the appropriate changes needed to burn cd's...

Change it back to it's original configuration...

KC
 
Old 08-03-2005, 02:02 AM   #6
karhu
LQ Newbie
 
Registered: Jun 2005
Location: Finland (far away from home -> PERU)
Distribution: Fedora Core 3
Posts: 24

Original Poster
Rep: Reputation: 16
many thanks kencaz!!!

finally I could burn a CD



for all those with the same problem as me:

- do not change /etc/fstab

- do not change /etc/grub.conf


- as Kencaz wrote: the solution is to give cdrecord the full path towards the cdrw. (you can get the right path towards your cdrw by looking at /etc/fstab - "emacs /etc/fstab")

nice --18 cdrecord dev=/dev/hdc speed=1 fs=4m -v -eject -audio tract*wav





regards,

Last edited by karhu; 08-03-2005 at 02:04 AM.
 
Old 08-18-2005, 10:16 PM   #7
aldimond
LQ Newbie
 
Registered: Aug 2005
Distribution: Technically Gentoo is a "meta-distribution", so I'll call my distro "OMGALSDISTROOMGGNULINUX"
Posts: 1

Rep: Reputation: 0
For all y'all talking about /etc/fstab, there's a clear and simple reason you shouldn't touch fstab for this: /etc/fstab is about mounting filesystems. That is, you'll have a line in your fstab saying that the filesystem on the device /dev/hdc should be mounted at /media/cdrecorder when you do decide to mount it (or when it automounts, if you do the automounting thing), and also specifies some options related to this mounting.

(For those that don't know, mounting a filesystem means taking information from a device and allowing it to be accessed through your directory structure. If you had nothing in your /mnt/fstab file and you wanted to use a data cd you'd have to issue a "mount" command specifying the device name of your cdrom drive (/dev/hdc), the location to which you want it mounted (/media/cdrecorder), and information passed as commandline arguments like the filesystem type and whether you can write to the device using commands like "mkdir" and "touch" when you access it via /media/cdrecorder. If you have information in your /etc/fstab file, all you have to do is type a simple "mount /medai/cdrecorder" and that stuff you don't want to memorize is automatically applied for you. For those not familiar with mounting, if you manually mount a filesystem on removable media you have to unmount it ("umount /media/cdrecorder") before you eject the disk. Unless you have an automounter that does that for you... I've never used an automounter so I don't know anything about 'em)

To burn a CD, you don't mount a filesystem. Therefore nothing in /etc/fstab has anything to do with CD burning. Same is true when you play an audio CD. The tipoff is that instead of specifying /media/cdrecorder to cdrecord you are specifying /dev/hdc. In fact, if a filesystem on a drive is mounted and you try to record or play a cd on that drive it will fail because the device is already being used for a filesystem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cdrecord but no SCSI? zecodela Linux - Software 5 10-16-2004 06:59 AM
Problem in cd recording, cannot open SCSI driver saulijk Linux - Software 0 10-12-2004 02:13 AM
help: cdrecord does not work due to "Cannot open SCSI driver" parv Linux - Software 2 09-21-2004 09:54 PM
USB external CD-RW: cdrecord "cannot open SCSI driver" Avatar Linux - Hardware 10 04-07-2004 12:00 PM
cdrecord (scsi emulation) HwzrHlslndr Linux - Software 17 01-11-2003 08:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration