LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-17-2004, 08:16 PM   #1
netquest1
Member
 
Registered: Aug 2003
Distribution: Gentoo 1.4, Slackware 9, Suse 9.0
Posts: 35

Rep: Reputation: 15
Apache wont start in Gentoo


I recently installed Gentoo Linux 1.4. I just installed apache and followed the necessary steps to do so included in the Linux desktop Configuration Guid provoded from Gentoo. these are the steps that i took:
emerge apache mod_php
rc-update add apache2 default
/etc/init.d/apache2 start

and i got this error when starting apache:
apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName [ !! ]

I think i fixed this error by removing the # comment tag infront of the line:
ServerName localhost
in the apache2.conf file but when i try to start it, i get this:
* Starting apache2... [ !! ]
and i get this error in the error_log file:
[Tue Feb 17 17:12:41 2004] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "box1"
Configuration Failed

any ideas on how i can fix this so that apache will start correctly. because right now i cant get it to start at all.

thanks!
 
Old 02-17-2004, 09:27 PM   #2
retep
Member
 
Registered: Sep 2003
Distribution: RedHat/Debian
Posts: 50

Rep: Reputation: 15
Try:

a) if you're not using mod_unique_id just comment out it's LoadModule
or b) grep for "box1" in the apache conf dir(s) and see if it's set in there anywhere.
 
Old 02-17-2004, 10:13 PM   #3
netquest1
Member
 
Registered: Aug 2003
Distribution: Gentoo 1.4, Slackware 9, Suse 9.0
Posts: 35

Original Poster
Rep: Reputation: 15
thanks i got it to work. i used this fix:
addd ip and box1 to /etc/hosts and it workd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache wont start stlyz3 Linux - Software 14 05-30-2005 02:25 PM
Apache 2 wont start on Gentoo 2004.1 kofrad Linux - Software 2 11-14-2004 08:11 AM
apache wont start mrgeoff Linux - Software 8 10-27-2004 03:46 PM
apache 1.3 wont start on redhat 7.3 buddamonk Linux - Software 3 03-03-2004 11:31 PM
Xfree86 acts as if installed but wont start on gentoo bling bling Linux - Software 1 11-19-2003 03:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration