LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-14-2005, 01:37 PM   #1
Jukas
Member
 
Registered: Mar 2005
Posts: 141

Rep: Reputation: 15
Apache Issue


I'm running Apache 1.3.33 on a Debian box hosting both public_html for local users (currently just myself and a friend) as well as a couple of my domains using Virtual Host.

What's strange is that directory indexing works fine for local users at domain.com/~user/ but won't work for domains using Virtual Host. I get a forbidden message in the browser and see the following in my logs:

[Thu Jul 14 10:36:04 2005] [error] [client *.*.*.*] Directory index forbidden by rule: /home/user/domain.com/images/

But I can't find the rule that's preventing directory indexing. Anyone clue me in?
 
Old 07-14-2005, 01:52 PM   #2
barghota
Member
 
Registered: Jul 2003
Location: Cairo, Egypt
Distribution: CentOS, RHEL, Debian, FreeBSD
Posts: 94

Rep: Reputation: 38
I didn't try apache on Debian, but i issued a problem on mandriva 2005 just like ur problem

i edited the vhosts (on mandriva its /etc/httpd/conf/vhosts/Vhosts.conf, on redhat its /etc/conf/httpd.conf) so figure out which one u got). I added the directive :

Code:
NameVirtualHost 192.168.1.3

<VirtualHost 192.168.1.3>
ServerName (your virtual host server name)
DocumentRoot (the directory containing the index file)
<Directory (the parent directory of the directory containing the index file)>
       Allow from all
       Options Indexes Includes
</Directory>
</VirtualHost>
and it worked fine.

Hope this would help.
 
Old 07-14-2005, 02:18 PM   #3
Jukas
Member
 
Registered: Mar 2005
Posts: 141

Original Poster
Rep: Reputation: 15
It seems I can enable it either in the Virtual host statement or with .htaccess but what I'm wondering is if there is a way to enable it globally for all virtual hosts and then I can let people deny it for specific directories with .htaccess
 
Old 07-14-2005, 02:33 PM   #4
barghota
Member
 
Registered: Jul 2003
Location: Cairo, Egypt
Distribution: CentOS, RHEL, Debian, FreeBSD
Posts: 94

Rep: Reputation: 38
you will have to make this for each virtual host

Code:
<Directory (the parent directory of the directory containing the index file)>
       Allow from all
       Options Indexes Includes
       AllowOverride AuthConfig
</Directory>
which will read the .htaccess in the server document root, each user will send u the .htaccess file and u have to put it under his document root

Last edited by barghota; 07-14-2005 at 02:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache MaxClients Issue SiLiCoN *BSD 6 12-08-2005 02:14 PM
ftp/apache issue Odins_Son Linux - General 1 08-17-2005 06:29 AM
Is this an apache issue? opsraja Linux - Networking 1 03-03-2005 12:03 AM
apache issue... Robin01 Linux - Newbie 3 09-21-2003 07:12 AM
new apache install issue Robin01 Linux - Newbie 1 09-19-2003 04:56 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration