LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-09-2006, 01:44 PM   #1
lezek
Member
 
Registered: Apr 2003
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
Apache HTTPd with mod_perl *and* mod_php


My ISP informs me that they do not have mod_perl installed because "A server can only be configured to run mod php or mod perl" (emphasis added).

As far as I am concerned, this is contemptible rubbish and it has put me into serious doubt regarding the competence of said ISP. But, thinking about it, I can't recall a time when I have ever actually had both mod_perl and mod_php working at the same time (I used to exclusively use PHP and now I exclusively use Perl ). That said, I can't find anything to the effect that the two are mutually exclusive on the web.

So, before I jump to conclusions and get angry about it, can anyone confirm that mod_php and mod_perl are or aren't mutually exclusive, or perhaps come up with a reason why my ISP might be labouring under an understandable misapprehension?
 
Old 02-09-2006, 03:10 PM   #2
phil.d.g
Senior Member
 
Registered: Oct 2004
Posts: 1,272

Rep: Reputation: 153Reputation: 153
I had them installed side-by-side at one point, both as dynamic modules.
 
Old 02-09-2006, 03:11 PM   #3
lezek
Member
 
Registered: Apr 2003
Distribution: Gentoo
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks. I did suspect they were talking complete rubbish.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is Httpd version 2.0.52 embedded mod_perl? lewkh Fedora 1 05-12-2005 09:59 PM
httpd: module "mod_perl.c" is not compatible with this version of Apache davidlarsen Linux - Software 2 08-25-2004 08:57 AM
mod_perl woes: upgrade or downgrade httpd? toddcurry Linux - Software 0 07-09-2004 01:42 PM
apache, httpd.conf, mod_perl ziggie216 Linux - Software 1 12-18-2003 01:19 AM
httpd.conf and mod_perl joshf Linux - Software 6 07-16-2003 12:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration