LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-02-2005, 06:16 PM   #1
cain_eve
Member
 
Registered: Nov 2004
Posts: 93

Rep: Reputation: 15
about glib


Hi all,
I am using redhat9 and the original glib on it is glib1.20. I download glib2.60 and install it.
The problem is I do not delete glib1.20 which is setup by rpm. 2.60 is intalled from source code. So how to let the system know that the glib have been updated to 2.60. I think is pkg-config but I don't know how to use it.
please step by step

Thanks

cain
 
Old 03-03-2005, 11:41 AM   #2
aeichner
LQ Newbie
 
Registered: Apr 2004
Location: Zittau, Germany
Distribution: Debian GNU/Linux (testing-release)
Posts: 9

Rep: Reputation: 0
Simply install both versions. Programs written for glib-2.0 (mostly gtk-2 programs) will use /usr/lib/libglib-2.0*.so and software for the old versions (older gtk programs) will use /usr/lib/libglib-1.2*.so

The pkg-config program is for compiling purposes. If glib-2 is installed, pkg-config tells you where to find header and library files. This is used by Makefile's when compiling gtk-software

PS: Didn't RedHat distribute glib-2 and gtk-2 as ready-to-use rpm's?
 
Old 03-03-2005, 12:49 PM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
When compiling from source, do
$./configure --prefix=/usr
 
Old 03-03-2005, 09:34 PM   #4
cain_eve
Member
 
Registered: Nov 2004
Posts: 93

Original Poster
Rep: Reputation: 15
oh thanks
I have install glib2.6 atk1.9 but there seems to have bug in pango1.8 so I can't install gtk2.6 yet
--prefix=/usr is the right thing to fix the problem
yes RedHat distribute glib-2 and gtk-2 as ready-to-use rpm's
but glib is glib2-2.2.1 at present.
gtk is also low version
thanks
and I know what is pkg-config now


cain
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 06:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration