LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 01-16-2010, 07:04 PM   #1
lightsabersetc
LQ Newbie
 
Registered: Jan 2010
Posts: 4

Rep: Reputation: 0
Question Trying to create wireless access point, cannot get adapter to transmit ESSID


Hey everyone, I have been working on this for a while now and am absolutely stumped. Basically, what i am attempting to do is make my ubuntu box into a gateway for my network. I have everything working thru hard wire, but I simply cant get the wireless to work. No matter what I do, I cannot get my wireless card to transmit an essid and allow nodes to connect. I have tried assigning it in the interfaces file (shown below), and I have also tried manually modifying it using the iwconfig command. Every time, it seems as if the command are successful; but when I verify with iwconfig, the ESSID is still "" . Here is the topology:
eth1: internet WAN
eth2: ethernet out to LAN
ra0: wireless out to LAN

Here is a copy of my /etc/network/interfaces file:
Code:
auto lo
iface lo inet loopback
auto eth2
iface eth2 inet static
        address 192.168.0.102
        netmask 255.255.255.0
        broadcast 192.168.0.0
        network 192.168.0.0
auto eth1
iface eth1 inet dhcp

auto ra0
iface ra0 inet static
	address 192.168.2.102
	netmask 255.255.255.0
	broadcast 192.168.2.0
	network 192.168.2.0
#wireless-mode Ad-Hoc
#wireless-essid laz
wpa-driver wext
wpa-ssid las
wpa-ap-scan 1
wpa-proto WPA RSN
wpa-pairwise TKIP CCMP
wpa-group TKIP CCMP
wpa-key-mgmt WPA-PSK
wpa-psk 56a72e371fd87baef20cda1a198f2972e479890dbe982ed336de33293c20d891
route command:
Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 ra0
192.168.0.0     *               255.255.255.0   U     0      0        0 eth2
98.160.136.0    *               255.255.252.0   U     0      0        0 eth1
link-local      *               255.255.0.0     U     1000   0        0 eth2
default         ip98-160-136-1. 0.0.0.0         UG    100    0        0 eth1
ifconfig:
Code:
eth1      Link encap:Ethernet  HWaddr 00:1a:66:4b:51:b0  
          inet addr:98.160.137.113  Bcast:98.160.139.255  Mask:255.255.252.0
          inet6 addr: fe80::21a:66ff:fe4b:51b0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:890686 errors:744 dropped:0 overruns:0 frame:744
          TX packets:614991 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1068172509 (1.0 GB)  TX bytes:73325990 (73.3 MB)

eth2      Link encap:Ethernet  HWaddr 00:25:11:73:89:75  
          inet addr:192.168.0.102  Bcast:192.168.0.0  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:26 Base address:0xe000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:542 errors:0 dropped:0 overruns:0 frame:0
          TX packets:542 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:56456 (56.4 KB)  TX bytes:56456 (56.4 KB)

ra0       Link encap:Ethernet  HWaddr 00:1a:ef:07:4b:4a  
          inet addr:192.168.2.102  Bcast:192.168.2.0  Mask:255.255.255.0
          inet6 addr: fe80::21a:efff:fe07:4b4a/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:5416 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8712 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:599565 (599.5 KB)  TX bytes:0 (0.0 B)
          Interrupt:22
ifdown -v ra0 && ifup -v ra0:
Code:
Configuring interface ra0=ra0 (inet)
run-parts --verbose /etc/network/if-down.d
run-parts: executing /etc/network/if-down.d/avahi-autoipd
run-parts: executing /etc/network/if-down.d/clamav-freshclam-ifupdown
run-parts: executing /etc/network/if-down.d/openvpn
run-parts: executing /etc/network/if-down.d/upstart
run-parts: executing /etc/network/if-down.d/wpasupplicant

ifconfig ra0 down
run-parts --verbose /etc/network/if-post-down.d
run-parts: executing /etc/network/if-post-down.d/avahi-daemon
run-parts: executing /etc/network/if-post-down.d/bridge
run-parts: executing /etc/network/if-post-down.d/wireless-tools
run-parts: executing /etc/network/if-post-down.d/wpasupplicant
wpa_supplicant: terminating wpa_supplicant daemon via pidfile /var/run/wpa_supplicant.ra0.pid
Stopped /sbin/wpa_supplicant (pid 31784).
wpa_supplicant: removing /lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.ra0.pid
Configuring interface ra0=ra0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/bridge
run-parts: executing /etc/network/if-pre-up.d/ethtool
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -s -B -P /var/run/wpa_supplicant.ra0.pid -i ra0 -D wext -C /var/run/wpa_supplicant
Starting /sbin/wpa_supplicant...
wpa_supplicant: creating sendsigs omission pidfile: /lib/init/rw/sendsigs.omit.d/wpasupplicant.wpa_supplicant.ra0.pid
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/ra0
wpa_supplicant: wpa-ap-scan 1 -- OK
wpa_supplicant: configuring network block -- 0
wpa_supplicant: wpa-ssid "las" -- OK
wpa_supplicant: wpa-psk ***** -- OK
wpa_supplicant: wpa-pairwise TKIP CCMP -- OK
wpa_supplicant: wpa-group TKIP CCMP -- OK
wpa_supplicant: wpa-key-mgmt WPA-PSK -- OK
wpa_supplicant: wpa-proto WPA RSN -- OK
wpa_supplicant: enabling network block 0 -- OK

ifconfig ra0 192.168.2.102 netmask 255.255.255.0 broadcast 192.168.2.0 	   	up

run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/avahi-autoipd
run-parts: executing /etc/network/if-up.d/avahi-daemon
run-parts: executing /etc/network/if-up.d/clamav-freshclam-ifupdown
run-parts: executing /etc/network/if-up.d/ethtool
run-parts: executing /etc/network/if-up.d/ntpdate
run-parts: executing /etc/network/if-up.d/openssh-server
run-parts: executing /etc/network/if-up.d/openvpn
run-parts: executing /etc/network/if-up.d/upstart
run-parts: executing /etc/network/if-up.d/wpasupplicant
Last, but not least-iwconfig:
Code:
lo        no wireless extensions.

eth2      no wireless extensions.

ra0       RT2860 Wireless  ESSID:""  Nickname:"RT2860STA"
          Mode:Auto  Frequency=2.437 GHz  Bit Rate=1 Mb/s   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality=10/100  Signal level:0 dBm  Noise level:-87 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth1      no wireless extensions.
During the ifup command, you can even see where the system "successfully" assigns the essid and psk to the device. Am i missing a step somewhere or is my syntax just incorrect? Any help would be greatly appreciated
 
Old 01-16-2010, 07:23 PM   #2
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
Hi - Welcome to LQ

Please tell us what distro you are using

Please run:

lspci | grep net

The output will tell us what interface devices are found on your box.

Two things immediately spring to mind:

1. Are you sure that your wireless device is capable of acting as an access point, and

2. Your iwconfig output shows mode set to Auto, I am pretty sure that this should be set to Master, according to my reading of: man iwconfig

Further are you sure that you ra0 broadcast IP setting is correct, in my experience it usually ends in .254

Hope this helps
 
Old 01-16-2010, 07:48 PM   #3
lightsabersetc
LQ Newbie
 
Registered: Jan 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your reply! I am using ubuntu v 9.10 and my adapters are:
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)
03:07.0 Network controller: RaLink RT2800 802.11n PCI

The internet in (eth1) is actually usb, which is why there are only two adapters. I was able to set up an ad-hoc network using the GUI network manager and was able to connect, so im pretty certain that this card can act as an access point. I just changed the auto to master in my interfaces. As for the broadcast address, I did a little research, and u are correct on that. I calculated what the broadcast address should be using my ip and subnet mask and came out with .255.
I then tried .255 for both my broadcast addresses, did not work. Changed to .254, still no cigar .

Last edited by lightsabersetc; 01-16-2010 at 07:48 PM. Reason: typo
 
Old 01-16-2010, 08:10 PM   #4
minrich
Member
 
Registered: Aug 2003
Location: Isles of Man & Wight
Distribution: See signature
Posts: 548

Rep: Reputation: 40
A quick google/linux for your RT2800 appears to confirm that it accepts Master mode and can act as an ap. However, I am uncertain how to assign an ESSID to the interface, as far as I am aware setting the ESSID using iwconfig sets the name of the ap that one wants to connect to, not the ESSID of the ap.

I think that you may have to investigate installing a 'radius' server on your box so that it broadcasts its presence and accepts/authenticates incoming connections. You may also be wise to remove encryption on the interface while you set it up, you can always set it up again later. The fact that it is working in ad-Hoc mode don't mean nothing.

Finally, I am not certain (I don't know) how one enables hiding and unhiding the broadcast of the ESSID set for the ap you are trying to create.

Its 1 a.m. here in blighty and I am going to crash soon, so I will check back in the morning, and anyway I have almost reached my level of incompetence on the subject of this thread.

Cheers
 
Old 01-16-2010, 09:23 PM   #5
lightsabersetc
LQ Newbie
 
Registered: Jan 2010
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for your help, get some rest .
To the best of my understanding, the wpa-ssid option sets the ssid and the wpa-ap-scan sets how to broadcast the signal (1 is visible, 2 hidden). I was just doing more troubleshooting and ran the ifdown && ifup again, and got something that might be of use:
Code:
Configuring interface ra0=ra0 (inet)
run-parts --verbose /etc/network/if-down.d
run-parts: executing /etc/network/if-down.d/avahi-autoipd
run-parts: executing /etc/network/if-down.d/clamav-freshclam-ifupdown
run-parts: executing /etc/network/if-down.d/openvpn
run-parts: executing /etc/network/if-down.d/upstart
run-parts: executing /etc/network/if-down.d/wpasupplicant
run-parts --verbose /etc/network/if-post-down.d
run-parts: executing /etc/network/if-post-down.d/avahi-daemon
run-parts: executing /etc/network/if-post-down.d/bridge
run-parts: executing /etc/network/if-post-down.d/wireless-tools
Error for wireless request "Set Mode" (8B06) :
    SET failed on device ra0 ; Network is down.
run-parts: executing /etc/network/if-post-down.d/wpasupplicant
Configuring interface ra0=ra0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/bridge
run-parts: executing /etc/network/if-pre-up.d/ethtool
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
Error for wireless request "Set Mode" (8B06) :
    SET failed on device ra0 ; Network is down.
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -s -B -P /var/run/wpa_supplicant.ra0.pid -i ra0 -D wext -C /var/run/wpa_supplicant
Starting /sbin/wpa_supplicant...
wpa_supplicant: sendsigs omission pidfile not created
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/ra0
wpa_supplicant: wpa-ap-scan 1 -- OK
wpa_supplicant: configuring network block -- 0
wpa_supplicant: wpa-ssid "las" -- OK
wpa_supplicant: wpa-psk ***** -- OK
wpa_supplicant: wpa-pairwise TKIP CCMP -- OK
wpa_supplicant: wpa-group TKIP CCMP -- OK
wpa_supplicant: wpa-key-mgmt WPA-PSK -- OK
wpa_supplicant: wpa-proto WPA RSN -- OK
wpa_supplicant: enabling network block 0 -- OK
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/avahi-autoipd
run-parts: executing /etc/network/if-up.d/avahi-daemon
run-parts: executing /etc/network/if-up.d/clamav-freshclam-ifupdown
run-parts: executing /etc/network/if-up.d/ethtool
run-parts: executing /etc/network/if-up.d/ntpdate
run-parts: executing /etc/network/if-up.d/openssh-server
run-parts: executing /etc/network/if-up.d/openvpn
run-parts: executing /etc/network/if-up.d/upstart
run-parts: executing /etc/network/if-up.d/wpasupplicant
Note the
Error for wireless request "Set Mode" (8B06) :
SET failed on device ra0 ; Network is down.
listed a few times. The only changes i have made to my interfaces file are:
iface ra0 inet manual (was static)
wireless-mode master (did not declare before)

Just for the sake of troubleshooting, I attempted to change the network to ad-hoc, which I was able to do using network manager. Same error. That's telling me that this has to be something syntax related, I just dont get it....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Distro to create Wireless Access Point - Atheros AR5212 PCI NIC theNbomr Linux - Wireless Networking 5 01-19-2010 10:58 AM
Wireless USB adapter - client and Access Point (AP) mesmunoz Linux - Newbie 0 05-26-2009 06:39 PM
Wi-Fi displaying the ESSID but yet No Access Point !! Fedexpress Linux - Newbie 2 10-02-2008 12:50 PM
LXer: Create a secure Linux-based wireless access point LXer Syndicated Linux News 0 07-20-2006 06:21 AM
Using an access point as a wirless adapter? xxterrorxx Linux - Wireless Networking 1 10-07-2005 08:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 09:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration