Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Security
User Name
Linux - Security This forum is for all security related questions.
Questions, tips, system compromises, firewalls, etc. are all included here.


  Search this Thread
Old 02-21-2004, 10:22 PM   #1
LQ Newbie
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
Firewall still not completely disabled on SuSe 9.0 after shorewall clear

Hi, I am trying to run a few services on a SUSE 9.0 machine (on a private LAN), such as webmin on 10000 and XServer on port 6000. At first I tried to use the SUSE firewall to no longer disable connections. Unfortunately, nmap still showed all ports to be closed. After giving up, I uninstalled the SUSE firewall and installed Shorewall.

After running 'shorewall clear', nmap showed the desired ports to be opened. However, connecting to them is still not possible.

Does anybody know how to get rid of SuSe's apparent extra restrictions, so I can just use ShoreWall?

Old 02-22-2004, 01:34 AM   #2
Registered: Sep 2003
Location: United Kingdom
Distribution: Ubuntu, Arch
Posts: 438

Rep: Reputation: 30
As root:

iptables -F

That should work
Old 02-22-2004, 05:05 AM   #3
LQ Newbie
Registered: Feb 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Sorry.. still no connection possible

Thanks anyway.
Old 02-22-2004, 11:59 PM   #4
Senior Member
Registered: Mar 2003
Distribution: Fedora
Posts: 3,658

Rep: Reputation: 69
Try doing killall iptables as root. Then do ps -ef to verify that iptables is not running. Then try connecting. If you still can't connect then you know that it is an application level problem rather than iptables/netfilter related.
Old 02-23-2004, 01:07 AM   #5
Senior Member
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
Are you running nmap against localhost? If so, that won't help your remote hosts. You need to run nmap from one of the hosts you're trying to connect from.

If the ports show as open from a remote host (on your LAN), but you can't connect to the services, then there's a good possibility that your server is using tcp wrappers. Make the appropriate entries in /etc/hosts.allow to allow your LAN clients to connect.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shorewall Firewall Help Pls kumarsundaram Linux - Security 1 07-16-2005 01:32 AM
Shorewall or other firewall??? SlipAway172 Linux - Security 5 01-25-2005 12:42 AM
How to disable firewall completely zyzyis Linux - Newbie 2 09-21-2004 08:23 AM
Suse 9.0 still refusing connections after shorewall clear and iptables -F driftindutchman Linux - Security 1 02-22-2004 11:56 PM
Suse 9.0 still refusing connections after shorewall clear and iptables -F driftindutchman Linux - Networking 0 02-22-2004 10:27 PM > Forums > Linux Forums > Linux - Security

All times are GMT -5. The time now is 07:23 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration