-   Linux - Security (
-   -   Firewall still not completely disabled on SuSe 9.0 after shorewall clear (

driftindutchman 02-21-2004 10:22 PM

Firewall still not completely disabled on SuSe 9.0 after shorewall clear
Hi, I am trying to run a few services on a SUSE 9.0 machine (on a private LAN), such as webmin on 10000 and XServer on port 6000. At first I tried to use the SUSE firewall to no longer disable connections. Unfortunately, nmap still showed all ports to be closed. After giving up, I uninstalled the SUSE firewall and installed Shorewall.

After running 'shorewall clear', nmap showed the desired ports to be opened. However, connecting to them is still not possible.

Does anybody know how to get rid of SuSe's apparent extra restrictions, so I can just use ShoreWall?


AMMullan 02-22-2004 01:34 AM

As root:

iptables -F

That should work :)

driftindutchman 02-22-2004 05:05 AM

Sorry.. still no connection possible
Thanks anyway.

Capt_Caveman 02-22-2004 11:59 PM

Try doing killall iptables as root. Then do ps -ef to verify that iptables is not running. Then try connecting. If you still can't connect then you know that it is an application level problem rather than iptables/netfilter related.

chort 02-23-2004 01:07 AM

Are you running nmap against localhost? If so, that won't help your remote hosts. You need to run nmap from one of the hosts you're trying to connect from.

If the ports show as open from a remote host (on your LAN), but you can't connect to the services, then there's a good possibility that your server is using tcp wrappers. Make the appropriate entries in /etc/hosts.allow to allow your LAN clients to connect.

All times are GMT -5. The time now is 02:01 AM.