LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2005, 10:15 AM   #1
overproof
Member
 
Registered: Apr 2005
Distribution: mandrake 10.2, ubuntu 7.10
Posts: 51

Rep: Reputation: 15
X-server.. how do I shut


Hi,

I need to install an NVIDIA driver, but before I do it I must shut down my X server.
How do I do that ?
Also I need to add few lines in /etc/X11/ but not sure if it should go in /etc/X11/XF86Config or in /etc/X11/xorg.conf as I've got both.
Thanks
 
Old 04-07-2005, 10:52 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
To shutdown X:

Open a terminal with <CTRL><ALT><F1>
Login as yourself
Give the command su root to become root
give the command init 3
Now X has been shut down.

Edit your file /etc/X11/xorg.conf , which you will find is linked to /etc/X11/XF86Config . You will need to use vi or pico to edit this file, as you will not have a nice graphical editor, so you might learn a little about these before you start.

When you have made the changes, exit from root by typing exit , now you are yourself again. Try to restart the xserver with startx maybe it will work, or maybe you will see error messages.
When you are happy, su to root again and give the command init 5 to restart the xserver.
That should be it. Have fun!
 
Old 04-07-2005, 11:36 AM   #3
overproof
Member
 
Registered: Apr 2005
Distribution: mandrake 10.2, ubuntu 7.10
Posts: 51

Original Poster
Rep: Reputation: 15
thanks for your reply,
Yes, now I know how to shut down or start the x-server.
I need a bit more help though with the Nvidia driver please.
when I try to install as per instuctions: sh NVIDIA-linux-x86-1.0-7174-pkg1.run it fails as it appears I dont have this gcc package.
below is a copy of the log:
option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /root/tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
ERROR: Unable to find the development tool `cc` in your path; please make sure
that you have the package 'gcc' installed. If gcc is installed on your
system, then please check that `cc` is in your PATH.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
Any help will be appreciated. Cheers
 
Old 04-07-2005, 01:25 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
OK,

gcc is the GNU C Compiler. You need it to compile things from source, and sooner or later you will want to do this. When you installed, you should have selected the "Development" packages or something similar to be installed, this installs a whole load of useful stuff. No matter, we can install gcc now from your CD/DVD.

Star-System-Configure- Configure your computer. Give root's password. This starts MCC.
Go to Software management - Install Software. Search for gcc and install it. It may say a whole load of other stuff needs to be installed as well, allow it to do this.

While you are at it, you will need to install your kernel source, as the NVIDIA driver needs to know how your kernel was built, and the output you have posted is complaining that it cannot find the kernel source.

Whilst in "Install Software" do a search for "kernel". It is important you install the source for the kernel you currently have running . You can check your kernel version by typing uname -a in a terminal. It will be something like 2.6.8.1-12mdk. Make sure you select and install only the kernel source that matches this number!

If you are running the 2.6 kernel, the only NVIDIA driver I have managed to get working with the 2.6 kernel is the 6111 version, and it needs a simple patch. So get the 6111 driver from NVIDIA and then please see this thread and follow the easy instructions in Linux24's post:

http://www.linuxquestions.org/questi...91#post1576891

Although the latest driver release has possibly fixed it, 6111 works well for me.

If all this seems like a load of trouble, well, it is and it isn't: It is part of the linux-learning process, first you'll struggle, then get used to it, and then quite suddenly find that it is enjoyable to have complete control over your computer.

Have fun!
 
Old 04-07-2005, 05:29 PM   #5
overproof
Member
 
Registered: Apr 2005
Distribution: mandrake 10.2, ubuntu 7.10
Posts: 51

Original Poster
Rep: Reputation: 15
Fun I'm having alright !
Again thanks for reply. yes I managed to get the kernel source files (by the way it is 2.6.8.1-12mdk)
after I cocked few things up and did a complete re-install. i have now installed the Nvidia driver Latest Version: 1.0-7174 ( I did that before I read your last reply) it seems to be ok as I can start X-server. The only thing I changed in /etc/X11/XF86Config was "nv" to "nvidia" as per installation notes.
Now to get TV out working I beleive I need to add few more lines in there, but dont know what.
(I've tried the following :
Option "NoLogo" "true"
Option "Rotate" "off"
Option "TwinView" "true"
Option "SecondMonitorHorizSync" "30-50"
Option "SecondMonitorVertRefresh" "60"
Option "MetaModes" "1024x768,1024x768;800x600,800x600;640x480,640x480"
Option "TVStandard" "Pal-B"
Option "ConnectedMonitor" "CRT,TV"
Option "TwinViewOrientation" "Clone"
Option "TVOutFormat" "SVIDEO

but didnt work, I dont know if I still have to configure something else ?)

Anyway as you say its all part of the fun.
Cheers for now
 
Old 04-07-2005, 05:50 PM   #6
overproof
Member
 
Registered: Apr 2005
Distribution: mandrake 10.2, ubuntu 7.10
Posts: 51

Original Poster
Rep: Reputation: 15
Thumbs up

Well, ... I was wrong on my previous post.
It does work with those lines. I was connecting the TV to the AV connector.
Now that I connected the s-video connector it works fine.
Thank you for your help.
Hard work, but it pays at the end....
Cheers
 
Old 04-08-2005, 01:43 AM   #7
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,087

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Problem solved: Good!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't shut down X server, tried everything(?) trentr Linux - General 4 11-30-2005 07:55 PM
how to shut downd X server from X server? mac1234mac Linux - Software 2 09-16-2005 01:02 PM
How do I shut down the x-server? JackieBrown SUSE / openSUSE 1 12-29-2004 08:50 PM
Auto shut down server ! the_reen Red Hat 1 07-08-2004 11:01 PM
how do i shut down X server? yzrider210 Linux - Newbie 17 11-21-2003 08:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration