Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-21-2006, 03:10 PM   #1
LQ Newbie
Registered: Sep 2005
Posts: 14

Rep: Reputation: 0
Typing on keyboard causes disk access; wtf?

Hey All,

I u/g my 2.6.14 kernel to 2.6.16, did a dist-upgrade (Debian Sarge) and rebuilt my initrd. Now, every time I type a key on my keyb I hear the disk get accessed. If i hold down my shift/ctrl/alt key, the disk goes nuts, but I am (almost) sure that my box didn't used to do this (could be wrong?).

I should note that this only happens when typing on the keyb connected to the box (either at the console or in X or whatever) and not during an ssh session or the like from a remote box.

I am guessing that this happens because the io from my keyb is going through a dev file that is on my disk, but how do I stop it? The sound is annoying and I'v reduced the lifetime of my disks just by typing this question (through uneccesary disk access).

I have googled and LQ-searched but have come up blank on this particular issue (well, I have learned a bunch of stuff about unrelated things so it hasn't been a total loss).

I see that a new device manager came with my 2.6.16 kernel (udev) and apparently, it operates slightly differently than devfs did so my theory is that udev is doing something that I am not expecting. I see that /dev/console (which is where I *think* local keyb io goes) and /dev/null need to exist before udev will work.


Some system info:

# mount
/dev/md0 on / type ext3 (rw,usrquota)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sdc1 on /backup type ext3 (rw,errors=remount-ro)
/dev/sdd1 on /u02 type ext3 (rw,errors=remount-ro)
tmpfs on /dev type tmpfs (rw,size=10M,mode=0755)


# cat /proc/mdstat
Personalities : [raid1]
md0 : active raid1 sda1[0] sdb1[1]
293033536 blocks [2/2] [UU]

unused devices: <none>


# ls -ld /dev/null /dev/console
crw------- 1 root root 5, 1 2006-05-21 10:26 /dev/console
crw-rw-rw- 1 root root 1, 3 2006-05-21 05:02 /dev/null


And just incase udev does have something to do with this:

# cat /etc/udev/udev.conf
# udev.conf

# The initial syslog(3) priority: "err", "info", "debug" or its
# numerical equivalent. For runtime debugging, the daemons internal
# state can be changed with: "udevcontrol log_priority=<value>".

# maximum size of the /dev tmpfs


# grep console /etc/udev/*
/etc/udev/links.conf:M console c 5 1
/etc/udev/permissions.rules:KERNEL=="console", MODE="0600", GROUP="root"
/etc/udev/run.rules:# ignore the events generated by virtual consoles
/etc/udev/run.rules:KERNEL=="console", OPTIONS+="last_rule"


# grep null /etc/udev/*
/etc/udev/links.conf:M null c 1 3
/etc/udev/permissions.rules:KERNEL=="null", MODE="0666"

Other possible factors contributing:
* This is a new keyb. I moved to another country and the old one got lost in space. This is a USB keyb plugged into the PS2 slot via an adaptor.

Also, my USB mouse (MS Optical) keeps getting de-detected in that it require me to keep unplugging it and plugging it back in. This is definitely a new problem, but I will worry about that later as I at least have a workaround. I only bring it up because it might be related.

Old 05-21-2006, 03:27 PM   #2
LQ Newbie
Registered: Sep 2005
Posts: 14

Original Poster
Rep: Reputation: 0
Thumbs up Solved: rmmod evbug

I am such a f'ing noob.

So, 2 mins after posting this I said to myself, I wonder what dmesg says...

# dmesg
ut0, Type: 0, Code: 0, Value: 0
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 4, Code: 4, Value: 28
evbug.c: Event. Dev: isa0060/serio0/input0, Type: 1, Code: 28, Value: 0

Googling this led me to some articles about excessive logging and that the excessive logging could be turned off by removing the module evbug (I guess it is some kind of debug logger and why it got loaded is beyond me, but that is for another day).

Anyways, the recommended fix was to:

# rmmod evbug

I did that, went back to google and typed another query to try to find the solution to this problem and noticed that my disk wasn't reacting to keyboard input anymore.

I did a quick modprobe evbug, disk stupidity came back...

Ugh. I hope this helps some of you other evbug victims out.

Old 05-21-2006, 04:04 PM   #3
LQ Veteran
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Congrats on solving the problem and thanks for posting back with the solution that worked for you.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
keyboard/Typing keys not working on suse 10.0 suse2166 Linux - Software 3 03-28-2006 05:37 PM
Keyboard typing problem dc11 Linux - Software 2 01-27-2006 11:20 PM
Typing Characters Not on the Keyboard Kamex Linux - Software 1 03-02-2005 03:56 PM
keyboard stops responding after typing capitals nigham Linux - Hardware 1 09-13-2004 12:19 AM
left numeric keyboard is typing numbers (problem with NumLock on/off) zstingx Linux - General 0 11-10-2003 09:59 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration