LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-19-2007, 10:28 PM   #1
VicRic
Member
 
Registered: Sep 2006
Location: Vancouver, Canada
Distribution: Mandriva 2010 / Fedora 15 2.6.40.6-0
Posts: 44

Rep: Reputation: 16
Typing accented characters in Linux


Hi. I use gedit for editing in my Linux systems (SUSE and Fedora) and I find that I can't type in accented characters like I used to do in Windows.

In the text editor in Windows, even using an English keyboard configuration, I could type in accented characters by entering a combination of Alt+<ASCIIcode>, for example Alt+130 would type in the accented 'e' character; this sequence doesn't work in Linux.

Any suggestions on how to solve the problem ?

Thnx
 
Old 05-19-2007, 10:58 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 62
Gnome has an applet called Character Palette. Right click on a blank area on the panel, Select "Add to Panel"
 
Old 05-20-2007, 01:46 AM   #3
Sonneteer
Member
 
Registered: May 2006
Location: Canada
Distribution: Slackware 13.37; Ubuntu 12.04
Posts: 81
Blog Entries: 5

Rep: Reputation: 15
When I need accented characters, I like to switch to an international keyboard map, such as the intl variation of the us keyboard. If you use them often, there should be something in the settings menu to set that up.
 
Old 05-21-2007, 02:41 PM   #4
VicRic
Member
 
Registered: Sep 2006
Location: Vancouver, Canada
Distribution: Mandriva 2010 / Fedora 15 2.6.40.6-0
Posts: 44

Original Poster
Rep: Reputation: 16
Thanks Rickh, the applet Character Map helped, however I found faster keyboard shortcuts.

Thanks Sonneteer, this may be of interest to you too.

According to Nodsu, the keyboard escape sequence in gnome is ctrl+shft, so while pressing it you type u+<UTF16charactercode> to type in the special characters.

For example:

ctrl+shft+ue1

ctrl+shft+ue9

ctrl+shft+ued

ctrl+shft+uf3

ctrl+shft+ufa

ctrl+shft+ufc

ctrl+shft+uf1

ctrl+shft+ubf

ctrl+shft+ua1

Also in Fedora and SUSE you can use 'Character Map / All Unicode Blocks' to find out the UTF16 code for any other character you may want to use.

BTW I haven't tried this with KDE.

Rgds
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accented Characters and other "foreign language" Characters Mark_in_Hollywood LQ Suggestions & Feedback 2 04-30-2007 07:10 PM
no accented characters on an old olivetti laptone plbrt Linux - Software 0 08-10-2006 03:48 PM
Quanta accented characters spaniard Linux - Software 4 11-04-2005 01:08 AM
How to type accented Greek characters? fishpi Linux - Software 1 08-04-2005 03:26 PM
Accented characters in C Orkie Programming 2 05-17-2005 01:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration