LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-22-2005, 05:26 PM   #1
Sparky1
Member
 
Registered: Apr 2005
Location: Montreal, Canada
Distribution: Suse 10, 9.3 Pro, FC 3
Posts: 36

Rep: Reputation: 15
Unhappy sigh... 3D acceleration in Suse 9.3


Hey all, I'm running Suse 9.3 Pro and I'm trying to get the latest ATI Fire GL drivers installed for the X1 128. Now I have been doing some reading, and the more I read, the more I get confused. I have tried tio run the check.sh script but I get a console permission error. I have also tried to run it as root in run level 3, same error. If I go into the ATI FireGL X1 details it shows

driver info #0:
Xfree86 v4 Server module: Radeon
Driver info #1:
Xfree86 v4 Server module: fglrx
3D support: yes
Extension: dri
XFConfig Entry: Option "UseinternalAGPGART" "no"\nOption "mtrr"
"off"\nOption "VideoOverlay" "on"\nOption "OpenGLOverlay" "off"

I'm assuming I am using Xfree86 and not X.Org 6.8. I treid to install the
fglrx 4_3_0-8.12.10-1.i386.rpm package by using rpm -Uh --force fglrx 4_3_0-8.12.10-1.i386.rpm
but I got a dependency error regarding fglrx.
I've read some guides and as I said its getting more confusing.

Is there anyone running Suse 9.3 Professional that has done this. I don't know if the regular Linux installation guide applies to Suse. Crap, I can't even compose a concise question any more!!
 
Old 05-22-2005, 05:58 PM   #2
wini_g
Member
 
Registered: Jun 2003
Distribution: SuSE 11.0
Posts: 171

Rep: Reputation: 30
I consider myself still a Newbee so I might be severly wrong .. :

As far as I know SuSE 9.3 uses Xorg 6.8.2
The driver & server module .. do they fit together .. arent they for different cards
one for radeon chips ... & the other one for FireGL cards ...
shouldnt there normally be only one ... in this case the fglrx module ... ?
Your options look a bit strange to me ... what about the ATI drivers ... I think there are some for new FireGL cards & such ...

You might find quite a lot of info on the SuSE page .... or search on LQ ....

Hope Ive maybe helped a bit .
 
Old 05-23-2005, 05:00 AM   #3
Cybers19
Member
 
Registered: May 2003
Location: Germany - Zöbingen
Distribution: Suse 9.3 & Win XP SP2
Posts: 69

Rep: Reputation: 15
Hi,

have a look at the readme on
"ftp://ftp.suse.com/pub/suse/i386/supplementary/X/ATI/suse93/i386/fglrx/8.12.10/"

For me it works fine.

ATI Radeon X800 Pro & SUSE 9.3 Pro

rgds,

Cybers19
 
Old 05-23-2005, 11:51 AM   #4
Sparky1
Member
 
Registered: Apr 2005
Location: Montreal, Canada
Distribution: Suse 10, 9.3 Pro, FC 3
Posts: 36

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Cybers19
Hi,

have a look at the readme on
"ftp://ftp.suse.com/pub/suse/i386/supplementary/X/ATI/suse93/i386/fglrx/8.12.10/"

For me it works fine.

ATI Radeon X800 Pro & SUSE 9.3 Pro

rgds,

Cybers19
That seems to have done the trick, I now have 3D hardware acceleration. Thank you.
I now have a new question, when I go to the desktop configuration utility>display settings>size and orientation,
it says my X Server does not support resizing and rotating the display. Please update to version 4.3 or greater. I need the X resize and rotate extension (RANDR) version 1.1 or greater to use the feature.
Is this a sacrifice I have to make to get 3D acceleration?

Also, is there somewhere I could get some information on how the graphics system and subsystem work on Linux, specifically Suse? I would really like to improve my understanding of the linux GUI. I don't want to just follow instructions on how to set it up, but rather be able to troubleshoot an issue on my own. I would like to understand the relationship of X Server, X Windows, and/or Xfree86 and Xorg. Does anyone have a good starting point? Thank you all for your input.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 10 no video acceleration shingalated SUSE / openSUSE 4 11-22-2005 06:18 PM
3d acceleration not working on suse 9.1 federico Linux - Laptop and Netbook 0 02-19-2005 12:24 AM
SiS741GX 3d acceleration on suse 9.1 ultramancool Linux - Hardware 0 01-07-2005 03:26 PM
No 3d Acceleration in SuSE 9 Kaola Linux - Hardware 4 12-15-2003 01:41 AM
Do 3D Acceleration and SuSE go together? concoran Linux - General 3 11-19-2001 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration