LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-24-2009, 02:31 PM   #1
farid_lmu
LQ Newbie
 
Registered: Jan 2009
Posts: 18

Rep: Reputation: 0
Wink sendmail config problem


hello I just installed sendmail from fedora 10 server package.
When I write /etc/rc.d/init.d/sendmail in command mode than the following problem happens:

[root@localhost farid]# /etc/rc.d/init.d/sendmail start
Starting sendmail: 451 4.0.0 /etc/mail/sendmail.cf: line 87: fileclass: cannot open '/etc/mail/local-host-names': World writable directory
451 4.0.0 /etc/mail/sendmail.cf: line 594: fileclass: cannot open '/etc/mail/trusted-users': World writable directory


could anyone please tell me what I've to do in here, though I didn't
configure anything in sendmail here.

Any idea/suggestion will be appreciated.

Thanks in advance
 
Old 03-24-2009, 05:10 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,887

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
You should run
Code:
chmod 755 /etc/mail
to remove the world writalbe attribute from /etc/mail
 
Old 04-02-2009, 08:13 AM   #3
farid_lmu
LQ Newbie
 
Registered: Jan 2009
Posts: 18

Original Poster
Rep: Reputation: 0
Post sendmail problem

Quote:
Originally Posted by bathory View Post
You should run
Code:
chmod 755 /etc/mail
to remove the world writalbe attribute from /etc/mail

===================================================================

Hello bathory thanks anyway for your suggestions. But the problem is that I couldn't solve it yet now. I tried according to your idea. But it shows the same error again.

Any more idea/suggestions would be most welcome.

thanks indeed.
 
Old 04-02-2009, 09:05 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,887

Rep: Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608Reputation: 1608
If running
Code:
ls -l /etc/mail
you find that the affected files have the correct permissions, take a look at this post and do the appropriate changes in sendmail.cf (Fw-o instead of Fw)

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SENDMAIL config error: mail loops back to me (MX problem?) /jhannus Slackware 6 06-21-2011 06:44 AM
Sendmail Config problem here....thanx jalmario Linux - Distributions 1 02-25-2007 09:27 PM
Sendmail - Config for IP Block's & Config Issues Thom_Redhat Linux - Software 1 04-07-2006 02:29 PM
sendmail M4 config problem fledermaus Linux - Software 8 10-20-2004 12:38 PM
sendmail config problem JakeS Linux - Software 1 10-01-2003 12:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration