Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-02-2003, 05:44 AM   #1
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Rep: Reputation: 15
problems installing glib

I've Redhat 9.0 installed on my system but I didn't initially install gnome. while installing gaim-0.71 I got the following error message.

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http()//www()gtk()org/.

So I downloaded latest glib from gtk-org and tried installing it. I got no error while installing glib. But the I keep on getting the above error while installing gaim even after that. I also tried to install GTK, ATK and PANGO from but they all give the same above error of not finding glib.

I also get the following error while installing gaim from rpm package.
error: Failed dependencies:
gtk+2.0 >= 2.0.0 is needed by gaim-0.71-1mdk9.1
libnss3 is needed by gaim-0.71-1mdk9.1 is needed by gaim-0.71-1mdk9.1 is needed by gaim-0.71-1mdk9.1 is needed by gaim-0.71-1mdk9.1
perl-base >= 2:5.8.0 is needed by gaim-0.71-1mdk9.1

Can somebody help? Should I first delete the files relating to glib from my system?
Thnx in advance
Old 03-30-2004, 08:19 PM   #2
Registered: Mar 2004
Location: Colorado
Distribution: Gentoo Linux 2004.1
Posts: 61

Rep: Reputation: 15
Why are you installing a Mandrake RPM package for a RedHat system?
Old 04-13-2004, 09:46 PM   #3
Registered: Oct 2003
Posts: 49

Rep: Reputation: 15
is that a problem?
I have the same error
where can we get the RPM (or any other type of file) for Red Hat?
Old 04-13-2004, 09:55 PM   #4
LQ Guru
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
If you install RPMs compiled for other distros you're just making yourself closer to dependency hell.
for Gaim they do provided rpms for Redhat 9

there's couple of good websites for searching RPMs, here's one I remember from top of my head
Old 04-14-2004, 03:14 PM   #5
Registered: Oct 2003
Posts: 49

Rep: Reputation: 15
try this, it worked for me

edit the .bashrc (vi .bashrc)
insert the following lines:

export LD_LIBRARY_PATH=/usr/local/lib
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig:/usr/X11R6/lib/pkgconfig

save the changes.

Try to install again.
Old 04-24-2004, 06:13 AM   #6
Registered: Apr 2004
Location: Helsingborg, Sweden
Distribution: Debian/Xandros 3.0
Posts: 41

Rep: Reputation: 15
I had the same problem while trying to install GTK on a debian system. I solved it copying the .pc files in /usr/local/lib/pkgconfig/ to /usr/lib/pkgconfig I never got the PKG_CONFIG_PATH variable to work. But after doing this I encoutered another problem while doing ./configure on another of the dependencies for GTK (ATK) and the error message looks like the following:

*** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.2.3)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from If GLIB is installed
*** but not in the same location as pkg-config add the location of the file
*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

Now I have only installed 2.4.0 on my set, nothing else. A "find / -name glib-2.0.pc" only returns the files that has to do with 2.4.0 so how can I have 2.2.3 installed? How do I get past this?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
problems installing glib :( R++ Linux - Software 3 03-29-2005 01:50 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 05:27 PM
Problems installing glib-2.2.0 ooagentbender Linux - Software 1 12-29-2003 03:21 AM
Problems installing GLib 2.0.4 Fred Affe Linux - Newbie 4 08-17-2003 05:17 AM
Installing glib 1.2.6 problems dgdgedd Linux - General 1 03-31-2003 02:49 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:01 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration