LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2009, 04:06 AM   #1
habeeb
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Rep: Reputation: 0
Problem booting into Vista after installing fedora 11


Hi Experts,

I have recently installed fedora11 on top of vista. I think my installation was successful, but the problem occurs, when i have a choice to select the OS to boot in, Its giving me only two options fedora and others, there is no option for vista and when i log into others, the system restarts.

After entering fedora, I have tried modifying menu.lst by adding entry
title Windows Vista Home Premium
root (hd0,0)
makeactive
chainloader +1

Now i got windows vista option when i restart, but when i select the vista option, its going some blue screen with 3 options like
1. Memory Test
2. some Hardware test (not sure)
3. Exit

I tried running the memory test and other test, but at some point in time, its aborting the test and restarting and its also restarting when i select exit option.......

Please help!!!!!!!!!!!

Thanks in advance,
Habeeb
 
Old 08-03-2009, 05:17 AM   #2
manu-tm
Member
 
Registered: May 2008
Location: France
Distribution: Ubuntu, Debian
Posts: 342

Rep: Reputation: 43
I'm not on fedora nor vista (I have ubuntu and xp) but did you run vista before re-partitioning your disk?
 
Old 08-03-2009, 05:33 AM   #3
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Rep: Reputation: 29
print the results of fdisk -l here
 
Old 08-06-2009, 12:12 PM   #4
habeeb
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Shahz,

Sorry for the delayed reply, i was out of station.
Below are the results of fdisk -l:

Disk /dev/sda: 320.0 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa0000000

Device Boot Start End Blocks Id System
/dev/sda1 1 25 200781 6 FAT16
/dev/sda2 * 26 1984 15728640 7 HPFS/NTFS
/dev/sda3 1984 29262 219111420 7 HPFS/NTFS
/dev/sda4 29262 38914 77528064 f W95 Ext'd (LBA)
/dev/sda5 29262 36911 61440000 7 HPFS/NTFS
/dev/sda6 * 36911 36936 204799+ 83 Linux
/dev/sda7 36936 38914 15881215+ 8e Linux LVM

Disk /dev/dm-0: 10.9 GB, 10993270784 bytes
255 heads, 63 sectors/track, 1336 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 5268 MB, 5268045824 bytes
255 heads, 63 sectors/track, 640 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-1 doesn't contain a valid partition table
 
Old 08-06-2009, 12:37 PM   #5
forubu
LQ Newbie
 
Registered: Jul 2009
Location: Trondheim, Norway
Distribution: Ubuntu
Posts: 28

Rep: Reputation: 16
It looks like your Vista partition is on root(hd0,1) instead of root(hd0,0).
 
Old 08-07-2009, 04:07 AM   #6
habeeb
LQ Newbie
 
Registered: Aug 2009
Posts: 3

Original Poster
Rep: Reputation: 0
I have changed the (hd0,0) to (hd0,2) in

title Windows Vista Home Premium
root (hd0,2)
makeactive
chainloader +1

and its working perfertly.

Thanks for all ur replies.
habeeb.
 
Old 08-07-2009, 09:12 AM   #7
shahz
Member
 
Registered: Sep 2006
Location: Quetta, Pakistan
Distribution: RHEL 4
Posts: 360

Rep: Reputation: 29
Quote:
Originally Posted by habeeb View Post
I have changed the (hd0,0) to (hd0,2) in


root (hd0,2)
is that root (hd0,2) or (hd0,1)

because your fdisk -l output says

/dev/sda2 * 26 1984 15728640 7 HPFS/NTFS


in this case it should be root (hd0,1)

check again!
 
  


Reply

Tags
lq


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
booting Vista, XP, and then installing Linux with grub james2b Linux - Newbie 3 04-27-2009 01:30 AM
Dual Booting in Fedora 8 & Vista Mabonyo67 Linux - Newbie 3 07-10-2008 02:46 PM
Error booting into Vista after installing Fedora 9 Captain DDL Linux - Newbie 12 06-14-2008 01:44 AM
Lost Vista booting after Fedora 8 install dpeace Linux - Newbie 9 01-03-2008 12:19 PM
installing fedora 6 on extrnal usb drive and dual booting with vista _kg Linux - Newbie 3 11-26-2007 08:02 AM


All times are GMT -5. The time now is 07:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration