LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-07-2005, 04:16 PM   #1
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Rep: Reputation: 15
no sound with mplayer plugin


Hello all,

I recently installed Fedora core 3 at work and I'm still getting used to it. (Never really used Linux before.) I've been trying to get multimedia to work in Firefox. I have mplayer and mplayerplugin installed and I can view .mov files but there is no sound. I'm not quite sure how to fix my problem. could somebody please advise?
 
Old 02-07-2005, 07:42 PM   #2
Ace07
Member
 
Registered: Feb 2005
Distribution: Fedora Core 3 (2.6.10_1.741)
Posts: 72

Rep: Reputation: 15
Re: no sound with mplayer plugin

Quote:
Originally posted by cliff76
Hello all,

I recently installed Fedora core 3 at work and I'm still getting used to it. (Never really used Linux before.) I've been trying to get multimedia to work in Firefox. I have mplayer and mplayerplugin installed and I can view .mov files but there is no sound. I'm not quite sure how to fix my problem. could somebody please advise?
Did you install ALL the codecs from the mplayer site?

There should be a tarball that is labeled 'all*.tar.gz' on the mplayer site. I recommend getting that and installing it.

Other than that I can't help you, I haven't been able to get *.mov files to play for very long. They always crash mplayer... X_X
 
Old 02-08-2005, 07:26 AM   #3
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Did you install ALL the codecs from the mplayer site?

There should be a tarball that is labeled 'all*.tar.gz' on the mplayer site. I recommend getting that and installing it.

Other than that I can't help you, I haven't been able to get *.mov files to play for very long. They always crash mplayer... X_X
Yes I believe I did install all of the codecs. I downloaded the "all" tarball from the site and expaned them in the /usr/lib/codecs folder but that makes no difference. Something else I've also tried. I found a quote on a forum regarding a problem like mine where the guy had to configure the audio output to get the sound to play. The solution was to set a config file under ~/.mplayer with the text ao=oss or something. I noticed that I only get output when using the Arts driver because I'm in KDE with the sound system running. I tried creating a file called config under ~/.mplayer with the text ao=arts but that doesn't make a difference either. I have both fixes in place and still have no sound. Thank you for your help and do you have any other suggestions?

Kind Regards,
Cliff
 
Old 02-08-2005, 09:12 AM   #4
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,210

Rep: Reputation: 71
Turn off the arts sound system. In the KDE control center, de-select the button "enable sound system" Mplayer has problems with arts and it can prevent sounds from playing, or in some cases cause a lag in sound behind video.
 
Old 02-08-2005, 10:32 AM   #5
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
Still nothing

I didn't think it was the sounds system. However I tried disabling it and logging off and logging back in to KDE and trying the plugin again. Still no sound. At this point I don't know what to do. I tried copying the gui.conf file over the config and then the GUI wouldn't even run. So I then restored the original settings in config and tried again. I have codecs expanded (I'm not sure if that's the extent of the install) and I have configs set and I still have no sound. Another issue that may or may not be related is my installing of mplayer using APT-GET/synaptic. I can see all of the related codecs in the synaptic window from the repository I just can't install them because they depend on mplayer-gui. That's why I had to manually download the tarball and expand it into /usr/lib/codecs. I also cannot download the skins for mplayer for the same reason. I only installed mplayer and never installed mplayer-gui from the repository. My repositories don't list mplayer-gui as an installable candidate. I am using apt-get with Fedora core 3 because I couldn't get yum to work at all. something with it being able to find the right xml files in the repositories that it keeps complaining about. I am a beginner but I have learned much already in my past month of Linux toying. please help.

Regards,
Cliff
 
Old 02-08-2005, 11:20 AM   #6
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,210

Rep: Reputation: 71
Try adding:
Code:
# Marillat's Non-free
deb ftp://ftp.nerim.net/debian-marillat/ unstable main
to /etc/apt/sources.list

Then do
Code:
apt-get update
You will then be able to install gmplayer and codecs using synaptic.
 
Old 02-08-2005, 11:26 AM   #7
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,210

Rep: Reputation: 71
Oops, you are not using Debian. Here is the place to go for Fedora: http://atrpms.net/name/atrpms-package-config/
 
Old 02-08-2005, 01:11 PM   #8
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
More problems

m_yates,

Thanx for the tip. I downloaded and ran the rpm for Fedora Core 3 and I got conflict errors. Now my synaptic GUI won't come up. Even if I run it from the command line nothing happens after I key my root pwd. I noticed there's a syndaemon command under /usr/bin and I don't see a syndaemon process running anymore eversince I rebooted earlier. I'm thinking that synaptic didn't register a daemon as a sys service? I dunno, I just know that things were working fine when I first installed it and I never rebooted until today now things don't work. (BTW, switching off/on sound system in KDE caused my system notifications to go away too. The default player doesn't work any more under sounds in Ctrl panel so I configured it to use an external player called play and that patch things for me.) While I have some idea of how things work I'm really just a newbie and I may be getting in over my head. Thanx to all who can and continue to help me thru this!

Kind Regards,
Cliff
 
Old 02-08-2005, 03:08 PM   #9
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
Completely messed up

Now everything is acting flaky! I can't use my default player in the KDE sound system settings (all of that worked this morning). Also my snyaptic GUI doesn't run. I can't determine if a daemon needs to be started or not but I'm guessing that's the problem. Please help.

Cliff
 
Old 02-08-2005, 03:38 PM   #10
Ace07
Member
 
Registered: Feb 2005
Distribution: Fedora Core 3 (2.6.10_1.741)
Posts: 72

Rep: Reputation: 15
Quote:
Originally posted by cliff76
Yes I believe I did install all of the codecs. I downloaded the "all" tarball from the site and expaned them in the /usr/lib/codecs folder but that makes no difference. Something else I've also tried. I found a quote on a forum regarding a problem like mine where the guy had to configure the audio output to get the sound to play. The solution was to set a config file under ~/.mplayer with the text ao=oss or something. I noticed that I only get output when using the Arts driver because I'm in KDE with the sound system running. I tried creating a file called config under ~/.mplayer with the text ao=arts but that doesn't make a difference either. I have both fixes in place and still have no sound. Thank you for your help and do you have any other suggestions?

Kind Regards,
Cliff
/usr/local/lib/codecs is where codecs are located on my system. Try installing them to that directory (since that is the default)...
 
Old 02-09-2005, 08:11 AM   #11
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
I moved the codecs folder from /usr/lib to /usr/local/lib. Still no sound. Again the video comes up fine. Are you sure its a codec problem and not a configuration issue? I was thinking the whole time that the audio driver the plugin uses by default was giving me issues. Like I said earlier, I've tried editing the config file and putting both arts and alsa in the ao property but still no sound. Thanx for helping. Any other suggestions?
 
Old 02-09-2005, 10:47 AM   #12
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,210

Rep: Reputation: 71
You can try running gmplayer (mplayer-gui) and changing the sound preferences. In gmplayer, you can change preferences easily by right clicking on the window playing the video. My audio is set to "oss" in the preferences and it works as long as nothing else is using sound.

Edit: You can also do the same thing in mplayer by manually editing the config file.
 
Old 02-09-2005, 12:10 PM   #13
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
can't get the plugin to work

I can do just about anything with gmplayeer and get it to work pretty good. (One thing I can't do is config our office HTTP proxy for the GUI). I don't see what this has to do with the plugin. There is an entirely different config file for the GUI (config-gui) and like I said earlier I tried copying this over the regular config file but that crashed even the GUI. Essentially what I need to find out is why sound doesn't work with the plugin. Also how do I config the GUI to use our HTTP proxy?
 
Old 02-09-2005, 12:30 PM   #14
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
Wait is is a codec problem

I finally stopped being stupid and downloaded the .mov file I was toying with and tried it in gmplayer instead of the plugin. I got the same results (video no sound) except this time there was an error popup. The popup said "can't find codec for audio format 0x324D4451". Now I searched google for the error (like any other law abiding Linux using citezen would do in this case) and found some references that said maybe mplayer needs to be compiled after the codecs are installed? I dunno. All I know is that I installed using synaptic over apt-get and that I couldn't install the codecs afterward. something the gui was complaining about mplayer-gui not being installed or installable. Now my question is how do I get mplayer to use the codecs that I downloaded? I installed them in both /usr/ lib/ and /usr/local/lib/. If I have to rebuild mplayer then what's the easiest way to do that? Remember I installed with apt-get. I'm running on Fedora core 3.
 
Old 02-10-2005, 07:48 AM   #15
cliff76
Member
 
Registered: Feb 2005
Location: PA
Distribution: Fedora Core 3
Posts: 48

Original Poster
Rep: Reputation: 15
I got my synaptic GUI working again and re-installed mplayer but still I get no sound. Help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mplayer-plugin no sound ?? memo007 Linux - Software 1 09-11-2005 09:46 PM
Re: MPlayer Plugin has no Sound RichMan1 Linux - Newbie 9 03-11-2005 07:11 PM
No sound in mplayer or mplayer firefox plugin case1984 Linux - Newbie 1 01-21-2005 12:58 AM
MPlayer / Mplayer Plugin no Sound apjonesy Linux - Software 5 08-06-2004 04:27 AM
sound mplayer plugin Mozilla alucard2 Linux - Software 4 03-21-2004 11:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration