LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2003, 05:05 AM   #1
therock
LQ Newbie
 
Registered: Jan 2003
Posts: 8

Rep: Reputation: 0
No-IP and Red Hat Linux 8.0


I want to install WEB SERVER. I using Homeportal Gateway 2 wire DSL, Red Hat Linux 8, dynamic IP .All thing i did is install No-IP on Linux 8.0..Then i command to run No-IP update. And i see in the command line message everytime i run nop-ip: "My addess.no-ip.org is set with IP:........(dynamic IP) with using NAT and Proxy enabled.."Some thing like that. Then next step i go to browser, but i can not access to my web site at: my address.no-ip.org. I dont know why. ANy one help please. Show me step by step as well as with commands. Should i do anything with "Server setting" menu cause they have "http server", "NFS server, "Domain Name service" Tools in the menu...How can i config so that the dynamic IP match with my web site.......????. Now i installed no-ip. Thanks for help
 
Old 01-14-2003, 05:09 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
if it works from the server at http://127.0.0.1

then it should work

run this after connecting

[code]
service httpd restart
[code]

Last edited by DavidPhillips; 01-14-2003 at 05:10 AM.
 
Old 01-14-2003, 05:21 AM   #3
therock
LQ Newbie
 
Registered: Jan 2003
Posts: 8

Original Poster
Rep: Reputation: 0
here what i command:"
[root@localhost root]# killall noip
[root@localhost root]# noip
[root@localhost root]# grep noip /var/log/messages

Jan 14 02:20:11 localhost noip[1896]: noip started as a background process with
NAT and PROXY enabled
Jan 14 02:20:12 localhost noip[1896]: ! LIA = 64.169.104.250, IP = 64.169.104.250
[root@localhost root]#
 
Old 01-14-2003, 05:27 AM   #4
therock
LQ Newbie
 
Registered: Jan 2003
Posts: 8

Original Poster
Rep: Reputation: 0
HEy thank y ou David I made i t work..
i seem not to run httpd service..after i run "service httpd restart" It work
Thank again.. I have one more question...So how can i set up No-ip and Httpd
run at the startup.
 
Old 01-14-2003, 05:38 AM   #5
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
you can put commands you want to run at startup in /etc/rc.d/rc.local

for http you can run it in the init.d scripts, to do this use this command
Code:
chkconfig httpd on
 
Old 01-14-2003, 05:51 AM   #6
therock
LQ Newbie
 
Registered: Jan 2003
Posts: 8

Original Poster
Rep: Reputation: 0
so how about i add No-ip command into rc.local
 
Old 01-14-2003, 05:55 AM   #7
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
yes that's the best way to do it I think
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
During Red Hat Linux 9 install: error "No devices found to install Red Hat Linux" rbradtx Linux - Newbie 11 06-25-2010 05:55 PM
Red Hat custom Kernel compilation mini-How-To for Red Hat 8-9 Thetargos Red Hat 431 04-13-2007 06:19 AM
Red Hat Linux 9.0 vs Red Hat AS 3.0 mhamilton3 General 2 08-31-2004 10:43 PM
Red Hat does not plan to release another product in the red hat linux line... Whitehat General 5 11-03-2003 07:33 PM
Red Hat Enterprise vs. Red Hat Linux Project RedHatMN Linux - Distributions 2 07-29-2003 05:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration