Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-17-2013, 02:11 PM   #1
LQ Newbie
Registered: Mar 2013
Posts: 6

Rep: Reputation: Disabled
No connection to the network via port eth0

I have no connection to the network via port eth0 - what should I do?
I have installed CentOS 6 on VMWare player 3.1
I did not know how to touch the FW setting if needed.
Old 03-17-2013, 03:19 PM   #2
Senior Member
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,289

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Post some basic information first -- what does "ifconfig eth0" show? How did you set up the virtual network in VMWare? It has a number of configuration options (host only, brudged, or NAT come to mind) for the virtual network it sets up. Which one did you choose?

The basic idea here is to see if you're getting an IP address assigned, and if not what the configuration options for your virtual network are.
Old 03-17-2013, 05:05 PM   #3
LQ Newbie
Registered: Mar 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
Internet access for VMWare

I shall copy and send you the ifcfg-eth0 credentials (one I recall is "BOOTPROT=dhcp".
My virtual network is set to "Bridged" (I ma using at home ADSL modem-router to the public ISP.
How do I check whether I was assigned an IP address?
Meanwhile greatly appreciate your prompt response (I have registered today to LQ and it is great !)
Old 03-18-2013, 01:52 AM   #4
LQ Newbie
Registered: Mar 2013
Posts: 3

Rep: Reputation: Disabled
can you post result of ifconfig -all
Old 03-18-2013, 03:00 PM   #5
LQ Newbie
Registered: Mar 2013
Posts: 6

Original Poster
Rep: Reputation: Disabled
It seemes that changing the virtual machine FW setting from "Bridged" to "NAT" resolved the issue - thank you for your quick suport so far.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Network eth0 activated upon boot in ifcfg-eth0; but no network connection after login TomRaaijmakers Linux - Networking 1 06-17-2010 09:29 AM
[SOLVED] Cannot establish connection on port 80 on wlan0 or eth0 dracofhc Linux - Networking 5 12-14-2009 10:08 AM
Eth0 shows up as nic port 2 - network schnanigans Thaidog Linux - Networking 5 02-29-2008 01:01 PM
Using eth0 as default network connection JoeDuncan Linux - Networking 6 12-20-2006 01:32 PM
eth0 is up but no network connection? yednotek Linux - Newbie 4 04-01-2006 04:21 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:10 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration