LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-30-2003, 04:52 PM   #16
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30

btw, what is the output of (in terms of permissions):

ls -l /mnt/windows
ls -ld /mnt/windows
 
Old 03-31-2003, 06:43 PM   #17
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Original Poster
Rep: Reputation: 30
a bunch of dr-xr-xr-x for the first one, even when logged in as root
drwxrwxrwx 14 root users 16384 Dec 31 1969 /mnt/files
for the second.
 
Old 03-31-2003, 07:28 PM   #18
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
Can you post your fstab line as it stands right now? and let me get this straight, everything mounts just dandy at boot time, only there is no write permissions? what do you do next? does chmod'ing it help?

On a side not, turn off the auto option and mount it manually with all the option you used in the fstab. any errors?
 
Old 03-31-2003, 07:31 PM   #19
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
umm....btw, did you make the group of /mnt/files 'users' yourself?
and lastly, do you use any gid/uid when mounting?
 
Old 03-31-2003, 09:18 PM   #20
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Original Poster
Rep: Reputation: 30
/dev/hda6 /mnt/files vfat auto,users,rw,exec,suid,gid=100,umask=000 0 0

this is what it says right now, and yes I added gid=100 myself.
chmod'ing helps, yes, if I am logged in as root. give me a minute and i'll turn off the auto and manually mount it ...
 
Old 03-31-2003, 09:26 PM   #21
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Original Poster
Rep: Reputation: 30
OK, manually mounting it,
mount -t vfat -O rw /dev/hda6 /mnt/files
had the same results: all files under the mount point were 0555. and if I chmod everything, it loses permissions when I unmount the filesystem.
 
Old 03-31-2003, 09:38 PM   #22
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
umount /dev/hda6 #if mounted
manually mount it again, using -O debug,users,rw,exec,suid,gid=100,umask=000

see if that helps to figure out the problem.
I'm running out of ideas, and I don't have a fat partition to play with... the only thing I can right now think of is the debug option plus playing with your gid (how well does it work if you leave out the gid?)

Maybe someone will come along, if this still doesn't help...
 
Old 03-31-2003, 09:44 PM   #23
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Original Poster
Rep: Reputation: 30
when I mounted manually, I left out the gid, again no write perms.
what does debug do?
and I tried this:
cd /mnt/files
chmod 0777 *
and it gave me a bunch of errors and only made everything 0755:
chmod: changing permissions of `dir_name' (requested: 0777, actual: 0755): Operation not permitted
 
Old 03-31-2003, 09:57 PM   #24
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
man mount:

Quote:
debug Turn on the debug flag. A version string and a list of file system parameters will be printed (these data are also printed if the parameters appear to be inconsistent).
what's messing with my head is not even root has write permissions. the same thing happens if you mount manually with root?
 
Old 03-31-2003, 10:02 PM   #25
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
play around with what options are selected. From doing some searching, this _should_ work:

mount -t vfat -o users,rw,exec,umask=000 /dev/hda6 /mnt/files
 
Old 03-31-2003, 10:05 PM   #26
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Original Poster
Rep: Reputation: 30
yes, works in root.
now i'm going to check to see if it will work in automount for users.
 
Old 03-31-2003, 10:09 PM   #27
stevenhasty
Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Slackware-current
Posts: 169

Original Poster
Rep: Reputation: 30
perfect! thanks!
 
Old 03-31-2003, 10:30 PM   #28
cuckoopint
Member
 
Registered: Feb 2003
Distribution: Debian
Posts: 797

Rep: Reputation: 30
cool.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
Mount point Making ??? faisalraja Linux - Newbie 3 06-08-2004 05:53 PM
Users cannot mount or access mounted windows vfat partitions (Distro: Gentoo Linux) kamel Linux - Software 6 05-15-2004 07:08 PM
What if making /var/mail world-writeable? J_Szucs Linux - Security 4 08-18-2002 10:33 AM
HELP! Error from mount: drive is write-protected... won't mount writeable. system Linux - General 2 12-27-2001 10:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration