LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   making a vfat mount point writeable for users (https://www.linuxquestions.org/questions/linux-newbie-8/making-a-vfat-mount-point-writeable-for-users-52381/)

stevenhasty 03-29-2003 01:29 PM

making a vfat mount point writeable for users
 
Running redhat 8.0 psyche. I checked out the man page on editing fstab, but I don't think this has what I want, which is to automount my shared partition (shared with windows, not a system partition) and make it writeable for users. I made it automount, but I'm not sure how to go about making it writeable. When I try to change the write permissions or group settings on the mount folder in X logged in as root, it says I don't have permission, and the same happened when I tried a chmod. The mount point, for reference, is /mnt/files and the partition is /dev/hda6 and my fstab file says this:
/dev/hda6 /mnt/files vfat auto,user 0 0

loke137 03-29-2003 01:35 PM

chmod 755 as user doesnt help?

stevenhasty 03-29-2003 01:49 PM

Nope, I can't seem to give users permission to write to the mount point even from root. "Operation not permitted."

loke137 03-29-2003 03:16 PM

you are writing to vfat or NTFS( the later is not well supported, meaning only experimental!)

stevenhasty 03-29-2003 03:29 PM

vfat ...

cuckoopint 03-29-2003 04:24 PM

well, first try setting 'rw' option explicitly with the others.
ie. user,auto,rw

Second, you may want to look at 'man mount'. The things that stand out the most are the entries for 'user' (and what it does), and under "Mount options for fat" you may need to set the umask explicitly.

stevenhasty 03-29-2003 06:38 PM

alright, I changed the options to include gid=100,rw,users and I'm still not able to change write permissions as root or be able to write as a normal user or a user within the group assigned to the mount point. I looked in man mount, but it does not explain what values to assign to umask, other than state that the value must be an octal. What is umask and what value would I set it to?

cuckoopint 03-29-2003 06:50 PM

man umask

the easiest hack would be umask=000 and will work in most cases (unless you have serious security issues - then do the math. If you don't know how to handle the numbers also check out 'man chmod')

stevenhasty 03-29-2003 06:55 PM

I had yet to learn there is a man page for all these things. From now on, I'll try that first...

cuckoopint 03-29-2003 06:59 PM

man topic
info topic
apropos topic

^all very useful. Also, the "See Also" sections are sometimes helpful to look for further info.

stevenhasty 03-29-2003 07:00 PM

hmmm ... when I tried man umask all I got was a listing of bash commands. I'm going to try the umask=000 since security issues are not very important ...

cuckoopint 03-29-2003 08:17 PM

Well, I was going to post you mine, but i just did a google search since I remembered there are many manpages that have been compiled for net use. For example:

http://www.hmug.org/man/2/umask.html

yeah, umask=000 should work, while umask=022 would give user writes, but no one else.

stevenhasty 03-29-2003 11:01 PM

umask=000 works great. Thanks.

stevenhasty 03-30-2003 03:19 PM

Alright, I've got the mount point writeable, but I can't get my permissions to stick on directories within the mount point. How would I make all files under the mount point writeable on startup?

cuckoopint 03-30-2003 03:50 PM

two things I can think of:

1. your gid/uid is funky (what is it right now?)
2. your permissions on the mounted directory are funky (ie. ls -l /mnt/windows - or whatever it may be)


All times are GMT -5. The time now is 08:32 AM.