LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2005, 01:15 PM   #16
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled

What does it show when you do "ls -l /dev/cdrom" in a terminal (again without the quotes)?
 
Old 07-06-2005, 01:16 PM   #17
Linux_n00b_57
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Slackware 11.0
Posts: 148

Original Poster
Rep: Reputation: 15
i did, and still nothing...do i have to restart my wm?
 
Old 07-06-2005, 01:20 PM   #18
Linux_n00b_57
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Slackware 11.0
Posts: 148

Original Poster
Rep: Reputation: 15
ls: /dev/cdrom is not a directory
 
Old 07-06-2005, 01:48 PM   #19
Ha1f
Member
 
Registered: Jun 2005
Location: University of Maryland
Distribution: FreeBSD
Posts: 268

Rep: Reputation: 30
in your editor change the fstab to whatever you identify your cdrom drive as.
 
Old 07-06-2005, 02:01 PM   #20
Linux_n00b_57
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Slackware 11.0
Posts: 148

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Ha1f
in your editor change the fstab to whatever you identify your cdrom drive as.
So in the fstab file :
/dev/hda1 / reiserfs defaults 1 1
/dev/hda2 /hda2 /reiesers defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto owner, ro 0 0
/dev/fdo /mnt/floppy auto noauto owner 0 0
/dev/pts /dev/pts devpts gid=5, mode=620 0 0
/proc /proc proc defaults 0 0

Change the cdrom line? and change cdrom to cd? or hdc?
 
Old 07-06-2005, 02:09 PM   #21
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Quote:
Originally posted by Linux_n00b_57
ls: /dev/cdrom is not a directory
Did you type /dev/cdrom/? If so, there shouldn't have been a / at the end.
 
Old 07-06-2005, 02:14 PM   #22
Linux_n00b_57
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Slackware 11.0
Posts: 148

Original Poster
Rep: Reputation: 15
Yes i did
 
Old 07-06-2005, 02:50 PM   #23
jupals
LQ Newbie
 
Registered: Mar 2005
Posts: 3

Rep: Reputation: 0
noob_57 are you sure about this line??

/dev/cdrom /mnt/cdrom iso9660 noauto owner, ro 0 0

coz if it doesnt mount then it probably should fire you with no such device message...
try changing from that line above to:

/dev/hda /mnt/cdrom iso9660 noauto owner, ro 0 0

or

/dev/hdb /mnt/cdrom iso9660 noauto owner, ro 0 0

or

/dev/hdc /mnt/cdrom iso9660 noauto owner, ro 0 0

or

/dev/hdd /mnt/cdrom iso9660 noauto owner, ro 0 0


i've tried that before, the first time i run linux, and that i'm not sure where my cdrom was configured.
 
Old 07-06-2005, 02:58 PM   #24
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
That's why I told him to do "ls -l /dev/cdrom", it should show to what device it's linked to.
 
Old 07-06-2005, 03:22 PM   #25
Ha1f
Member
 
Registered: Jun 2005
Location: University of Maryland
Distribution: FreeBSD
Posts: 268

Rep: Reputation: 30
do like jupals said--
but
try hdb first, because hda is your hard drive...
 
Old 07-06-2005, 07:52 PM   #26
Linux_n00b_57
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Slackware 11.0
Posts: 148

Original Poster
Rep: Reputation: 15
Ok, hdb got the best resault...which would be the same as cdrom....everything else said it was valid.
Are you sure this is the problem because i will still mount a normal CD without a problem.
 
Old 07-07-2005, 07:12 AM   #27
Ha1f
Member
 
Registered: Jun 2005
Location: University of Maryland
Distribution: FreeBSD
Posts: 268

Rep: Reputation: 30
so its mounting the burned cds now?

if it is, is it still mounting the cds that werent burned?
 
Old 07-12-2005, 08:58 AM   #28
Linux_n00b_57
Member
 
Registered: Jun 2005
Location: Canada
Distribution: Slackware 11.0
Posts: 148

Original Poster
Rep: Reputation: 15
sorry i wasn't valid....sorry for not replying sooner but i was gone away...but it still won't mount anything thats burned...well i haven't tried the slackware disks, but the ones i want won't mount.
 
Old 07-12-2005, 09:02 AM   #29
Ha1f
Member
 
Registered: Jun 2005
Location: University of Maryland
Distribution: FreeBSD
Posts: 268

Rep: Reputation: 30
in your fstab file, change the files sysytem on your cdrom to auto.

so:

/dev/hdb /mnt/cdrom auto noauto owner,ro,user 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount a nfs mount from linux client to AIX nfs server dennyqian AIX 13 04-12-2016 12:30 AM
CD Mount in Suse Linux pakuson Linux - Hardware 1 11-14-2005 03:56 AM
fat32 mount in linux ash_great Linux - Software 1 07-30-2005 05:50 AM
Mount UFS HD In Linux TechnoGecko Linux - General 2 04-29-2004 09:01 PM
I cannot mount what Linux will not let me mount TheTwistedSpasm Linux - General 3 01-27-2004 01:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration