LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-08-2004, 06:20 AM   #1
orion666
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Rep: Reputation: 0
Question LILO 22.5.7.2 dulal boot


Hello. im absolute newbie at linux. yetserdeay i just managed to install Linux (Debian) on my comp and got a little bit confused.
i have 4 partitions on my hard drive, hd1(system), hd2 for WinXP; and hd3 and hd4(swap) for linux. after the first reboot i got a window with a caption - LILO 22.5.7.2... , to choose a drive to boot from.
it looks something like this:

hda1(NT) <---thats where my winxp system is
hda2(NT)
LINUX
the default boot drive is actually hda2 (???). whell, what i managed to do from within linux is to change "hda1(NT)" name to "Windows" but i couldnt make it default boot drive.

i can choose to boot from hda1 manulally and my winxp works fine, but it windows doesnt recognise the other two partitions(ext3 file system). is that should be that way?

1. how can i change the default boot drive to hda1(Windows) and remove hda2 from that LILO list because it is not bootable???

2. is it possible to get rid of that LILO, and when starting winxp, there would be a list of operating systems that i could choose from(winXp or Linux) (like when hitting "F8 or whatever" key)?
 
Old 02-08-2004, 07:47 AM   #2
shadow.blue
Member
 
Registered: Jan 2003
Distribution: gentoo (2.6.5-gentoo)
Posts: 73

Rep: Reputation: 15
look at your /etc/lilo.conf file, there is everything you need.

To remove a partition from the boot-menu, simply delete a block, like

image = /boot/bzImage-2.6.0apm
root = /dev/hda1
label = 2.6.0apm
read-only


To make another partition default, change the line
default = xxx
where xxx is the label of your new default partition.

To your second question, it is not possible like you say.

You need a bootloader, like lilo or grub.

You could alternatively use loadlin, where you boot default in win_xp and if you want linux
you go to command line mode and tipe in "loadlin"
 
Old 02-08-2004, 10:57 AM   #3
orion666
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Original Poster
Rep: Reputation: 0
aaa, how can i override that lilo.conf file? its read-only.
 
Old 02-08-2004, 12:17 PM   #4
shadow.blue
Member
 
Registered: Jan 2003
Distribution: gentoo (2.6.5-gentoo)
Posts: 73

Rep: Reputation: 15
You have to be root.

If it still dont work, then set the writeable flag to the file.
chmod +w /etc/lilo.conf

Or use vim as editor, and save the file with :w!, where ! means override the read-only. (only works if you own the file, so you have to be root anyway)
 
Old 02-08-2004, 01:07 PM   #5
orion666
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Original Poster
Rep: Reputation: 0
Well. im an absolute lama i guess. i dont know how to save a file with vim. there are no such menu and i dont know how i could do this from terminal.

ok.
thats what i do:
i go to the terminal. becoming root (su, psw) then getting to etc/ (cd /etc)
then i write
chmod +w /etc/lilo.conf
then
vim lilo.conf

and then i try to rewrite some things with pressing two times "insert" key, because otherwise it wont let me to modify anything.

what to do next?

or am i doing something wrong?
 
Old 02-12-2004, 12:22 PM   #6
Dominik
Member
 
Registered: Nov 2003
Distribution: slackware9.1/freebsd5.2
Posts: 53

Rep: Reputation: 15
go in a terminal & type :

man vim (man produces the doc related to the command you type)

it explains you how to use it.

Try this link too

www.vim.org/htmldoc/howto.html
 
Old 02-12-2004, 03:41 PM   #7
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
To save things in vim you have to use :write!. Depending on what desktop enviroment you are using, you can kwrite (kde) or gedit (gnome), and besides them, there are loads of none-command line text editors out there.
 
Old 02-13-2004, 12:35 AM   #8
orion666
LQ Newbie
 
Registered: Feb 2004
Posts: 4

Original Poster
Rep: Reputation: 0
im using a terminal, because i know how to become root there (su). im using gedit, and when i open lilo.conf with non-command editor, i dont know how to become root without using the terminal to overwrite this read-only file.
 
Old 02-13-2004, 06:36 PM   #9
Inexactitude
Member
 
Registered: Oct 2003
Distribution: Slackware 12.2, Ubuntu 9.04
Posts: 477

Rep: Reputation: 30
Well, if you su to root and then run gedit from the console, you'll be able to save the changes as root.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
lilo boot screen wont show windows to boot into!! please help Fear58 Linux - General 3 07-10-2004 10:55 PM
Lilo lost, Install disk failing to restore Lilo on dual boot? Dobie Linux - Newbie 2 05-05-2004 06:00 PM
I install Slackware on small HDD with LILO, can't boot LILO? kleptophobiac Slackware 4 08-10-2003 05:50 PM
lilo and openmosix was just installed and was added to lilo boot menu but.. kublador Linux - Software 0 06-18-2003 02:59 AM
Made a bootdisk with RedHat 7.1 to boot: Gave me SYSLINUX, not LILO:Want to use LILO Colonel Panic Linux - Software 0 08-17-2001 07:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration