LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-03-2017, 06:11 PM   #1
zillur
Member
 
Registered: Apr 2015
Posts: 217

Rep: Reputation: Disabled
libgtk2 install problem


Hi there,
I was trying to install MEGA in my centos7 workstation. It gives me this error:
Code:
[zillur@genomics tools]$ sudo dpkg -i megacc_7.0.26-1_amd64.deb 
(Reading database ... 80 files and directories currently installed.)
Preparing to unpack megacc_7.0.26-1_amd64.deb ...
Unpacking megacc (7.0.26) over (7.0.26) ...
dpkg: dependency problems prevent configuration of megacc:
 megacc depends on libgtk2.0-0 (>= 2.0); however:
  Package libgtk2.0-0 is not installed.
 megacc depends on libgtk2.0-bin (>= 2.0); however:
  Package libgtk2.0-bin is not installed.

dpkg: error processing package megacc (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 megacc
So I tried to install libgtk2.0-0. But:
Code:
[zillur@genomics tools]$ sudo yum install libgtk2.0-dev
[sudo] password for zillur: 
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.us.leaseweb.net
 * epel: mirror.us.leaseweb.net
 * extras: mirror.us.leaseweb.net
 * updates: mirror.us.leaseweb.net
No package libgtk2.0-dev available.
Error: Nothing to do
What should I do now? Thanks in advance.
Best regards
Zillur
 
Old 07-03-2017, 06:53 PM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 19.1 MATE
Posts: 8,016
Blog Entries: 5

Rep: Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861Reputation: 2861
Forgive me for my naviety, but why are you not installing the rpm version of MEGA?

Also, why are you using dpkg as a package manager to install debs on CentOS and then using yum to install those packages' dependencies? Have you found some way that each package manager's database also keeps track of all packages installed by the other?

libgtk2.0-dev is a Debian-family package. It won't be in the standard CentOS repos.

If I were you, I would stick to rpm's and yum. Using both yum and dpkg on the same system willy-nilly is a recipe for trouble.

Last edited by hydrurga; 07-04-2017 at 05:11 AM.
 
Old 07-03-2017, 09:19 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
I also have not heard of using dpkg on centos. You can use yum search gtk (gnome tool kit) to find the centos names of the files you require. Debian uses many packages starting with "lib". But redhat, centos, and fedora don't use the same convention.

Although, it's interesting to see that you got dpkg to actually do something on centos.
 
Old 07-03-2017, 10:41 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1162Reputation: 1162Reputation: 1162Reputation: 1162Reputation: 1162Reputation: 1162Reputation: 1162Reputation: 1162Reputation: 1162
Installing the rpm is your best practice. <seriously>
Why not use yum to do a search?

If yum can't find it to install it add a repo if need be:-

https://sick.codes/how-to-install-me...-centos-7-vps/
https://pkgs.org/
https://centos.pkgs.org/7/nux-dextop-x86_64/4/

https://www.geekytuts.net/shell-tric...ools-centos-7/

https://centos.pkgs.org/7/nux-dextop...86_64.rpm.html

https://www.centos.org/docs/5/html/D...rpm-using.html

https://www.linuxtechi.com/download-...ntos-7-rhel-7/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where is libgtk2.0-dev drink87 Linux - Newbie 1 12-02-2012 10:10 AM
libgtk2.0-bin install problem darknails Linux - General 5 07-19-2006 04:15 PM
libgtk2.0-dev allelopath SUSE / openSUSE 1 03-31-2006 04:36 AM
Error whilst intalling 'libgtk2.0-dev', 'Broken Pipe'?! Eerath MEPIS 4 08-15-2005 09:47 AM
problems setting up libgtk2.0-common via apt-get on debian unstable f3lix Linux - Software 1 04-15-2003 12:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration