LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-15-2006, 05:04 PM   #1
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Rep: Reputation: 15
KDE instead of Gnome


I've successfully installed Debian etch from the netinstal, however I would prefer to use KDE instead of Gnome. The problem is that although I believe I downloaded and installed the KDE package, I have no idea how to disengage Gnome and put KDE in its place.
Additionally..... is there a way to get GRUB to load graphically rather than terminal?

I have ordered the Linux Cookbook so that I can research problems in the future.

Thanks all
 
Old 08-15-2006, 05:33 PM   #2
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Your defualt runlevel is probably 2. So check to see if S99gdm is in /etc/rc2.d/ . As for selecting your default window manager, When you boot up you should see session. Click on it and change to KDE. It will then ask you if you want it to be your defualt or run it just this once. You may not get the login manager unitl you get your runlevel correct.

Also if you don't see S99gdm then check /etc/rc3.d or /etc/rc4.d/. If it is not there then try creating the symlink S99gdm to I think /usr/bin/gdm.
 
Old 08-15-2006, 08:51 PM   #3
AwesomeMachine
Senior Member
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 3,003

Rep: Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518Reputation: 518
apt-get install kdm

dpkg-reconfigure xserver-common

choose kdm
 
Old 08-16-2006, 09:03 AM   #4
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
http://images.linuxquestions.org/questions/images/smilies/confused.gifAlthough I appreciate the above responces, (I really do appreciate that you've taken the time to try and help) I have no idea how to begin implementing the solutions you have suggested. I purposely posted in the newbie forum because I'm new to Linux configuration.
I don't know how other people new to Linux work on solving problems, but I do as much searching on the internet for information, solutions, instructions as I can find. When I can't find the specific information, or am unable to understand the instructions (usually prepared for someone familiar with programing, or with indepth understanding of Linux) then I will post a help plea here.

I do however appreciate that you took the time to offer assistance.
 
Old 08-16-2006, 09:12 AM   #5
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
What parts are you exactly having problems on so we can be more specific and give you better instructions or advice on how to get your problem solved. Both of our solutions that was given were commands that should be entered into a terminal. like Eterm, Xterm, rxvt, etc. Again just let us know how we can help you and where you are having problems.
 
Old 08-16-2006, 09:42 AM   #6
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
Thanks.

ok.....this is what I found when asking to display contents of S99gdm :

#! /bin/sh
### BEGIN INIT INFO
# Provides: x-display-manager gdm
# Should-Start: console-screen
# Required-Start: $local_fs $remote_fs
# Required-Stop: $local_fs $remote_fs
# Default-Start: 2 3 4 5
# Default-Stop: S 0 1 6
# Short-Description: GNOME Display Manager
# Description: Debian init script for the GNOME Display Manager
### END INIT INFO
#
# Author: Ryan Murray <rmurray@debian.org>
#
set -e

PATH=/sbin:/bin:/usr/sbin:/usr/bin
DAEMON=/usr/sbin/gdm
DEBCONF_DAEMON=/usr/bin/gdm

test -x $DAEMON || exit 0

if [ -r /etc/default/locale ]; then
. /etc/default/locale
export LANG LANGUAGE
fi

. /lib/lsb/init-functions

# To start gdm even if it is not the default display manager, change
# HEED_DEFAULT_DISPLAY_MANAGER to "false."
HEED_DEFAULT_DISPLAY_MANAGER=true
DEFAULT_DISPLAY_MANAGER_FILE=/etc/X11/default-display-manager

case "$1" in
start)
if [ -e "$DEFAULT_DISPLAY_MANAGER_FILE" -a "$HEED_DEFAULT_DISPLAY_MANAGER" = "true" -a "$(cat $DEFAULT_DISPLAY_MANAGER_FILE)" != "$DEBCONF_DAEMON" ]; then
log_action_msg "Not starting GNOME Display Manager; it is not the default display manager"
else
log_daemon_msg "Starting GNOME Display Manager" "gdm"
start_daemon $DAEMON
log_end_msg $?
fi
;;
stop)
log_daemon_msg "Stopping GNOME Display Manager" "gdm"
set +e
start-stop-daemon --stop --quiet --pidfile /var/run/gdm.pid \
--name gdm --retry 5
set -e
log_end_msg $?
;;
reload)
log_daemon_msg "Scheduling reload of GNOME Display Manager configuration" "gdm"
set +e
start-stop-daemon --stop --signal USR1 --quiet --pidfile \
/var/run/gdm.pid --name gdm
set -e
log_end_msg $?
;;
restart|force-reload)
$0 stop
$0 start
;;
*)
echo "Usage: /etc/init.d/gdm {start|stop|restart|reload|force-reload}"
exit 1
;;
esac

exit 0


I have no idea (at this time) what any of that means. Back in a moment after I check into the next suggestion you provided.
 
Old 08-16-2006, 09:50 AM   #7
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Well that means that you have that their. Check your inittab to see what runlevel you boot up to. I probably should made my instructions a little more clear. My fault. You did not have vi the file. We just need to see if you have that in your directory which you do.

Last edited by jstephens84; 08-16-2006 at 09:52 AM.
 
Old 08-16-2006, 10:03 AM   #8
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
where might I find my "initab" ?

sorry you have to get so basic to help me.
 
Old 08-16-2006, 10:07 AM   #9
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
also, when I tried booting up again, the bootloader quickly got me to the screen where I select which OS I want to run, ( XP or Debian ) and once I selected Debian everything moves so fast....seemingly hundreds of text lines scrolling up the screen, that I have no idea where I might find "session", per your suggestion.
 
Old 08-16-2006, 10:15 AM   #10
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
inittab can be found under /etc. You will have to read carefully through that file. my suggestion is befor editing that file issue a cp /etc/inittab /etc/inittab_bkup to create a backup.
 
Old 08-16-2006, 10:25 AM   #11
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
You won't find the Session option until you get to a graphical login. So once you get your pc up to a graphical login then we shall be able to work on part two of your problem
 
Old 08-16-2006, 11:16 AM   #12
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
I thought I had the KDE instead of Gnome solved, thanks to your last post. I found the "session" option at the graphical login page. I selected KDE and rebooted, but it came up Gnome again. It's not a tragic problem.... I'm just more familiar with KDE; able to find my way around better.

I did find the inittab file, and you were right.... the default runlevel is set to 2.
What should it be set to?
I also tried making a backup file per your advice, but got an error because I did not specify where to save the backup file to. I need to learn how to use command lines.

Hopefully "The Linux Cookbook" will help me learn my way around Linux.
 
Old 08-16-2006, 11:33 AM   #13
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
When you select gnome it will ask you to make it the default or to use it just this time. Select make it defualt. As far as backup of config files Here is what I normally do.

Code:
mkdir /usr/local/conf_bkup
Now to backup the file inittab
Code:
cp /etc/inittab /etc/inittab_bkup
when you type in cd /etc/inittab if you hit tab once you get to the init part it will fill in the rest. I would definetly use the linux cook book. It will help you out. For right now give this site a try. It will get you going a little bit.
 
Old 08-16-2006, 11:49 AM   #14
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
As you were providing excellent instructions, I was rebooting and trying to get the session thing worked out again. The option screen this time asked if I wanted to make KDE my default.....something it did not offer previously (for some reason) probably an error on my part.

So thanks to your help, I now have KDE operating. much appreciated.
 
Old 08-16-2006, 11:55 AM   #15
Perquisitor
Member
 
Registered: Jul 2004
Location: Panama City Beach, Florida
Distribution: Debian Etch
Posts: 150

Original Poster
Rep: Reputation: 15
also.......... thanks so much for the link to that Linux Command website.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a Igel that comes with kde and gnome. gnome can not view the network thefedexguy Linux - Networking 5 01-21-2017 03:35 PM
Gnome/KDE Desktop Folder & Gnome Autostart ihatethedekoys Linux - General 1 08-07-2006 11:16 AM
Aborted KDE 3.5.1 Install while using KDE 3.4 and KDE and Gnome Won't Boot cheetahman SUSE / openSUSE 5 03-04-2006 11:03 AM
KDE/GNOME switching? And how to connect to the internet in GNOME SuSE 10.0 Cards_STL SUSE / openSUSE 14 10-29-2005 07:21 PM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 09:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration