LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-21-2011, 06:49 AM   #1
innovator_rfc
LQ Newbie
 
Registered: Aug 2011
Location: Sydney, Australia
Distribution: Fedora 15 with Gnome 3
Posts: 1

Rep: Reputation: Disabled
Lightbulb installing program which bombs out with an error at 'YUM: running rpm_check_debug


Hi,
I'm using YUM Extender to install some software on a Toshiba Satellite P30 Laptop, running Fedora 15 and Gnome 3. I tried to remove the offending packages using Remove on Pending Action. On Apply after removal, it still tries to install the removed packages. I don't want to have to go through the whole selection procedure again for the other packages. What can I do ?


18:16:20 : Downloaded : (9/27): EMBOSS-6.3.1-10.fc15.i686.rpm ( 7.9 M )
18:16:47 : Downloaded : (10/27): EMBOSS-devel-6.3.1-10.fc15.i686.rpm ( 175 k )
18:19:43 : Downloaded : (11/27): EMBOSS-libs-6.3.1-10.fc15.i686.rpm ( 1.1 M )
18:19:45 : Downloaded : (12/27): ftplib-3.1-7.fc15.i686.rpm ( 17 k )
18:26:41 : Downloaded : (13/27): kdebase-4.6.5-1.fc15.i686.rpm ( 2.9 M )
18:27:25 : Downloaded : (14/27): kdebase-libs-4.6.5-1.fc15.i686.rpm ( 285 k )
18:27:33 : Downloaded : (15/27): libXcursor-devel-1.1.11-3.fc15.i686.rpm ( 22 k )
18:27:46 : Downloaded : (16/27): libXi-devel-1.4.3-1.fc15.i686.rpm ( 98 k )
18:27:48 : Downloaded : (17/27): libXinerama-devel-1.1.1-2.fc15.i686.rpm ( 12 k )
18:27:51 : Downloaded : (18/27): libXrandr-devel-1.3.1-2.fc15.i686.rpm ( 19 k )
18:27:57 : Downloaded : (19/27): libXv-devel-1.0.6-2.fc15.i686.rpm ( 38 k )
18:28:17 : Downloaded : (20/27): libeplplot-6.3.1-10.fc15.i686.rpm ( 152 k )
18:28:23 : Downloaded : (21/27): libeplplot-devel-6.3.1-10.fc15.i686.rpm ( 54 k )
18:29:02 : Downloaded : (22/27): libharu-2.1.0-3.fc15.i686.rpm ( 319 k )
18:29:13 : Downloaded : (23/27): libmng-devel-1.0.10-5.fc15.i686.rpm ( 85 k )
18:29:24 : Downloaded : (24/27): mpfr-devel-3.0.0-4.fc15.i686.rpm ( 63 k )
18:51:24 : Downloaded : (25/27): qt-devel-4.7.3-8.fc15.i686.rpm ( 10 M )
19:09:47 : Downloaded : (26/27): qt3-devel-3.3.8b-35.fc15.i686.rpm ( 8.7 M )
19:09:50 : Downloaded : (27/27): xbiso-0.6.1-6.fc15.i686.rpm ( 17 k )
19:09:50 : YUM: Running rpm_check_debug

19:11:11 : ERROR: Error in yum Transaction : Test Transaction Errors: file /usr/bin/remap from install of EMBOSS-6.3.1-10.fc15.i686 conflicts with file from package wcstools-3.8.1-2.fc15.i686

20:45:08 : YUM: Package matching BackupPC-3.1.0-17.fc15.i686 already installed. Checking for update.

20:45:38 : YUM: Running rpm_check_debug

20:45:39 : ERROR: Error in yum Transaction : [u'ERROR with rpm_check_debug vs depsolve:', 'file /usr/bin/remap from install of EMBOSS-6.3.1-10.fc15.i686 conflicts with file from package wcstools-3.8.1-2.fc15.i686', u'Please report this error at http://yum.baseurl.org/report']


Thank you for your time
Roderic


Part of my question is why didn't Yum Extender remove EMBOSS as I requested. I checked the package list after deleting, and EMBOSS was no longer on the list. I asked it to process the new list and it still tried to process EMBOSS. Why ?

Last edited by innovator_rfc; 09-02-2011 at 03:52 AM. Reason: only half answered
 
Old 08-21-2011, 07:25 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,361
Blog Entries: 55

Rep: Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547Reputation: 3547
If you don't need wcstools then remove it before continuing, elif you need wcstools then this conflict IMO can't be resolved without some CLI-fu. Download (as in 'yum --downloadonly') and query ('rpm -qpi /path/package|grep Reloc') the packages to see if they're relocatable. If they are both then decide which package has a higher priority for you then remove the lower priority one, elif only one of them is then that creates the decision for you ;-p Install as usual and then D/L the lower priority packages and install them using 'rpm' for example with the "--prefix" or "--relocate /usr=/usr/local --relocate /etc=/usr/local/etc" switches. Elif this isn't working for you search Fedoras bug tracker and file a report as both EMBOSS and wcstools are in the Applications/Engineering group and they should (have upstream) fix things.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Running rc.local with additional routes produces SIOCADDRT file exists and bombs johnmchugh623 Debian 1 08-27-2010 08:38 AM
I updated my Fedora 10 using YUM now I get ERROR with rpm_check_debug vs depsolve ddeeks Linux - General 5 05-13-2009 03:59 PM
Yum giving ERROR with rpm_check_debug vs depsolve repeatedly ajaygoeslinux Linux - Software 5 05-10-2009 11:15 AM
Error running yum while installing some packages cuco76 Fedora 2 07-09-2004 03:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration