LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2005, 07:16 PM   #1
phil81uk
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Rep: Reputation: 0
How to enable Active FTP in system-config-securitylevel


Hi,

I've just started playing with my first dedicated server. I bought it so that I can host a Public FTP site on it. I started VSFTPD and used system-config-securitylevel to allow FTP. And all works well!

But Internet Explorer wont log in. It gives the message "An error ocurred opening that folder on the FTP server. Make sure you have permission to open that folder. Details: The server name or address could not be resolved".

I tried disabling the server firewall in system-config-securitylevel and then IE can log in fine.

I understand that IE uses Active FTP and hence cannot get through the firewall.

Is there any way of setting up the Linux firewall so that Internet Explorer can connect?

Thankee
 
Old 12-06-2005, 11:53 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
During active FTP, the server connects back to your client machine to transfer the data, therefore you have to modify the firewall on your client machine to do so. Are you sure you don't mean passive FTP? I posted something about that recently in the network forum that you might want to take a look at (the search function should find it easily). I haven't used IE for FTP in years, but I was pretty sure it supported passive FTP. Active FTP makes a back connection from port 20 (ftp-data) on the server to some random port on the client machine. As long as that's enabled, you'd be set.
 
Old 12-09-2005, 09:19 AM   #3
SPo2
Member
 
Registered: Jun 2005
Posts: 88

Rep: Reputation: 15
Hi,

phil81uk,
i can't answer your question but its more asking for myself as i have ftp connection problems.

i uses RH 9, How do u allow ftp in :system-config-securitylevel.....what line do u add?
--none?

pls advise
 
Old 12-09-2005, 09:26 AM   #4
phil81uk
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,

I executed system-config-securitylevel and went to custom. In custom there is an option to enable FTP. I thought it only enables Active FTP, but now it turns out that it only enables Passive FTP (I had it the wrong way round).

Philip.
 
Old 12-09-2005, 09:42 AM   #5
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
If you haven't managed to get it working right yet, you can try the following,
Code:
#chkconfig vsftpd on
#service vsftpd start
Make sure that your firewall is configured to allow ftp and that your ethernet card is selected as a trusted device.
 
Old 12-12-2005, 04:39 AM   #6
phil81uk
LQ Newbie
 
Registered: Dec 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Well that was embarrissing... all I had to do was enable my ethernet card as a trusted device in system-config-securitylevel and presto ... it now accepts both Active and Passive FTP. (all that after reading a days worth of articles on IPtables!)

Thank you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
system-config-securitylevel mnauta Fedora 2 11-20-2004 05:45 PM
iptables defaults set by system-config-securitylevel: why are ports 50 and 51 opened? meonkeys Fedora 1 09-23-2004 12:41 PM
Set up dcc and timeserver with system-config-securitylevel fedetxf Fedora 0 08-17-2004 08:34 PM
redhat-config-securitylevel and SAMBA chromedog Programming 0 05-02-2004 05:48 PM
redhat-config-securitylevel, cannot specify other ports? nsong Linux - Software 2 03-10-2004 09:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration