LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-18-2017, 09:54 AM   #1
MarcinT
LQ Newbie
 
Registered: May 2017
Posts: 5

Rep: Reputation: Disabled
Help with Manjaro installation!


When I try to install Manjaro, it shows me a message saying "An EFI system partition is necessary to start Manjaro. To configure an EFI partition, go back and select or create a FAT32 filesystem with the esp flag enabled and mount point /boot/efi."

I have Windows 10 installed, and I'd like to not lose any data. Just want to dual-boot it. I created an /ext4 and /swap paritions on a seperate HDD already. Windows 10 is on an SSD.

I'm not sure what to do :/ I'd like to be able to choose between Windows 10 and Manjaro when I start up my PC so I really don't want to screw anything up.

Thanks!
 
Old 05-18-2017, 11:38 AM   #2
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 5,501
Blog Entries: 16

Rep: Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262Reputation: 3262
If you have Windows 10, you should already have an efi system partition. It's probably /dev/sda1. You can check this by running fdisk -l /dev/sda (that option is a lower-case "l" by the way, not a "1"). Then use the mount command to mount it on /boot/efi as instructed.
 
Old 05-18-2017, 04:44 PM   #3
MarcinT
LQ Newbie
 
Registered: May 2017
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks, I did that and it seemed to work. I was able to boot into Manjaro. But, now I have a big problem, I'm unable to get into the BIOS or Manjaro. Every time I press F11 to access it, my monitors turn off, I get a no signal message and I have to restart. I can get into Windows if I leave my PC for a few seconds.

I'm not sure how to fix that :/ I'm pretty sure I accessed the GRUB menu once, but now no matter what I do nothing happens.

I'd appreciate any help!

EDIT: I also tried changing the boot order in EasyUEFI but that didn't help.

Last edited by MarcinT; 05-18-2017 at 04:47 PM.
 
Old 05-18-2017, 05:00 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,395

Rep: Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083Reputation: 2083
Pre-installed windows 10 is almost alway UEFI. Did you verify that on windows under My Computer to see if you had an EFI/FAT32 partition?

Did you boot and install Manaro EFI or were you just able to boot the Manjaro installation DVD? If you did the install, it should have created a separate folder on the EFI partition and installed it's boot files there. You should be able to check this by booting the Manjaro DVD and mounting the EFI partition. I don't think your attempts to install Manjaro would affect the BIOS, you might check the various settings.
 
Old 05-18-2017, 05:04 PM   #5
MarcinT
LQ Newbie
 
Registered: May 2017
Posts: 5

Original Poster
Rep: Reputation: Disabled
I was able to boot and install Manjaro from my thumb drive. I'm not able to do that now though, every time I try to boot the Manjaro USB it gives me a 'No signal' message on my monitors.
 
Old 05-18-2017, 05:30 PM   #6
MarcinT
LQ Newbie
 
Registered: May 2017
Posts: 5

Original Poster
Rep: Reputation: Disabled
Ok, I somehow got into Manjaro again, I honestly don't know how. I just restarted my PC...
 
Old 05-18-2017, 05:37 PM   #7
MarcinT
LQ Newbie
 
Registered: May 2017
Posts: 5

Original Poster
Rep: Reputation: Disabled
These are my partitions: http://imgur.com/a/51PRR

I'm now trying to restore GRUB. Hopefully that won't burn anything.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Manjaro down? ButterflyMelissa Manjaro 3 05-02-2017 02:45 AM
No Display After Installation of Manjaro 0.8.13 naghmash Arch 7 06-21-2015 04:20 PM
[SOLVED] manjaro still in qwerty... ButterflyMelissa Linux - Newbie 2 04-07-2015 05:22 AM
Will Manjaro Linux Net edition act like Manjaro or a base install of Arch? punchy71 Linux - Newbie 4 06-28-2014 08:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration