LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2011, 09:56 AM   #1
shanis42
LQ Newbie
 
Registered: May 2011
Posts: 1

Rep: Reputation: Disabled
Grub 2 Boot Options


Ubuntu 11.04 - Grub 2

I am having a problem with a boot configuration.

My system will hang until I move the mouse or press a key on the keyboard. I use manual time and in the span of an hour my system clock will be 15 minutes off.

The research I have done tells me that the problem is with Dynamic Ticks. The workaround is to disable dynamic ticks in my boot options.

CONFIG_NO_HZ=n

I think I am adding the line:
CONFIG_NO_HZ=n to my /etc/default/grub file (sudo gedit /etc/default/grub)

Then running (sudo update-grub)

Does this sound right? I am a newb and don't want to mess anything up.

Thanks in advance.
 
Old 05-25-2011, 04:14 PM   #2
mostlyharmless
Senior Member
 
Registered: Jan 2008
Distribution: Arch/Slackware/Knoppix
Posts: 1,783
Blog Entries: 14

Rep: Reputation: 279Reputation: 279Reputation: 279
nohz=off on the kernel command line might work, but what you wrote above is a kernel configuration option for a kernel recompilation.
 
1 members found this post helpful.
Old 05-25-2011, 04:20 PM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852Reputation: 4852
mostlyharmless is right, change your CONFIG_NO_HZ to nohz. The rest of your solution is right.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 06:45 PM
GRUB boot options after update numtre Debian 2 03-07-2009 06:48 AM
GRUB boot options. enyawix Linux - Software 2 12-08-2004 02:49 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-13-2004 12:40 AM
Hiding boot options with GRUB? kayhan Linux - Newbie 1 12-28-2003 05:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration