LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2006, 11:43 AM   #1
banan
LQ Newbie
 
Registered: Mar 2005
Posts: 9

Rep: Reputation: 0
Question Failed dependencies: krb5-libs


Hello everyone.
I am trying to install Plesk on fresh installation of FedoraCore3.
Everything goes fine until I get ->
Quote:
error: Failed dependencies:
krb5-libs = 1.3.6-5 is needed by (installed) krb5-devel-1.3.6-5.i386

----- end of output -----
packages failed to install: Not all required packages were installed.
===> Autoinstaller: stopped logging at Mon Sep 11
But when I do :
Code:
rpm -q krb5-libs
I get :
Code:
krb5-libs-1.3.6-5
What should I do to get rid of this annoying error?
Anyone? Please? Help?
 
Old 09-11-2006, 05:09 PM   #2
tpetri1807
Member
 
Registered: Jan 2006
Location: Frankfurt, Germany
Distribution: Fedora Core 6, Kubuntu 7.04
Posts: 60

Rep: Reputation: 15
This means the installed *-devel package needs exactly the version of krb5-libs that you have installed, and you were probably trying to install a newer version or remove the version you have. Did you use yum to install your software? You should, because yum takes care of dependencies and installs or upgrades other packages as needed.
Code:
sudo yum install packagename
Or use su - and then
Code:
yum install packagename
if you're not in the sudoers file.
 
Old 09-11-2006, 07:53 PM   #3
banan
LQ Newbie
 
Registered: Mar 2005
Posts: 9

Original Poster
Rep: Reputation: 0
thanks tpetri1807.
I was getting this error because Plesk was trying to install newer version of krb5-libs without updating the rest of dependencies.
I have updated the package with yum and everything went along without any problems. Thanks much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help krb5-libs/c compiler blackspade Linux - Software 4 08-17-2005 04:39 AM
krb5-libs installation moiaussi Linux - Newbie 2 01-26-2005 11:02 AM
Problem with dependencies of libs from OpenSSL mavinac Linux - Software 4 03-24-2004 11:04 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM
krb5-libs-1.2.7-10.i386.rpm?? There but not?? Syst3m_Snip3r Linux - Software 1 11-18-2003 06:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration