Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 04-01-2001, 04:53 PM   #1
LQ Newbie
Registered: Mar 2001
Posts: 4

Rep: Reputation: 0

How can I check to see if DMA is being used on my HD's?

I did a hdparm and my drives seem really 3MB/sec!

And after I check it how do I enable it?

Thank you

Old 04-02-2001, 05:42 AM   #2
Registered: Feb 2001
Posts: 109

Rep: Reputation: 15


#hdparm -c 1 -d 1 -k 1 /dev/hda

(got this from a related thread:

Old 04-02-2001, 03:14 PM   #3
LQ Newbie
Registered: Mar 2001
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you


That increased my speed 10X's!!!!

I still can't figure out how to make the system boot with those parameters, but I'll keep monitoring the other thread on this subject for it.

Thanks again

Old 08-06-2003, 05:39 AM   #4
Registered: Apr 2003
Distribution: Server= Fedora Core 2, Desktop= Ubuntu Hoary Preview
Posts: 41

Rep: Reputation: 15
Add the command:

#hdparm -c 1 -d 1 -k 1 /dev/hda

to your rc.local file or one of the init files...

That will enable DMA when you boot.
Old 08-06-2003, 05:56 AM   #5
Senior Member
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 21, MX-21, Manjaro
Posts: 4,634

Rep: Reputation: Disabled
You should enable DMA in the BIOS, then booting is also faster, unless your distribution changes the settings to slow again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling DMA in Ubuntu wellington Linux - Hardware 2 09-17-2005 11:41 AM
problem enabling dma matrixon Linux - Hardware 2 04-30-2005 12:50 AM
Enabling DMA - tried everything? imranakbar Linux - Hardware 2 01-18-2005 02:49 AM
Enabling DMA on FC2 coolzero Fedora 11 12-21-2004 01:44 PM
Enabling DMA DeadlyMuffin Slackware 4 07-19-2004 09:24 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:40 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration