LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-19-2004, 02:55 AM   #1
DeadlyMuffin
Member
 
Registered: Feb 2003
Distribution: Gentoo, Debian, Openslug, Slackware
Posts: 46

Rep: Reputation: 15
Enabling DMA


I'm running Slack 10, and I just recompiled my kernel (is now 2.6.7) But now DMA is turned off for my root disk (/dev/hda)
anybody have any clue how it got turned off and how can I turn it back on again? Did I kill something in the compile that I shouldn't have? if so, what is it so I can recompile and fix it?

I've tried "hdparm -d1 /dev/hda", but it tells me that the opperation isn't permitted.

this is the output of "hdparm -i /dev/hda"

/dev/hda:

Model=WDC WD450AA-00BAA0, FwRev=10.09K11, SerialNo=WD-WMA2E1545327
Config={ HardSect NotMFM HdSw>15uSec SpinMotCtl Fixed DTR>5Mbs FmtGapReq }
RawCHS=16383/16/63, TrkSize=57600, SectSize=600, ECCbytes=40
BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=87930864
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2
AdvancedPM=no WriteCache=enabled
Drive conforms to: device does not report version: 1 2 3 4

* signifies the current active mode
 
Old 07-19-2004, 03:07 AM   #2
DeadlyMuffin
Member
 
Registered: Feb 2003
Distribution: Gentoo, Debian, Openslug, Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
I just checked, and DMA seems to be working on the other hard drives on my system, just not my root one!
 
Old 07-19-2004, 03:55 AM   #3
linuxnubx
Member
 
Registered: Jul 2004
Posts: 92

Rep: Reputation: 15
How do I check if my DMA is working? Nm. Checked it using hdparm -I thanks!

Last edited by linuxnubx; 07-19-2004 at 02:10 PM.
 
Old 07-19-2004, 05:33 AM   #4
ebit
Member
 
Registered: Jul 2004
Distribution: Slackware 10.1
Posts: 39

Rep: Reputation: 15
I've spent most of yesterday upgrading to 2.6.7. Turns out I missed an option when I complied the kernel.
 
Old 07-19-2004, 10:24 PM   #5
DeadlyMuffin
Member
 
Registered: Feb 2003
Distribution: Gentoo, Debian, Openslug, Slackware
Posts: 46

Original Poster
Rep: Reputation: 15
Bingo. Found it last night. Forgot to compile in support for my chipset... the drives that were using DMA were on a different controller. Recompiled and it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enabling DMA in Ubuntu wellington Linux - Hardware 2 09-17-2005 12:41 PM
problem enabling dma matrixon Linux - Hardware 2 04-30-2005 01:50 AM
Enabling DMA - tried everything? imranakbar Linux - Hardware 2 01-18-2005 03:49 AM
Enabling DMA on FC2 coolzero Fedora 11 12-21-2004 02:44 PM
Enabling DMA bizzikid Linux - Newbie 4 08-06-2003 06:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration