LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-06-2003, 01:53 PM   #1
Hady
Member
 
Registered: Nov 2003
Posts: 55

Rep: Reputation: 15
Automatic Turn Off


Hi!

My computer does not automatically turn off when I shut down from my Red Hat Linux 8.0 (It does not even shut down when I press the button)

so every time I'm using Linux and I want to shut down, I restart my pc to windows xp, then shut down my pc automatically from there.

Any suggestions how I can fix this, and make it automatically shut down from Linux?


THANKS!!
 
Old 12-06-2003, 02:01 PM   #2
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Ah.. right..

Hold the button for 5-8 seconds instead of just pressing it and it will shut off just fine.

Switch away from CrapHat 8 and the acpi power will probably work and your computer will shut itself down ok as well.

Or, go get a new, fresh kernel, and the acpi patches. Compile it with everything enabled so your computer can use its advanced features and turn itself off.
 
Old 12-06-2003, 02:02 PM   #3
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
if your pc can be shut down by OS, that means it either support acpi or apm, find out which type of power management it support, then enable it in linux.

if its acpi for example, then go to /etc/lilo.conf under append = "acpi=on"

(that's assume you have acpi / or apm in your kernel)
 
Old 12-07-2003, 04:02 PM   #4
Hady
Member
 
Registered: Nov 2003
Posts: 55

Original Poster
Rep: Reputation: 15
Thanks for your help.

Could you tell me EXACTLY what to write in the lilo.conf file? and after which lines?

(and how do I know if acpi is in my kernel?)

Thanks!
 
Old 12-07-2003, 04:31 PM   #5
unwrittenlaw
Member
 
Registered: Sep 2003
Distribution: Slackware FreeBSD Gentoo Novell
Posts: 73

Rep: Reputation: 15
Quote:
Hold the button for 5-8 seconds instead of just pressing it and it will shut off just fine.
Well i Disagrre with that because if you shut down your computer like that you goin to scratch your Hard Drive and your goin to mess up your clusters and wont work for nothing
 
Old 12-07-2003, 05:05 PM   #6
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
i've posted few thread regards this issue.... maybe you ca do a search or something?

log as root, go to /boot
cat config | APM, then cat config | ACPI
to see if your kernel has it as support (i believe any think + 2.4.0 has apm and acpi, not sure)

if you do,
next you need to find out what your motherboard support, apm or acpi? you maybe able to find that from your BIOS setup, or you have to contact the manufacture.

to try and see if it works: when boot computer, hit ESC at LILO, then type: linux apm=on or linux acpi=on then press enter.

what it does is to load apm or acpi at boot, then shut down the computer once linux is loaded and see if you can shut it down. either apm or acpi works, can't be both.

if you found out which one it works, go ahead and log in as root

go to /etc/lilo.conf, use your favor editior and add the following code

apm=on or acpi=on where you see append = " (your code goes between " and " )

for example:

image=/boot/vmlinuz
label=linux
root=/dev/hdb1
initrd=/boot/initrd.img
append="devfs=mount apm=on apm=apm_real_mode_power_off "
read-only


regard,
 
Old 12-07-2003, 05:15 PM   #7
sirpelidor
Member
 
Registered: Oct 2003
Location: Madison
Distribution: mdk 8.2, 9.0, 9.2, slack 9.1
Posts: 403

Rep: Reputation: 30
ok , i just tried redhat 9.0 and i see it works, dunno if 8.0 can shut down or not.

if the my last post is not working, that means maybe your kernel don't have apm / acpi loaded
you need to check that by login as root:

go to: /usr/src/linux (depends on your kernel, mine is call /usr/src/linux-2.4.19-35mdk)

type: make xconfig

under General setup, go verify your "Power Management" and see what u got.

you may or maynot need to compile your kernel. if you did changes ur kernel, you need to re-compile your kernel.

since u use redhat, go to google, type in kernel-howto follow step by step. once you are done, follow the same steps as my last post

regards
 
Old 12-08-2003, 08:23 AM   #8
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 37
Quote:
Well i Disagrre with that because if you shut down your computer like that you goin to scratch your Hard Drive and your goin to mess up your clusters and wont work for nothing
No it won't. Once Linux has been stopped, it parks the hard drive for you. As in old versions of Windows when it used to say "It is now safe to turn off your computer".
Just to verify what sirpelidor said:
Quote:
ok , i just tried redhat 9.0 and i see it works, dunno if 8.0 can shut down or not.
Redhat 8 used to shut down fine for me, so follow what he says and it should work
 
Old 01-27-2004, 06:55 AM   #9
disco rugby
LQ Newbie
 
Registered: Jan 2004
Location: Hamburg, Germany
Distribution: Mandrake 10 Community, SuSE 9.0 pro, Lindows 4.5
Posts: 13

Rep: Reputation: 0
I'm having a problem shutting down SuSE 9 professional. The spalshscrean (?) comes on with the 'shut down progress bar' going across the screen. That is until it gets about 95% of the way across, then it stops myteriously waiting for God knows what.
Now I'm sure there is a way to see what is going on 'behind the scenes' as it were, that tells what's going on and where it got hung up. Anybody know how to go about solving the mystery of why a newly installed SuSE 9 enjoys running all the time.

As a side line: part of the reason I went to linux is that my girlfriend was getting pretty upset at winDOZE allways crashing while she watched movie trailers on the web. Now we have the opposite problem, we can't get it to shut off!

Cheers,
rich
 
Old 01-27-2004, 10:24 AM   #10
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
The words "Press F2 for Details" are not just there for your viewing pleasure... Press F2!
 
Old 01-28-2004, 06:23 AM   #11
disco rugby
LQ Newbie
 
Registered: Jan 2004
Location: Hamburg, Germany
Distribution: Mandrake 10 Community, SuSE 9.0 pro, Lindows 4.5
Posts: 13

Rep: Reputation: 0
Repply to Caeda:

re: The words "Press F2 for Details" are not just there for your viewing pleasure... Press F2!

Have done so on many occasions, get the text page of what's going on and at some point it just stops and doesn't turn off the computer. Is there something else I should be doing?

Cheers,

Rich
 
Old 01-29-2004, 07:42 PM   #12
Caeda
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Suse 6.0+, Mandrake 5.0-10.0, Redhat 6.0-9.0, Gentoo 1.2+, Gnoppix, Knoppix, Sabayon, Ubuntu 5.04+
Posts: 1,811

Rep: Reputation: 45
Well. At what point does it stop?
 
Old 01-29-2004, 08:01 PM   #13
Djony
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware 10.0
Posts: 27

Rep: Reputation: 15
Guys who wrote this letters were probably right in most situations, but id didn't work for me to write in lilo.conf "acpi=on".But this one worked : "acpi=force".
Just log as root, edit in emacs or KWrite lilo.conf. change this line and close.editor with changes.
After that type "lilo" as command in shell.Reboot and that's it!Good luck!
 
Old 01-29-2004, 08:16 PM   #14
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 46
How about this:

Open a shell prompt (command prompt).

Type su - to log on as root
input your password.

Now type modprobe apm

Now type shutdown -h now

If it shuts down properly just put edit your /etc/rc.d/rc.local file so that on some line there are the words modprobe apm

It's not the most perfect way, but it is the easiest way in my opinion

Peace,
Whitehat
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to start, stop, turn on, and turn off deamons BuckRogers01 Debian 3 08-16-2005 10:39 AM
turn off doesn't really turn and power off pcandpc Mandriva 11 05-30-2005 04:22 PM
Turn off? theonebeyond Slackware 7 10-01-2004 12:30 AM
How to turn off Xserver in the gui and turn it off in the command line geminiviper Linux - Newbie 8 08-20-2004 09:05 AM
Turn off ?! kosmognov Linux - Software 3 08-14-2003 12:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration