Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-16-2005, 02:52 PM   #1
Registered: Sep 2002
Distribution: CentOS
Posts: 170

Rep: Reputation: 15
apt-get update error and gdesklets

I'm using apt-get under SuSe 9.2. I've executed apt-get update and then apt-get upgrade, it would upgrade 63 packages, mostly kde stuff and then 17 that need to be kept back

The following packages have been kept back
arts arts-devel kdeaddons3-kate kdebase3 kdebase3-devel kdegames3
kdegraphics3 kdegraphics3-fax kdelibs3 kdelibs3-devel kdemultimedia3
kdenetwork3 kdenetwork3-vnc kdepim3 kdesdk3 kdeutils3 mysql-connector-java
63 upgraded, 0 newly installed, 0 removed and 17 not upgraded.

Are they left behind becuase I do not have them originally installed or should I install them, and how do you force them to install.

The next issue is after downloading the 63 packages, I get the following:

Committing changes...
Preparing... ########################################### [100%]
file /opt/kde3/share/services/popmail-conduit.desktop from install of kdepim3-kpilot-3.3.92_2005021609-1 conflicts with file from package kdepim3-3.3.2-3
E: Error while running transaction

How can I resolve this error?

The next issuse is with installing gDesklets .33.1, after ./configure I get

configure: error: Library requirements (pygtk-2.0 >= 2.4.0 libgtop-2.0 >= 2.6.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

However, I know I've installed those files from the SuSe CDs. Do I have to refresh the database or something, I remember command 'updatedb' or something like that that would refresh but this does not work when I type it in.

Any suggestions would be appreciated, THANK YOU!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
what to do? gpg error on apt-get update darkleaf Debian 7 04-30-2006 04:24 AM
Xandros: apt-get update error, need assistance Keen48 Linux - Newbie 1 10-11-2005 10:34 PM
apt-get update error on FC3 obliviux Linux - General 3 06-16-2005 08:58 PM
apt-get update error cedar Debian 9 09-04-2004 07:17 PM
Does 'apt-get update' update the database used by 'apt-cache'? davidas Debian 5 04-20-2004 01:27 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:03 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration