LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-12-2005, 07:17 PM   #1
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Rep: Reputation: 15
ADSL internet access with Suse 9.2


I have just installed Suse Linux 9.2, it's looks great and I'm really looking forward to operating without viruses, spyware and the rest of that nonsense.

There's just one thing: I don't seem to be on-line and it's not clear what I should do about it. I followed the instructions to set up a DSL connection on the root, but nothing seems to be happening. I was a little surprised that it didn't ask for details of the modem (a Voyager 105). Should it have done? Where else might the problem lie? Can anyone please help?!
 
Old 01-12-2005, 08:26 PM   #2
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,285

Rep: Reputation: 61
Have you had the modem online before, or is this the first time the modem is being used? Most DSL modems have to be setup in the modem itself to make a connection to your ISP, you will need to put the username and password supplied to you by your ISP.

You will also need to either configure it with either a static or DHCP assigned IP address. If you have that information available, you can usually access your DSL modem via your web browser, most default to either http://192.168.0.1 or http://192.168.1. And will have as the default login
username: admin
password: admin

If your modem has been working before, you just might need to enable the DHCP server in the modem to give your machine an IP address to connect to modem. All though most modems default with DHCP server enable.
 
Old 01-14-2005, 08:42 AM   #3
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks for the advice. I've installed the driver now. Can't get it to work but I think I know why and I'm working on it!

Once again, thanks for taking the trouble to reply to my request.

Tom
 
Old 01-14-2005, 08:43 AM   #4
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks for the advice. I've installed the driver now. Can't get it to work but I think I know why and I'm working on it!

Once again, thanks for taking the trouble to reply to my request.

Tom
 
Old 01-14-2005, 09:49 PM   #5
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: KirraMail Live Email Server
Posts: 1,285

Rep: Reputation: 61
Quote:
Originally posted by Nizhni
Thanks for the advice. I've installed the driver now. Can't get it to work but I think I know why and I'm working on it!

Once again, thanks for taking the trouble to reply to my request.

Tom
That's ok, lets us know if your still having problems.
 
Old 01-17-2005, 03:22 PM   #6
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks for the advice.

In the end I've gone out and bought an ethernet router to replace the USB modem, since so many other people have reported problems with them. But I can't get it to work either! All the manuals tell me different things I ought or ought not to set up for it, while some other postings on this forum have said you don't really need to set anything up at all.

Now I'm completely confused. Following what seemed to be authoritative advice, I changed some of the net card settings to what appeared to be correct. Maybe I should have left well alone?

On the Suse/Novell forum on this site I have requested advice on configuring DHCP, but I'm no longer sure that's what I need. But I don't know where else to begin.

Anyone got any advice how I can begin to unscramble the situation?!

Tom
 
Old 01-17-2005, 04:14 PM   #7
bdrake
Member
 
Registered: Aug 2004
Location: Montrose, CA
Distribution: Slackware, SuSE, OpenZaurus
Posts: 45

Rep: Reputation: 16
First, look in the router's manual to determine if its "inside" network (your side) is set to 192.168.0.x or 192.168.1.x. Assuming it is 192.168.0.x, issue the following commands on your SuSE box:
ifconfig eth0 192.168.0.10 netmask 255.255.255.0
route add default gw 192.168.0.1
That's all you need to do for the SuSE box's network connection.

Now you can bring up a web browser, enter http://192.168.0.1 for the address, and configure your router so that it will set up your ADSL connection through the modem. You will probably want to configure a PPPoE connection, using the username and password set up by your ISP. Instructions for this should be in the router's manual.

--Barry
 
Old 01-17-2005, 04:35 PM   #8
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
This looks very helpful - thanks.

I've entered the two lines of commands you gave. There was no visible response to either of them; the shell just moved on to the next # prompt. Is that as it should be?

I then entered http://192.168.0.1 on the Konqueror browser and it said:
An error occurred while loading http://192.168.0.1:
Could not connect to host 192.168.0.1.

Any suggestions what I should do next?

Tom
 
Old 01-17-2005, 04:40 PM   #9
bdrake
Member
 
Registered: Aug 2004
Location: Montrose, CA
Distribution: Slackware, SuSE, OpenZaurus
Posts: 45

Rep: Reputation: 16
Yes, that is as it should be. To check to see if the commands "took", you can type:
ifconfig
route
and that will display your network configuration and routing table, respectively.

"Any suggestions what I should do next?"
What does your router manual say about the "inside" network? Is it 192.168.0.x or 192.168.1.x? I have a Linksys, and it defaults to .1.x, but many others default to .0.x; which is yours?

--Barry
 
Old 01-17-2005, 04:51 PM   #10
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Great! At last I feel I'm getting somewhere.

The Netgear's default is 192.168.0.x. That's why I typed that into the browser.

I've found the network configuration and routing table, as you suggested. The latter shows "inet addr:127.0.0.1" and "Mask:255.0.0.0". Is either of them at all significant?

Cheers,
Tom
 
Old 01-17-2005, 06:07 PM   #11
bdrake
Member
 
Registered: Aug 2004
Location: Montrose, CA
Distribution: Slackware, SuSE, OpenZaurus
Posts: 45

Rep: Reputation: 16
I happened upon your other thread, and it seems you have two network interfaces. I assume the Centrino is for a wireless connection, so we should be working with the other one (hooked up with a cable), yes? Anyway, the output of your ifconfig and route commands should look like this:

nld1:/etc # ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:0C:76:B3:BB:FF
inet addr:192.168.0.10 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20c:76ff:feb3:bbff/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:170491 errors:0 dropped:0 overruns:0 frame:0
TX packets:125246 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:149412941 (142.4 Mb) TX bytes:18061795 (17.2 Mb)
Interrupt:11 Base address:0xe400

nld1:/etc # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0
nld1:/etc #

Note that your "wired" interface may actually be eth1 instead of eth0, so you may have to adjust your commands accordingly. How does this compare with what you have now?

--Barry
 
Old 01-17-2005, 06:26 PM   #12
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Yes, it seems to be the Acer card that I need for the cable connection.

The output of the ifconfig command is:

eth0 Link encap:Ethernet HWaddr 00:C0:9F:35:5B:BF
inet6 addr: fe80::2c0:9fff:fe35:5bbf/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:67 errors:0 dropped:0 overruns:0 carrier:67
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:17538 (17.1 Mb)
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:77 errors:0 dropped:0 overruns:0 frame:0
TX packets:77 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5420 (5.2 Mb) TX bytes:5420 (5.2 Mb)

The output of the route command is:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * 255.0.0.0 U 0 0 0 lo

Does that tell you anything?

Cheers,
Tom
 
Old 01-17-2005, 07:33 PM   #13
bdrake
Member
 
Registered: Aug 2004
Location: Montrose, CA
Distribution: Slackware, SuSE, OpenZaurus
Posts: 45

Rep: Reputation: 16
RX packets: 0 tells me you're not hooked up to anything on the eth0 interface. Let's figure out what kind of hardware you have installed. Type
dmesg | grep eth
and post the results. We need to figure out which hardware your kernel is detecting for eth0.

--Barry
 
Old 01-17-2005, 07:43 PM   #14
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Let's wait a moment before we try that. I've got a little further since my last reply. ifconfig now gives this output:

eth0 Link encap:Ethernet HWaddr 00:C0:9F:35:5B:BF
inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::2c0:9fff:fe35:5bbf/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:35 errors:0 dropped:0 overruns:0 frame:0
TX packets:45 errors:0 dropped:0 overruns:0 carrier:2
collisions:0 txqueuelen:1000
RX bytes:7710 (7.5 Kb) TX bytes:6602 (6.4 Kb)
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:50 errors:0 dropped:0 overruns:0 frame:0
TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3260 (3.1 Mb) TX bytes:3260 (3.1 Mb)

There are some RX packets in there under eth0. Does that tell you anything more?

Tom
 
Old 01-17-2005, 07:57 PM   #15
Nizhni
Member
 
Registered: Jan 2005
Location: Oxford, England
Posts: 43

Original Poster
Rep: Reputation: 15
Me again! I have done what you suggested, and dmesg | grep eth produced these results:

eth0: Broadcom 4400 10/100BaseT Ethernet 00:c0:9f:35:5b:bf
eth1: Using hotplug firmware load.
eth1: Radio is disabled by RF switch
eth1: Bound to 0000:02:04.0
b44: eth0: Link is down.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
eth0: no IPV6 routers present
SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.0.2 DST=192.168.0.1 LEN=52 TOS=0X08 PREC=0x00 TTL=64 ID=41820 DF PROTO=TCP SPT=1039 DPT=80 WINDOW=1930 RES=0x00 ACK FIN URGP=0 OPT (0101080AEB590002230A)

The final line with all the capitals came up nine times. It's identical each time, except that all but the first have "PSH" between "ACK" and "FIN", and the number AEB59000 (in the middle of the long string in brackets at the end) is different in every case.

Conclusions?

Tom
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent Internet Access Since Router/ADSL Modem change yogiman Linux - Networking 4 11-22-2005 02:26 PM
DHCP set-up for ADSL internet on Suse 9.2 Nizhni SUSE / openSUSE 7 01-18-2005 08:51 AM
SUSE 9.2 and Adsl internet? kersoz2003 Linux - Networking 2 12-06-2004 10:37 PM
RedHat 9.0 Internet ADSL access by a shell nyqvist Linux - Newbie 3 12-10-2003 02:08 AM
freeswan + ADSL+Internet access PcHammer Linux - Networking 0 10-17-2003 05:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration