LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-19-2003, 06:02 PM   #1
ironChimp
Member
 
Registered: Feb 2003
Location: Scotland ( for some obscure reason)
Distribution: Mandrake 9, RH8, Suse 7.3
Posts: 32

Rep: Reputation: 15
Exclamation trusting eth0 in mandrake 9


Hi,

I've been trawling through endless forums/chatrooms etc for ages, and i've not found anything close to a solution to my problem, so i'm hoping that someone here'll be able tp help


:::::::::: The Situation :::

I have a desktop computer, that i'm using as a file server etc. for my laptop. My laptop runs WinXP ( Has too, or the University will NOT let me use it on their network.... grumble ... grumble...)

My desktop currently has Mandrake 9.0 installed.


:::::::::::: The Problemo ::::::


Until recently, i was using RH8.0, until a minor error during partition resizing made me lose everything, so i upgraded to Mandrake 9 while i had the option.

My network worked fine until then.

Now i cannot access my SAMBA shares because the firewall will not let me enter the Computer from winXP

( I get a message saying that may not have the correct permissions, nd that the network resource was not found)

::::::: Main question ::::::::::::::::::

In RH8 i could set eth0 to be a trusted device, can i do the same thing with Mandrake 9?

::::::::::::::::::::::::::::::::::::::::::::::::

Currently, everything works perfectly with mandrake 9, my laptop can access the Internet through the LAN connection, and the DHCP works fine, its just the Shared directories that i cannot access.


Help please
:::::::::::::::::::::::::::
 
Old 02-19-2003, 07:12 PM   #2
ironChimp
Member
 
Registered: Feb 2003
Location: Scotland ( for some obscure reason)
Distribution: Mandrake 9, RH8, Suse 7.3
Posts: 32

Original Poster
Rep: Reputation: 15
can no-one help me?
 
Old 02-20-2003, 03:59 AM   #3
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
if eth0 is your only network interface, trusting all connections from this (i assumet that you are referring to the firewall config) is the same as turning off your firewall. i.e. iptables -F/ipchains -F.
 
Old 02-20-2003, 03:14 PM   #4
SlickWilly
Member
 
Registered: Dec 2002
Posts: 327

Rep: Reputation: 30
You probably don't have your samba allowing your subnet access to it.

Look in your smb.conf for the following lines and change the allow to the subnet your laptop is on :

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
; hosts allow = 192.168.1. 192.168.2. 127.
hosts allow = 192.168.10. 127.

As you can see, mine is allowing anything on 192.168.10.xxx and localhost.



Slick.
 
Old 02-21-2003, 05:55 AM   #5
ironChimp
Member
 
Registered: Feb 2003
Location: Scotland ( for some obscure reason)
Distribution: Mandrake 9, RH8, Suse 7.3
Posts: 32

Original Poster
Rep: Reputation: 15
I've got my computer connected to the internet through a modem, if i stop the firewall, as suggested, will that also remove the firewall from the modem? i'd liek my modem o be protected, but allow all acess from my network to the computer.

I know trhat you can do this easily under RH8, but i like mandrake better .....


Last edited by ironChimp; 02-21-2003 at 05:59 AM.
 
Old 02-21-2003, 05:17 PM   #6
ironChimp
Member
 
Registered: Feb 2003
Location: Scotland ( for some obscure reason)
Distribution: Mandrake 9, RH8, Suse 7.3
Posts: 32

Original Poster
Rep: Reputation: 15
Been reading up, and i've managed to get my internet access to be ahared accross my network, easy enough with ne of the 'drakes.

However, my samba access is still denied. Whenever i click on the computer in Network neighbourhood on my laptop ( the only other computer on my network at the moment - more to come though ), i get a message saying i don't have permissions / access to my network, and that the computer is not found.

Does this help anyone with my problem? I've been trying for almost a week to get this sorted


::::::::::::::: thanx :::
 
Old 02-21-2003, 05:19 PM   #7
ironChimp
Member
 
Registered: Feb 2003
Location: Scotland ( for some obscure reason)
Distribution: Mandrake 9, RH8, Suse 7.3
Posts: 32

Original Poster
Rep: Reputation: 15
( IronChimp again)

Hosts allow is set to:

hosts allow = 192.168.1. 127.

i've also tried

host allow = ALL

my latop's ip address is set by a dhcp service on the desktop.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba-3 PDC trusting M$ Windows 2000 & AD climbingmerlin Linux - Networking 1 08-14-2005 07:11 AM
Trusting myself! (Firestarter) robertmarkbram Linux - Security 0 07-15-2004 09:15 PM
Help with eth0 mandrake 10.0 HollowSoft Linux - Networking 5 05-31-2004 11:26 PM
DHCP / eth0 / Mandrake rabin Linux - Networking 2 11-11-2002 04:06 PM
Mandrake and eth0 Tuxer Linux - General 2 02-05-2002 12:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 12:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration