LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-15-2003, 02:11 PM   #1
Dogface1SG
Member
 
Registered: Oct 2003
Posts: 30

Rep: Reputation: 15
SWAT status, SMBD not running


First, Thank you, I just started with mandrake 9.1 this last weekend and this site has been a great resource.

I have done numerous searches over the last 5 days. I have came up with a blank on the 2 problems I am encountering.

Problem 1
In SWAT I click on the start smbd button, the window refreshes and has smbd not running. I checked the smbd.log (actually log.smbd on my machine) it states

[2003/10/15 11:21:25, 0] lib/pidfile.cidfile_create(86)
ERROR: smbd is already running. File /var/run/samba/smbd.pid exists and process id 3456 is running.

I also tried smbstatus which it got nothing.

Problem 2
testparm does nothing on my machine.

Thanks again
 
Old 10-15-2003, 03:44 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Welcome to LQ.

1) Try:
killall smbd
killall nmbd
service restart smb

2) Does nothing not even generate an error message.
 
Old 10-15-2003, 10:06 PM   #3
Dogface1SG
Member
 
Registered: Oct 2003
Posts: 30

Original Poster
Rep: Reputation: 15
Didn't work

Swat showed it as not running, log.smdb showed it was, even after the killall's

could it be that I utilized Mandrake Control Center and enabled internet Sharing? It designated my eth1 as 192.168.1.1 I am not certain what program it utilizes to do this.

Nothing, brings up the watch mouse cursor for a few seconds and that is it. Do I have to be logged in as root to run the testparm?
 
Old 10-16-2003, 12:26 AM   #4
Dogface1SG
Member
 
Registered: Oct 2003
Posts: 30

Original Poster
Rep: Reputation: 15
Ok I'm an idiot

i was using the run command.

I have now done it from a terminal window.
killall smbd
smbd: no process killed
killall nmbd
nmbd: no process killed
service restart smb
bash: service: command not found

testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[printers]"
Processing section "[print$]"
Processing section "[pdf-generator]"
Processing section "[netlogon]"
Processing section "[profiles]"
Processing section "[homes]"
Loaded services file OK.

just in case here is my smb.conf

workgroup = whatever
netbios name = name
interfaces = eth1 192.168.1.1
bind interfaces only = No
security = USER
encrypt passwords = Yes
update encrypted = No
smb passwd file = /etc/samba/smbpasswd
pam password change = No
passwd program = /usr/bin/passwd
passwd chat = *new*password* %n\n *new*password* %n\n *changed*
password level = 0
username level = 0
log file = /var/log/samba/log.%m
max log size = 50
timestamp logs = Yes
nt smb support = Yes
time server = Yes
unix extensions = No
mangling method = hash
add user script = /usr/sbin/useradd -d/dev/null -g 100 -s /bin/false -M %u
logon script = logon.bat
logon path = \\%L\profiles\%u
logon drive =
logon home = \\%N\%U
domain logons = Yes
os level = 65
preferred master = Yes
local master = Yes
domain master = Yes
browse list = Yes
enhanced browsing = Yes
dns proxy = Yes
wins proxy = No
wins support = Yes
pid directory = /var/run/samba
socket address = 192.168.1.1
homedir map = auto.home
template homedir = /home/%D/%U
template shell = /bin/false
username =
guest account = nobody
guest ok = No
only user = No
status = Yes
nt acl support = Yes
mangled names = Yes
browseable = Yes

[netlogon]
path = /usr/local/samba/lib/netlogon
browseable = No

[profiles]
path = /home/samba-ntprof
read only = No
create mask = 0600
directory mask = 0700
browseable = No

[homes]
read only = No
browseable = No

I tried to thin it out as much as I could.
 
Old 10-16-2003, 08:27 AM   #5
Dogface1SG
Member
 
Registered: Oct 2003
Posts: 30

Original Poster
Rep: Reputation: 15
Ok I have found myanswer

in the samba help files while using SWAT help button next to interfaces

"If bind interfaces only is set then unless the network address 127.0.0.1 is added to the interfaces parameter list smbpasswd(8) and swat(8) may not work as expected due to the reasons covered below."

"The swat status page tries to connect with smbd and nmbd at the address 127.0.0.1 to determine if they are running. Not adding 127.0.0.1 will cause smbd and nmbd to always show "not running" even if they really are. This can prevent swat from starting/stopping/restarting smbd and nmbd."

As you can see, I did not have bind interfaces only on. I have since added 127.0.0.1 to my interfaces and activated bind interfaces. VOILA

Sorry to have bothered you over something that I should have RTFM about.

Perhaps more questions later. Thanks for the quick response/advice
 
Old 10-16-2003, 01:45 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
When you run commands such as service and killall for system services make sure you are logged in as root or su'ed root using "su -" before running the commands.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SMBD not running? alirezan1 Linux - Networking 0 12-21-2004 05:05 AM
Samba Dameon smbd is not running and won't start rjcmi Linux - Newbie 2 04-22-2004 09:44 AM
Why so many smbd processes running mdkelly Linux - Networking 2 11-05-2003 05:47 PM
smbd - not keen on running rwhitworth Linux - Networking 3 04-26-2003 05:18 PM
command line check to see if smbd and nmbd are running rioguia Linux - Networking 2 11-18-2002 01:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration