LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-08-2004, 07:38 AM   #1
FlyingDutchman9
LQ Newbie
 
Registered: Nov 2004
Posts: 3

Rep: Reputation: 0
(strange?) problem with samba & konqueror


i'm trying to view a samba share with konqueror, so i type:

Code:
smb://168.196.*.*/
this works perfectly fine, i get a list of the shares on the specific pc, but when i double-click a directory to open the actual share konqueror loads for a sec then shows nothing, status bar reporting: "0 files, 0 directories"

same thing happens when i type the following:

Code:
smb://168.196.*.*/sharename/
this is pretty annoying since i like to view the actual shares, hehe
anyone knows anything about this problem?
could it be that samba or konqueror is not conifgured properly?


please help me out,


FD
 
Old 11-08-2004, 12:28 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi FlyingDutchman9, welcome to lq. Are the shares on a windows machine or another linux machine? I believe viewing the shares is handled by smbclient, so that leads me to think there may be a problem on the other box.
good luck.
 
Old 11-08-2004, 02:01 PM   #3
FlyingDutchman9
LQ Newbie
 
Registered: Nov 2004
Posts: 3

Original Poster
Rep: Reputation: 0
it's not a problem of the server, because i tried access both windows computers and linux samba servers and they all are acting thesame, i can browse the 'root' dir of the pc, but when i open a share it simply shows nothing...

and i tried browsing shares on both windows & linux computers with my winxp machine and they all work, so it's not a server problem...




also, when i enter a share it shows no files or dirs, but the spinning konqueror logo tells me that it's somehow still loading or something, but it never ends...

Last edited by FlyingDutchman9; 11-08-2004 at 02:04 PM.
 
Old 11-08-2004, 02:05 PM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
I wasn't thinking of a server problem, as much as a user/permission problem on the server.
good luck.
 
Old 11-08-2004, 02:39 PM   #5
FlyingDutchman9
LQ Newbie
 
Registered: Nov 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Peacedog
I wasn't thinking of a server problem, as much as a user/permission problem on the server.
good luck.
no, that's not the problem, since i tried to access the shares from other pc's, and that worked just perfectly fine...
it really got something to do with konqueror/samba i think...
 
Old 11-08-2004, 04:45 PM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Alright, let's eliminate samba. What does

smbclient -L 168.196.*.*

return?
good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange konqueror problem, mime type application/octect not found Ghost_runner Mandriva 4 09-13-2004 10:15 PM
Samba & Roaming Profiles -- Strange Problem baz2 Linux - Networking 1 07-13-2004 11:45 AM
Strange Samba problem ludwig W Linux - General 2 01-28-2004 01:10 AM
Strange Konqueror problem jimmmac Linux - Software 0 09-01-2003 07:08 AM
strange problem with samba ramu_ak Linux - Networking 0 07-11-2003 08:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration