LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-20-2004, 11:39 AM   #1
rejser
Member
 
Registered: Jan 2004
Distribution: Ubuntu dapper/breezy
Posts: 102

Rep: Reputation: 15
Sharing printer through samba


I'm sharing my printer through samba to my girlfriends computer which she runs Win XP on.
Her computer are able to find the printer, install, but can't print. When I looked around (in windows), it can't configure which port to use.
Normally you can click on some button to edit it, but I can't.
Is this a windows problem or is it me?

I followed since I have no earlier experience of samba.
http://www.tldp.org/HOWTO/SMB-HOWTO-9.html
 
Old 05-20-2004, 12:07 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
what is your firewall situation on both machines? have you tried turning them off to configure the printer?
 
Old 05-20-2004, 12:20 PM   #3
rejser
Member
 
Registered: Jan 2004
Distribution: Ubuntu dapper/breezy
Posts: 102

Original Poster
Rep: Reputation: 15
Running external firewall, these are however linked by router, Windows discovers the link to the printer, but don't put it as port to printer.
 
Old 05-20-2004, 12:28 PM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
let's have a look at you smb.conf.
 
Old 05-20-2004, 02:39 PM   #5
rejser
Member
 
Registered: Jan 2004
Distribution: Ubuntu dapper/breezy
Posts: 102

Original Poster
Rep: Reputation: 15
[global]
guest account = smbprint
printing = cups
[printers]
guest ok = yes
create mask = 0700
guest only = yes
use client driver = yes
browseable = yes
guest ok = yes
 
Old 05-20-2004, 05:46 PM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
try adding this

printcap name = cups
printer admin = @adm

under global

and this

path = /var/spool/samba
print command = lpr-cups -P %p -o raw %s -r # using client side printer
drivers.

under printers

on another note, may i suggest configuring samba completely. if you don't wish to share files, just don't create any shares. here are the relevant parts of my smb.conf for your use

[global]

workgroup = yourworkgroup
netbios name = yournetbiosname
server string = Samba Server %v
security = SHARE
encrypt passwords = Yes
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
printcap name = cups
dns proxy = No
printer admin = @adm
printing = cups

[printers]
comment = All Printers
path = /var/spool/samba
create mask = 0700
guest ok = Yes
printable = Yes
print command = lpr-cups -P %p -o raw %s -r # using client side printer
drivers.
browseable = No

good luck.

Last edited by Peacedog; 05-21-2004 at 06:30 AM.
 
Old 05-21-2004, 03:31 AM   #7
rejser
Member
 
Registered: Jan 2004
Distribution: Ubuntu dapper/breezy
Posts: 102

Original Poster
Rep: Reputation: 15
Does still not work, must be a windows problem.
 
Old 05-21-2004, 06:36 AM   #8
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
some things to check, after any changes to your smb.conf, you'll need to restart samba, and, the windows machine. you may also need the windows drivers, even though to this point your unable to get to the port. i'd try setting up samba completely, then restart everything. grab a copy of the windows drivers for the printer, to have on hand. once your able to see and connect to the samba server, then try your "add printer wizard", you'll choose a network printer, and follow the rest of the steps the wizard walks you thru. hope this helps.
good luck.
 
Old 05-21-2004, 07:37 AM   #9
rejser
Member
 
Registered: Jan 2004
Distribution: Ubuntu dapper/breezy
Posts: 102

Original Poster
Rep: Reputation: 15
Tried it, it adds a printer, but no port. It finds the printer, adds it, but when I look at the advanced settings, it got no port, there are ports, but I can't choose anyone, and the right one that I choose during install ain't there.
 
Old 05-21-2004, 09:20 AM   #10
Hamsjael
Member
 
Registered: Aug 2003
Location: Vejle, Denmark
Distribution: Mainly Debian, some Fedora for the bleeding edge fix
Posts: 92

Rep: Reputation: 15
Exclamation

Hi rejser

You need to add "printable = yes" under [printers] this is the way samba distinguises the printer share from other shares. If it is not set you will not be able to print to it.

good luck

Hamsjael
 
Old 05-21-2004, 09:21 AM   #11
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
have a look at this

http://www.faqs.org/docs/Linux-mini/...g_with_windows

good luck.
 
Old 05-21-2004, 10:27 AM   #12
rejser
Member
 
Registered: Jan 2004
Distribution: Ubuntu dapper/breezy
Posts: 102

Original Poster
Rep: Reputation: 15
Have printable = Yes
think it is a windows problem...
 
Old 05-21-2004, 01:10 PM   #13
luisgp
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
I am no expert, but I set up a samba print server yesterday after much sweating.

I was having your same problem, (when instralling the printer, it shows the server, but I couldn't see the printers on it) in some windows machines, while in my own machine I could do this perfectly.

It turned out that I could do it when logged on on windows as a user which was also created on the samba server (user:luis on both machines), but not as guest on the other machine even though it asked me for a login when connecting to the samba server and I logged on as luis.

For me the solution would be: creating on samba the same users that you use on your windows machines. I don't know how to do this on the shell though, due to the encrypted password stuff, I had to create them from gnome app (redhat 9). I am sure there is a way to do it anyway.

Other easy way to share the printer is to configure CUPS to accept LPD/LPR print jobs and install the unix print service on you win machines and create a LPR port pointing to your server (give it a static IP preferably). That would make it even easier.


I hope this helps.

Luis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing a printer using samba kponenation Fedora 1 11-15-2005 08:14 PM
Sharing Printer using Samba subaruwrx Linux - Software 2 03-22-2005 11:48 AM
Samba and printer sharing onelung02 Linux - Software 2 02-28-2005 01:50 PM
samba printer sharing nithin_bhaskar Linux - Networking 1 06-17-2004 05:17 PM
Sharing Printer with Samba ritris Slackware 8 05-09-2003 09:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 09:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration