LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Home Forums Tutorials Articles Register
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-20-2011, 08:30 AM   #1
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Port forward on Cisco ASA 5505 (8.4) not working


I have struggled with this for 3 days now, just can't get port forwarding to work!
I have now given up the gui as I finally found a serial port for my computer - the gui/ASDM really sucks! Anyway, today I first reset everything to factory default, then configured via cli. All things but pf works fine.

First the setup, 3 vlans:
* Outside:
dhcp, 192.168.0.102, ethernet 0/0, vlan 2
* Inside:
192.168.5.0/24, ethernet 0/1 - 0/6 = vlan 1
Cisco:s internal ip: 192.168.5.1
Webserver ip, static, 192,168,5,2
* Kontor:
172.168.5.0/24, ethernet 0/7, vlan 7
no forward interface Vlan2

So far all is fine, Kontor reaches Inside only, Inside reaches everything.
Ciscos web interface is reached via port 7490, so it doesn't conflict with pf of port 80 to Webserver.

Now to portforward commands:
Code:
object network Webserver
 host 192.168.5.2
 nat (inside,outside) static interface service tcp www www
 access-list outside_access_in permit tcp any object Webserver eq www
That should be everything needed, I've read hundreds of pages all saying the same??

And last, complete config:
Code:
ciscoasa(config)# sh run
: Saved
:
ASA Version 8.4(2)
!
hostname ciscoasa
enable password kSdfIGxHxdPlmd80 encrypted
passwd kSdfIGxHxdPlmd80 encrypted
names
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
 switchport access vlan 7
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.5.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Vlan7
 description VLAN till kontor
 no forward interface Vlan2
 nameif kontor
 security-level 100
 ip address 172.16.5.1 255.255.255.0
!
ftp mode passive
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object network obj_any
 subnet 0.0.0.0 0.0.0.0
object network Webserver
 host 192.168.5.2
access-list outside_access_in extended permit tcp any object Webserver eq www
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu kontor 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network obj_any
 nat (inside,outside) dynamic interface
object network Webserver
 nat (inside,outside) static interface service tcp www www
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
timeout floating-conn 0:00:00
dynamic-access-policy-record DfltAccessPolicy
http server enable 7490
http 192.168.5.0 255.255.255.0 inside
http 0.0.0.0 0.0.0.0 outside
http 172.16.5.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart
telnet timeout 5
ssh scopy enable
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 10
console timeout 0

dhcpd auto_config outside
!
dhcpd address 192.168.5.11-192.168.5.36 inside
dhcpd enable inside
!
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum client auto
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
no call-home reporting anonymous
Cryptochecksum:e6cbe3b7c7abbec2ca220e44f41a1559
: end
 
  


Reply



Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] SNMP Help For Cisco ASA 5500 Series Firewalls. mrm5102 Linux - Networking 7 10-19-2011 12:47 PM
Cisco ASA 5505 and OpenVPN karnac01 Linux - Networking 1 05-21-2011 08:35 AM
site2site vpn with openswan to cisco asa 5500 kloenie Linux - Security 2 12-02-2010 08:54 AM
site to site vpn racoon with cisco asa 5505 routing issues wastingtime Linux - Networking 1 04-02-2010 12:26 PM
Linux KVM/VMWare bridged interfaces and the Cisco 5505 fantasygoat Linux - Networking 1 12-04-2009 01:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration