LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-10-2006, 11:22 AM   #1
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Rep: Reputation: 34
Permissions problem in Apache 1.3


Hi,

I've setup TWiki in my webserver, however when I wnat to access my htdocs/twiki/bin/configure.pl file:

In the webbrowser I go like:
http://localhost/twiki/bin/configure.pl

the web server replies:

Forbidden
You don't have permission to access /twiki/bin/configure.pl on this server.

Apache/1.3.33 Server at darkstar.example.net Port 80

I'm logged in as root, and still I dont have access to the file??
 
Old 05-10-2006, 01:09 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,522

Rep: Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775
Make sure that the script is executable and that you have "Options +ExecCGI" for the /twiki/bin/ directory
 
Old 05-10-2006, 01:35 PM   #3
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
yup I have that these are my settings for the folder:
<Directory "/var/www/htdocs/twiki/bin">
Options +ExecCGI FollowSymLinks
SetHandler cgi-script
Order Allow,Deny
Allow from all
Deny from env=anonymous_spider
</Directory>
 
Old 05-11-2006, 01:56 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,522

Rep: Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775
It looks OK. Perhaps you have to change the SetHandler line, to:
Code:
SetHandler cgi-script .pl .cgi
Also take a look at the error_log to see if you find out why you're denied access.
 
Old 05-11-2006, 02:00 AM   #5
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
The error_log says this:
[Thu May 11 11:18:14 2006] [error] [client 58.65.128.217] (13)Permission denied: file permissions deny server access: /usr/local/apache/htdocs/TWiki/pub/TWiki/TWikiLogos/T-logo-140x40-t.gif
[Thu May 11 11:18:15 2006] [error] [client 58.65.128.217] (13)Permission denied: file permissions deny server access: /usr/local/apache/htdocs/TWiki/pub/TWiki/TWikiDocGraphics/help.gif
[Thu May 11 11:18:15 2006] [error] [client 58.65.128.217] (13)Permission denied: file permissions deny server access: /usr/local/apache/htdocs/TWiki/pub/TWiki/TWikiDocGraphics/warning.gif
[Thu May 11 11:18:15 2006] [error] [client 58.65.128.217] (13)Permission denied: file permissions deny server access: /usr/local/apache/htdocs/TWiki/pub/TWiki/TWikiDocGraphics/help.gif
[Thu May 11 11:18:16 2006] [error] [client 58.65.128.217] (13)Permission denied: file permissions deny server access: /usr/local/apache/htdocs/TWiki/pub/TWiki/TWikiDocGraphics/tip.gif
[Thu May 11 11:18:18 2006] [error] [client 58.65.128.217] (13)Permission denied: file permissions deny server access: /usr/local/apache/htdocs/TWiki/pub/TWiki/TWikiDocGraphics/tip.gif
 
Old 05-11-2006, 02:02 AM   #6
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
And from the httpd.conf file, the settings for TWiki/pub folder are:

<Directory "/usr/local/apache/htdocs/TWiki/pub">
Options FollowSymLinks +Includes
AllowOverride None
Allow from all
</Directory>
 
Old 05-11-2006, 02:06 AM   #7
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
Ok it seems that
when I point my browser to
Twiki/bin/configure, permission is denied and it says:
in the error_log

[Thu May 11 12:01:52 2006] [error] [client 58.65.128.217] Options ExecCGI is off in this directory: /usr/local/apache/htdocs/TWiki/bin/configure

although according to httpd.conf I have allowed it
 
Old 05-11-2006, 02:11 AM   #8
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
in some of my posts you might have noticed I use the path

"/var/www/htdocs/twiki/" and in some "/usr/local/apache/htdocs/TWiki"
Their are actually two installations with identical problems
 
Old 05-11-2006, 02:11 AM   #9
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,522

Rep: Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775
From the logs it's /usr/local/apache/htdocs/TWiki/pub the directory where you should put the: "Opttions +ExecCGI" which according to your last post is not set
 
Old 05-11-2006, 08:44 AM   #10
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
but the pub directory doesnt contain any scripts, its the bin directory which contains the scripts,
 
Old 05-21-2006, 04:57 AM   #11
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Original Poster
Rep: Reputation: 34
anyone?? the problem still has not been solved
 
Old 05-21-2006, 08:14 AM   #12
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,522

Rep: Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775
Put:
Code:
AllowOveride Options or
AllowOveride All
inside the <Directory "/var/www/htdocs/twiki/bin">..</Directory>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache 2 VirtualHost woes, permissions problem, just can't work it out. utow Linux - Software 2 04-19-2005 01:48 PM
APACHE Problem 2 dirs, identical permissions and security contexts, one gives 403? tones Linux - Software 2 03-13-2005 08:45 AM
Fedora3 + Apache Permissions problem stedo Linux - Software 2 01-18-2005 07:17 AM
Apache, RedHat ES Permissions Problem kclevenger Linux - General 0 05-25-2004 02:42 PM
Permissions problem w/ Apache conf dir player_2 Linux - Software 2 08-23-2003 07:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration