LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-30-2003, 09:48 PM   #1
Apokai
LQ Newbie
 
Registered: Jan 2003
Location: Canada
Posts: 2

Rep: Reputation: 0
Unhappy NetGear MA401 + RedHat 8.0


Hi there,

really need a hand with that. I've tried several things to make my new MA401 card. I've tried the instruction of NETGEAR.COM (only for RH 7.3). Didn't work.

Looked at all the messages, nothing is working.

The documentation of NetGear talks about a device named WLAN0 but the URL. The also speak of a file named ws-lang.opts but I don't have it.

I compiled my Kernel with turning on all the options for the Wireless card.

When I tried ifconfig, there's no WLAN0. There's a ETH0 but It is for my on-board ethernet.

the command :
/sbin/cardctl ident

gives :
Product info : "NETGEAR MA401RA Wireless PC", ...
manfid : 0X000b, 0x7300
fucntion: 6 (network)


Anyway can help me to build this up ?
 
Old 01-31-2003, 02:11 AM   #2
turtle
LQ Newbie
 
Registered: Jan 2003
Distribution: redhat 8
Posts: 5

Rep: Reputation: 0
This page was really helpful to me
http://www.saragossa.net/LinuxG3/ls-wlan.shtml

A great alternative to the prism2 driver is the orinoco_cs driver, especially for the Netgear card. You should use the latest version of orinoco_cs if you choose to do that (0.13a or later).
 
Old 02-02-2003, 03:01 PM   #3
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
Hey there.. I also have a Netgear MA401RA card running on RedHat 8.0. This is how you make it work.

Open the file /etc/pcmcia/config

Add these lines to it.. somewhere in the wireless devices section to maintain some consistency.. it's buried around 500 lines or so.

card "Netgear MA401RA"
manfid 0x000b, 0x7300
bind "orinoco_cs"

This assumes you have the orinoco drivers installed and pcmcia installed... most likely you do since I did.

I rebooted but I don't think you have too... Make sure you get two beeps instead of a beep then bonk.

Then goto the Internet Configuration Wizard and add a wireless connection. You should now have the option to chose the Lucent wireless card choice. Use that one.. Set up what device you want to use.. I chose eth1. You should be good to go.

Good luck.

Toppy
 
Old 02-04-2003, 02:14 PM   #4
relictele
LQ Newbie
 
Registered: Feb 2003
Location: WV
Distribution: RedHat 8.0
Posts: 1

Rep: Reputation: 0
De-lurking for a minute to say that this forum, members & information have helped me immensely! I am writing this via RedHat 8.0 with a NetGear MA401RA after dozens of false starts. FWIW The ESSID agreement was a crucial item for me.

I am still curious as to the necessity of /etc/pcmcia/hermes.conf but I am not going to mess with success.
 
Old 02-04-2003, 05:16 PM   #5
turtle
LQ Newbie
 
Registered: Jan 2003
Distribution: redhat 8
Posts: 5

Rep: Reputation: 0
I think the system reads the /etc/pcmcia/config. Inside /etc/pcmcia/config is line that includes other *.conf files in the /etc/pcmcia directory. i.e. "source ./*.conf"

You'd create the hermes.conf file if you didn't want to edit the config file, although you could just as easily use the hermes.conf lines inside the config file.
 
Old 02-06-2003, 01:48 PM   #6
boulanger
LQ Newbie
 
Registered: Feb 2003
Posts: 2

Rep: Reputation: 0
I have an NETGEAR M401 RA.

I installed RH 8.0 on my laptops (an HP)

I read many doc an message and I don't understand why it(s doesn't works.

I have installed the orinoco 0.13 (make + make all)

I modified my file /etc/pcmcia/config (I added my card)

I added eth1 with redhat-config-network.

But When I boot.
I have two bips

In dmesg my card is known

...
hermes.c 4 jul 2002
orinoco_cs 0.13
...
eth1 : Station Identity
...
eth1 : Error -110 writing Tx descriptor to BAP
...


Can you help me ?
 
Old 02-06-2003, 04:08 PM   #7
turtle
LQ Newbie
 
Registered: Jan 2003
Distribution: redhat 8
Posts: 5

Rep: Reputation: 0
Did you select "managed" mode for the card? Selecting "ad-hoc" could cause problems. (Edit the entry for your card under the "Devices" tab in neat, then check the "Wireless Settings" tab.)

Another problem could be the ESSID of your access point.

I'm assuming that you're using DHCP?
 
Old 02-06-2003, 04:39 PM   #8
boulanger
LQ Newbie
 
Registered: Feb 2003
Posts: 2

Rep: Reputation: 0
I tried my thing from two or three weeks and my card work fine on windows without configuration and does'nt work on RH 8.0.

yes I worked with DHCP

can you purpose some step for analyse the pb.

I have next particular message in my dmesg:

eth1 : Error -110 setting multicast list

when I ask
/etc/rc.d/init.d/network restart

for eth1 I have an error and an echec

Where I can define definitevly the ESSID and over eth1 information ?
 
Old 02-17-2003, 03:17 AM   #9
rmartine
Member
 
Registered: Dec 2002
Location: San Luis Obispo, CA
Distribution: Fedora Core 3
Posts: 618

Rep: Reputation: 30
Look in the network configuration thingy. From there you should be able to set the SSID of your network. The error 110 Tx error is a bug somewhere in the firmare of all our cards. The orinoco guys are still pulling their hair out cuz they can't find the problem. No one wants to cooperate with Linux.

Look at the commands iwconfig *I think* or ifconfig. It's something like that. From one of those commands you can set the SSID, channel, freq. etc.

Sorry can't help much more. I got lucky and was able to connect the Netgear card after editing the one config file.
 
Old 03-19-2003, 12:02 AM   #10
CultLdr
LQ Newbie
 
Registered: Mar 2003
Location: Houston
Distribution: RH 8
Posts: 1

Rep: Reputation: 0
re:MA401

This worked great for me, thank you very much for the info. I did have to reboot before it worked but I appreciate you putting this info out there. Now I'm able to get all this done on my wireless net.


Quote:
Originally posted by rmartine
Hey there.. I also have a Netgear MA401RA card running on RedHat 8.0. This is how you make it work.

Open the file /etc/pcmcia/config

Add these lines to it.. somewhere in the wireless devices section to maintain some consistency.. it's buried around 500 lines or so.

card "Netgear MA401RA"
manfid 0x000b, 0x7300
bind "orinoco_cs"

This assumes you have the orinoco drivers installed and pcmcia installed... most likely you do since I did.

I rebooted but I don't think you have too... Make sure you get two beeps instead of a beep then bonk.

Then goto the Internet Configuration Wizard and add a wireless connection. You should now have the option to chose the Lucent wireless card choice. Use that one.. Set up what device you want to use.. I chose eth1. You should be good to go.

Good luck.

Toppy
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Toshiba Satellite, Netgear MA401, Redhat 9 = NOT WORKING UGHGHGH!!!!! chopinpatel Linux - Networking 6 10-21-2003 06:28 AM
RedHat 9 and Netgear MA401 Evan P. Linux - Hardware 2 09-29-2003 11:13 PM
Acessing a VPN in RedHat 8.0 w/Netgear MA401 Card bafraid2b1 Linux - Networking 1 01-28-2003 07:50 AM
RedHat 8.0 with wireless WIFI NETGEAR Card MA401 ... Yumi Linux - Wireless Networking 5 01-25-2003 03:37 AM
Netgear MA401, RedHat 7.3 gig103 Linux - Networking 1 11-27-2002 05:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration