LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 02-11-2003, 10:47 AM   #1
ZhiYi
Member
 
Registered: Feb 2003
Distribution: Redhat
Posts: 30

Rep: Reputation: 15
Question My samba connection does not work! Help!


Hi!
I use realtek ethernet cards to connect 2 redhat linux 8 systems together to form a peer to peer network.
My stats for the first network card are ::
IP add: 169.254.156.54 Mask:255.255.0.0 Bind to MAC add: 00:50:2c:05:98:a9 Host IP add: 127.0.0.1 HostName:localhost.localdomain DNS Hostname:localhost.localdomain

The stats for the 2nd network card are::
IP add:169.254.61.56 Mask:255.255.0.0 Bind to MAC add: 00:50:fc:84:32:56 HostIP add:127.0.0.1 HostName:localhost.localdomain DNS Hostname:localhost.localdomain
I read up on the redhat documentation on samba,followed its instructions and configured the last part of the smb.conf file. The very last section of the file reads as follows after modification:
[sharename]
comment = My stuff
path = /home/share
valid users = ong ocy
public = no
writable = yes
printable = no
create mask = 0765
I only modified the last part of the smb.conf file cos the documentation shows only tis part.

So i logged in as root on both pcs,went to the terminal and typed
smbclient //169.254.61.56/home/share -U ong on one pc. However the following messages appeared:
added interface ip=169.254.156.54 bcast=169.254.255.255 nmask=255.255.0.0
error connecting to 169.254.61.56:139(connection refused)
error connecting to 169.254.61.56(connection refused)
connection to 169.254.61.56 failed
The other pc also showed a similar error message when i tried the connection on the other pc.

Do you know where the problem lies ? Is it because of the configuration of the ethernet cards and the smb.conf or the wrong commands typed ? Please help because i have spent a long time reading the documenation,tinkling with the settings and trying out different commands but to no avail. ( Btw,i think the connection works because i have tried out the ping command )
Please reply quickly if you can.........thanks!! :?:
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
My Internet connection does not work. Help! Cameldriver Linux - Hardware 7 09-28-2006 09:39 AM
Internet connection doesn't work Stevy Linux - Networking 2 09-22-2005 11:37 AM
samba connection error! linuxboy_inside Linux - Networking 3 12-08-2004 11:31 PM
Samba dropping connection Krizzc Linux - Networking 0 10-27-2004 04:54 AM
samba connection history computergeek84 Linux - Networking 2 02-01-2004 07:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration