LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-21-2005, 07:40 AM   #1
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Rep: Reputation: 0
Smile Internet connection problem with Mandrake


Hi I am pradeep,
I am using Mandrakelinux 10.1 official release. Recently i acquire BSNL broadband connection. They tell this ADSL connection they gives me an ADSL modem that connects through my LAN card (Realtek RTL8139 Family PCI Fast Ethernet NIC) by telephone line. BSNL gives me only username and password to activate the connection like dialup. The problem is that after all type of configuration i am not being successful to install the connection on Mandrake. An icon in taskbar shows me the ethernet link is up. I also tried rp-pppoe after configuration it successfully connects my ADSL connection with showing green lights. But when i insert any website address it shows errors like there is no connection. So pls help me to install this connection.
Thanx!
 
Old 07-21-2005, 08:05 AM   #2
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
make sure the /etc/resolv.conf file show correct information abour your DNS, rp-pppoe is maybe just not be set to get DNS information from your ISP.
 
Old 07-22-2005, 09:05 AM   #3
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
Thanx for your reply.
How can i decide the 'DNS' information correct.
the resolv.conf file contains the entry

nameserver 192.168.1.1

Well the output of my ifconfig is following.

eth0 Link encap:Ethernet HWaddr 00:0C:76:C6:78:48
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20c:76ff:fec6:7848/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:788 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1396 (1.3 Kb) TX bytes:48316 (47.1 Kb)
Interrupt:23 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:346 errors:0 dropped:0 overruns:0 frame:0
TX packets:346 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:20278 (19.8 Kb) TX bytes:20278 (19.8 Kb)
Thanx!

Last edited by Pradeep Kashyap; 07-22-2005 at 09:14 AM.
 
Old 07-22-2005, 09:44 AM   #4
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
well 192.168.1.1 mean your "router" is acting as DNS, it could work if the router is then tranfering your request to your ISP.

my guess would be first to change the "192.168.1.1" with your ISP DNS ip (you should have this information somewhere with the papers they gave you when you signed with them, or just call them?) to see if it does any good.

Note : can you tell us more about your network architecture? I mean, is the "192.168.1.2" ip you have is correct? This is a private range, mean you can't browse internet with this, but if you are connecting trought a router (or if your modem act like a DHCP server, mean it connects itself then share the connection to your computer) it could be correct). Some ASCII drawing could help too
 
Old 07-22-2005, 01:19 PM   #5
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
I have no any type of IP on the papers. But currently i am using WindowXP as an alternate for net, is it could help? I am giving you properties that i find in Connection-Status-Details:

Device Name WAN Miniport(PPPOE)
Device type PPPOE
Server type PPP
Transports TCP/IP
Authentication MD5 CHAP
Server IP Address 59.94.105.1 (variable)
Client IP Address 59.94.105.128 (variable)

This modem works as an ADSL modem + router + firewall. And as i told before they gives me only username and password not any ip add. I think system can automatically obtain DNS IP address.
 
Old 07-22-2005, 01:59 PM   #6
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
so on XP you get ip 59.94.105.128? Then there is obliviously something wrong on linux, you modem doesn't connect at all. What's your modem model and what were you using (what application) to connect?
 
Old 07-22-2005, 03:10 PM   #7
eka
Member
 
Registered: Jul 2005
Location: Bulgaria Plovdiv
Distribution: Mandriva 2006
Posts: 104

Rep: Reputation: 15
The easy way is to copy XP settings to Linux.Use manual (not automatic) settings.If it works on XP no reason to not work on Mandrake just you must make it.
 
Old 07-22-2005, 07:22 PM   #8
floppywhopper
Member
 
Registered: Aug 2004
Location: Perth, Western Australia
Distribution: Mageia , SME , IP Fire, LinuxMX
Posts: 637
Blog Entries: 2

Rep: Reputation: 114Reputation: 114
Have you been into the Mandrake Control Centre
and set up networking and internet in there

Can you tell us the brand and model of your modem
is it one of these modems that you set up by connecting to the modem
via a web browser

just guessing
it appears that 59.94.105.128 is the IP address of your modem
I think you need to assign yourself an IP address manually
and then tell mandrake that you connect through the IP address
of the LAN side of the router
which probably should be something like
192.168.0.1

floppy
 
Old 07-23-2005, 01:51 AM   #9
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
1. The Modem model is: UTSTARCOM's UT-300R2 ETHERNET ADSL MODEM
Specifications:

A. ADSL protocols: G.DMT (G.992.1), T1.1413 Issue2, G.Lite(G.992.2)
B. WAN Protocols: RFC 2364(PPPOA), RFC 2516(PPPOE), RFC 1483(BRIDGE&

ROUTING), RFC1577
C. Multi-PVC support, Qos for ATM support
D. Web configuration & Monitor
E. Max Data rate: downstream 8128kbps /upstream 960kbps
.........
For other information access the following link|

http://www.utstar.com/Solutions/CPE/ADSL_CPE/

I am using Konqueror v3.2.3 and Mozilla v1.7.2 for connection.

there is some more information that i found in.

LAN Connection status-Support||-Details*
||(in support tab)
Address type : Assigned by DHCP
IP Address : 192.168.1.2
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.1.1


*(in Details window)
IP Address: 192.168.1.2
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.1.1
DHCP Server: 192.168.1.1
DNS Server: 192.168.1.1

In Broadband connection status that i posted you previous post ip have changed today.
Server IP Address: 59.94.101.1(variable)
Client IP Address: 59.94.101.198(variable)

..........................
..........................

Eka, thanx for reply.

Can u describe this by step by step because i am not new to Linux but yes! very new to networking. There are many steps to configure like DHCP Hostname-Zeroconf. etc. What will i fill in these fields? Please start from New connection link.
...........................
...........................

Floppy! thanx also you for reply

Tell me the process for assign an IP add. manually, and where i use 192.168.0.1?

Newbies notes reply:
Specs: MANDRAKELINUX 10.1 Official release Downloaded version(pri partition).
Installation type: Generic Desktop installation(with all development tools) not any Server entry.
WinXP: XP professional 2002 (sec partition)
Location: India, Delhi(NCR)

Last edited by Pradeep Kashyap; 07-23-2005 at 01:52 AM.
 
Old 07-23-2005, 05:14 AM   #10
floppywhopper
Member
 
Registered: Aug 2004
Location: Perth, Western Australia
Distribution: Mageia , SME , IP Fire, LinuxMX
Posts: 637
Blog Entries: 2

Rep: Reputation: 114Reputation: 114
I don't think this will be too much of a problem
but it may take a little time

first
go into windows
we need to see in network properties or whatever it is in Win XP
what the IP address of your gateway is
and if there is a proxy
what the IP address / port number of that is

you will also need to note anything else in there

floppy
 
Old 07-25-2005, 04:17 AM   #11
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
Well i already posted my XP's connection properties, the changes only in ip Addresses. Today my specs r:

In Broadband connection properties:
Dev name = WAN Miniport (PPPoE)
" Type = PPPoE
Server IP Add = 59.94.105.1
Client IP Add = 59.94.105.206

In LAN connection properties:

IP Add = 192.168.1.2
Subnet Mask = 255.255.255.0
Default Gateway = 192.168.1.1
DHCP Server = 192.168.1.1
DNS Server = 192.168.1.1

Broadband connection is connection that i created from Win's NEW CONNECTION WIZARD.
 
Old 07-25-2005, 05:51 AM   #12
floppywhopper
Member
 
Registered: Aug 2004
Location: Perth, Western Australia
Distribution: Mageia , SME , IP Fire, LinuxMX
Posts: 637
Blog Entries: 2

Rep: Reputation: 114Reputation: 114
Pradeep said
In LAN connection properties:

IP Add = 192.168.1.2
Subnet Mask = 255.255.255.0
Default Gateway = 192.168.1.1
DHCP Server = 192.168.1.1
DNS Server = 192.168.1.1

Now thats what we needed

Go to the Mandrake Control Centre
so
so Main Menu ( yellow star in bottom LH screen )
Go System
Go Configuration
Go Configure your computer
enter Root password
Go "Network & Internet"
Go "New Connection"
Go "Lan Connection"
Select the option of your Lan Card
Select Manual configuration and Go "Next"
Enter your IP address ( 192.168.1.2 )
Enter your Netmask ( 255.255.255.0 )
Go Next
Host Name = What ever your computer is called
DNS Server 1 = 192.168.1.1
Gateway = 192.168.1.1
Go Next
Zeroconf Host name = leave blank & Go "Next"
Next screen will say the network needs to be restarted
do you want that
click yes and go "next"
congratulation screen
click finish
This should set you up

you may need to, in a browser, turn on your internet connection
so you may need to type in the browser address
the IP address ( and port number ) of the modem
and do what you have to do

Hope this helps
floppy

Last edited by floppywhopper; 07-25-2005 at 05:54 AM.
 
Old 07-25-2005, 11:45 AM   #13
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
So Floppy! I did as u told.

But i cudn't undrstnd ip add and port no 'in' browser. Tell me the format.
I tried http://192.168.1.1/eth0/www.yahoo.com
If it is right the error is
404 server not found
cud'nt found requested url: eth0/www.yahoo.com
 
Old 07-25-2005, 06:03 PM   #14
floppywhopper
Member
 
Registered: Aug 2004
Location: Perth, Western Australia
Distribution: Mageia , SME , IP Fire, LinuxMX
Posts: 637
Blog Entries: 2

Rep: Reputation: 114Reputation: 114
Pradeep

I'm not sure what you are trying to do in your last post

did you do everything I said regarding the Mandrake control centre
were there any problems in that

regarding administering your modem
go into win XP
and note down the IP address and port number
of your modem
if and when you have to turn the modem off and on
and connect and disconnect from the internet
from your browser in win XP

if you need to connect to you modem it will be something like
http://192.168.1.1:( port number )
or
https://192.168.1.1:( port number )

hope this helps
floppy
 
Old 07-26-2005, 09:33 AM   #15
Pradeep Kashyap
LQ Newbie
 
Registered: Jul 2005
Location: India
Distribution: Mandrakelinux 10.1
Posts: 14

Original Poster
Rep: Reputation: 0
Sorry! for my Language.

Well as you told after configuration of LAN conn i goes to browser and enter the address with IP address and eth0 (Modem is connected to ethernet port). When i inserted the ip address like this
http://192.168.1.1/ an Log in window opened and ask me for username and password but which username and password i typed in all username as well as root password but error Bad username and password" has shown me. And with http://192.168.1.1/eth0 an occurred 404 not found The requested URL '/eth0' was not found on this server.

2. Will i need to start my adsl connection with this? Although its already started.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10.1 internet connection sharing with windows XP problem dbancajas Linux - Networking 1 07-02-2005 02:51 AM
mandrake internet connection problem emolamol Linux - Wireless Networking 25 01-25-2005 11:22 AM
Mandrake 10.0 internet connection problem mclalan Linux - Networking 1 06-28-2004 06:14 AM
XP/Mandrake 9.2 Internet Connection Sharing problem DoddyUK Linux - Networking 8 05-10-2004 08:35 PM
internet connection problem in mandrake 9.2 djkaat Linux - Networking 1 03-21-2004 05:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration