LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 10-30-2003, 03:06 AM   #1
anGeR
Member
 
Registered: Oct 2003
Distribution: Slackware 13.37
Posts: 40

Rep: Reputation: 15
Smile howto: crossover connection between two linux machines?


Yo ppl!
I've got two linux RH9 machines and I want to make crossover connection between them.
So I want to know what should I do?
I've got two nic's and crossover cable and they are connected. So what services do I need and how to make connection so they can see each other?

I hope that you will help me

thx ppl!
 
Old 10-30-2003, 04:17 AM   #2
Cyclo
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1
Posts: 47

Rep: Reputation: 15
Plug in the hardware, plug in the cables, then (assuming they each only have one network card)

Load the appropriate kernel moduels for the NICs (cant help you there, :google: is your friend)

On first machine:

ifconfig eth0 10.0.0.1

On second machine

ifconfig eth0 10.0.0.2


You can also use 192.168.0.1 and 192.168.0.2 if you feel like it. Then (unless you have strange firewall settings) it should work
 
Old 10-30-2003, 05:22 AM   #3
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
In /etc/modules.conf file you should have a line like this on each machine:
alias eth0 <nic_module>
 
Old 10-30-2003, 10:00 AM   #4
anGeR
Member
 
Registered: Oct 2003
Distribution: Slackware 13.37
Posts: 40

Original Poster
Rep: Reputation: 15
the problem was in crossover cable - it didn't work!
Now everything is ok but there is one problem :
In one machine I've got isdn and lan card and in the other only lan card. Network between them works. But when both (isdn and lan) cards are activated on the first machine I can't connect to internet, while the network between two comps works.
But when I deactivate lan card, connection to internet is back again.
Any ideas how to solve this problem ?

thx on previous answers
 
Old 10-31-2003, 06:15 PM   #5
GJB
LQ Newbie
 
Registered: Oct 2003
Distribution: RedHat 6-9 Gentoo Slackware 9.1
Posts: 26

Rep: Reputation: 15
Seems as though you got a route problem. look at route -n before and after you put up your isdn link ... my best guess is that after you put up the isdn link the default route is pointing to your other machine or something while it shoutd be pointing at ppp0 wich should be your isdn connection.

GJB
 
Old 11-01-2003, 08:08 AM   #6
anGeR
Member
 
Registered: Oct 2003
Distribution: Slackware 13.37
Posts: 40

Original Poster
Rep: Reputation: 15
thx ppl!
I will try those options you gave me and if problem still remains I'll post again
 
Old 09-13-2008, 07:59 AM   #7
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 313

Rep: Reputation: 30
howto: crossover connection between a linux and a Window machine?


It is another newBie question.

What about the crossover connection between a linux and a Window machine?

I connect 2 machines with crossover cable.
Pin 1 to Pin 3
Pin 2 to Pin 6

On window side, the network card icon at bottom right side is ok.

Both machines with static private IP but ping not working, anyone know how to config?


Please help

Last edited by fhleung; 09-13-2008 at 08:01 AM.
 
Old 09-13-2008, 08:08 AM   #8
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 120Reputation: 120
Brought up a 5 year old thread? Newbie isn't the reason!
 
Old 09-28-2008, 04:40 AM   #9
fhleung
Member
 
Registered: Aug 2004
Distribution: Fedora, Debian
Posts: 313

Rep: Reputation: 30
Quote:
Comp A IP= 192.168.1.1
Comp A GW= 192.168.1.100

Comp B IP= 192.168.1.100
Comp B GW= 192.168.1.1
Need to enter DNS ip for window machine side.
 
Old 06-27-2009, 07:51 PM   #10
fakie_flip
Senior Member
 
Registered: Feb 2005
Location: san antonio, texas
Distribution: Fedora 64 bit RAID0 + LUKS, CentOS (server), Backtrack, Gentoo Hardened
Posts: 1,439

Rep: Reputation: 80
Thumbs up

Yes, He brought up a 5 year old thread and ,so am I too. This is why. I found this page through a Google search because I was having a problem connecting two computers together through a network connection with a crossover cable. The point IS that people find these pages through LQ and Google searches looking for answers!

I've done it before. Right now I am doing it between an XP machine and and a Ubuntu machine, both 64-bit. Not only have I got it working that the computers communicate fast through gigabit lan cards on each end, but I am also sharing the internet from the XP machine to the Ubuntu machine using multiple network connections and currently connected to the net with Internet Tethering through a Blackberry Curve which I dialed into as a modem. Okay, let me get to the point. Here was what I forgot to make it work. If you do all the steps but miss one like I did, then it won't work. The trick is doing this.

If on an Ubuntu machine or one with sudo setup similar:

PHP Code:
echo "1" sudo tee /proc/sys/net/ipv4 
OR:

PHP Code:
sudo bash -"echo "1" > /proc/sys/net/ipv4 
If on the majority of linux distros:

PHP Code:
su -
echo 
"1" > /proc/sys/net/ipv4 

Last edited by fakie_flip; 06-27-2009 at 07:56 PM. Reason: forgot code blocks
 
Old 07-07-2013, 04:43 AM   #11
angelo.c
Member
 
Registered: Jul 2011
Location: Hong Kong
Distribution: Slackware 13.1,CentOS 6.4,Fedora 16
Posts: 55

Rep: Reputation: Disabled
Hi fakie_flip!

I came across same issue when setting up 2 computers with crossover cable and it doesn't work as well.

I tried your command echo "1" > /proc/sys/net/ipv4 but it says "/proc/sys/net/ipv4 is a directory.
 
Old 07-08-2013, 10:35 AM   #12
jefro
Guru
 
Registered: Mar 2008
Posts: 10,246

Rep: Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255Reputation: 1255
"the return of the thread"

A nic generally has a way to auto correct for cable type. Crossover or patch is OK as long as one nic can autocorrect.

Problems happen sometimes when nic is powered up with no connection and won't adjust correctly to patch or crossover.

You'd be surprised how many cables are not correct or of a good quality. Use good quality cable and be sure it is current for cards. Cat6 if gig.

Sometimes the auto speed gets out of whack too.

Use network tools to help decide, even looking at lights on nic may help.

Last edited by jefro; 07-09-2013 at 03:20 PM.
 
Old 07-08-2013, 10:41 AM   #13
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-19-live-usb/ aix
Posts: 3,551

Rep: Reputation: 513Reputation: 513Reputation: 513Reputation: 513Reputation: 513Reputation: 513
this is what i did:
http://www.linuxquestions.org/questi...6/#post3804866
 
Old 07-08-2013, 02:15 PM   #14
RootMason
Member
 
Registered: Oct 2012
Location: Tucson, AZ
Distribution: Debian/CentOS
Posts: 123

Rep: Reputation: 5
Gotta laugh at a decade-old question! Kudos to Linux-Questions for being around so long.

I agree with Jefro, most current NICs have the capability to auto-negotiate. Crossover cables should not be necessary.

"... modern implementations of the Ethernet over twisted pair standards usually no longer require the use of crossover cables."

I can agree with Jefro's ideas of snags you might run into, such as problems with autonegotiation, and add one of my own: sticky MACs.
 
Old 07-08-2013, 10:42 PM   #15
angelo.c
Member
 
Registered: Jul 2011
Location: Hong Kong
Distribution: Slackware 13.1,CentOS 6.4,Fedora 16
Posts: 55

Rep: Reputation: Disabled
RootMason,thanks for your reply.

It turns out I mixed up 2 cables with different ethernet cards.

Sorry about that.

Last edited by angelo.c; 07-08-2013 at 10:56 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
internet connection sharing between two computers using crossover cable farnell_mark Debian 1 06-04-2005 04:44 PM
Sharing internet connection between Slackware and XP via crossover cable islord Linux - Networking 3 01-24-2005 10:38 AM
Network connection between Linux/UNIX machines marv77 Linux - Newbie 3 08-13-2004 09:01 AM
Slackware 9, Windows XP, crossover cable and an internet connection dxdad Linux - Networking 37 11-11-2003 08:45 PM
Manage multiple linux-machines through one linux-machine howto ? Satriani Linux - Networking 18 06-10-2003 09:54 AM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration